Wireless configuration after error message

An error message is displayed on console screen after wireless setting.

net.bridge.bridge-nf-call-custom = 0
/etc/rc.common: eval: line 1: =: not found
[20413.270000] hyfi_netlink_receive: 108: hyfi: Not attached to bridge br-lan
Error running command

It looks like a Netfilter issue
I would like to know how to solve it.

What is /sys/class/net/bridge/nf_call_custom?

On my system, I see:

  • nf_call_arptables
  • nf_call_ip6tables
  • nf_call_iptables

And I only see this for each bridge interface...

  • What model device are you using?
1 Like

It looks like a problem with something with your environment or third-party scripts, if /etc/rc.common is erroring out.

hyfi is pretty rare out there, with one of the few references I could find being to a four-year-old git repo https://github.com/qianguozheng/qsdk/tree/master/qca/src

1 Like

From my system config

  • nf_call_arptables
  • nf_call_ip6tables
  • nf_call_iptables
    There are only three.
    How do I check the version?

Can I find a solution?

Version of what?

I asked what device you're using.

1 Like


Qualcomm Atheros AP152 reference board

I guess this is the model name.

1 Like

OK, now that we know the device...the other question is:

I do not see /sys/class/net/bridge/nf_call_custom on my system.

1 Like

I do not know.
My /etc/sysctl.conf
There is no such thing.
But I get an error message

Can you paste the FULL command used to change your wireless setting AND the error message?

Please paste your /etc/config/wireless (be sure to obscure your key).

1 Like

Wireless settings

-> uci set wireless. @ wifi-iface [0] .mode = ap

/ etc / config / wireless

config wifi-device 'wifi0'
        option type 'qcawifi'
        option macaddr '44:d1:fa:25:cd:fe'
        option hwmode '11ng'
        option channel '3'
        option txpower '29'
        option htmode 'HT20'
        option disabled '0'

config wifi-iface
        option device 'wifi0'
        option key '12345678'
        option encryption 'psk2+tkip+ccmp'
        option network 'lan'
        option mode 'sta'
        option ssid 'MAP7000_2G_TEST_0823'
        option wmm '1'
        option wds '1'

config wifi-device 'wifi1'
        option type 'qcawifi'
        option macaddr '44:d1:fa:25:cd:ff'
        option hwmode '11ac'
        option channel '153'
        option disabled '0'

config wifi-iface
        option device 'wifi1'
        option wds '1'
        option network 'lan'
        option encryption 'psk2+tkip+ccmp'
        option key '12345678'
        option mode 'ap'
        option ssid 'MAP7000_JHS_TEST'

Have you simply tried the config using the web GUI?

1 Like

created the web GUI directly in html and configured cgi in C language.

web server is lighttpd.


Are you saying you built your own GUI?!?!

Let's not be difficult, what happened when you used the provided LuCI web GUI?

There is no error message in the existing openwrt web GUI.
Does this issue vary depending on the web GUI?

  • In the future, please inform us you're not using stock/default OpenWrt firmware/software.
  • If the stock web GUI works, then your issue is likely with your CLI entries and custom web GUI, correct?



Yes, I get an error like the picture when I use the web GUI.

I'll try to explain again. I do not see a /cgi-bin/wireset.cgi on my installation of OpenWrt! This appears to be your software - and YOUR issue.

Please consider the For Developers section, or fixing it yourself.

You noted that you're able to configure your wireless using the default LuCI web GUI, please consider marking the appropriate post as the solution.

1 Like

I see your point

Thanks for taking time out from your busy schedule

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.