Wireguard no traffic

i am trying to configure wireguard in openwrt and in my android phone.
unfortunately i cannot anywhere from the phone. Nor to my LAN systems, neither to the Internet.
Some help please

![IMG_20221007_110623|243x500](upload://zHLMP1dItl5xkh0Dr7baWsQzw1T.jpeg)


![router|690x387](upload://zU5k1imRVBpGzeF5N5RI89PbRJ0.png)
**here is my config for firewall**

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'

config zone 'lan'
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'
        list network 'WG_Server'

config zone 'wan'
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        list network 'Modem_Cosmote'
        list network 'WAN_pppoe'
        list network 'wan'

config forwarding 'lan_wan'
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

network


config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdf5:627f:2fff::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.170.1'
        list dns '1.1.1.1'
        list dns '8.8.4.4'


config interface 'wan'
        option proto 'dhcp'
        option device 'eth2'

config interface 'WAN_pppoe'
        option proto 'pppoe'
        option device 'eth1'
        option username 'atuxnull@cosmote.gr'
        option password 'xxxxxxyyyzz'
        option ipv6 '0'
        option peerdns '0'
        list dns '1.1.1.1'
        list dns '8.8.4.4'

config interface 'Modem_Cosmote'
        option proto 'static'
        option ipaddr '192.168.178.5'
        option netmask '255.255.255.0'
        option device 'eth1'

config interface 'WG_Server'
        option proto 'wireguard'
        option private_key 'xxxxyyyyCPSJmiGHR2phCyyyyyy'
        option listen_port '61820'
        list addresses '10.14.0.1/24'

config wireguard_WG_Server
        option description 'Atux'
        option public_key 'aaaaa6iqfmIRpbtbbbb9zwEiYQHhNcccc'
        list allowed_ips '10.14.0.3/32'
        option route_allowed_ips '1'
        option persistent_keepalive '25'

This post was flagged by the community and is temporarily hidden.

that might not be the best of suggestions, openvpn is slower and have a bigger overhead.

1 Like

i would like to stick with Wireguard for this system.

look at Wireguard and clients internet access
No internet access from wireguard clients

or just search the forum for wireguard internet client

Please stop it.

Change the allocated IP on your phone from 10.15.0.3/32 to 10.14.0.3/32.

2 Likes

my mistake. typo into IPs. false alarm. thank you all.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.