Wireguard and storage shared network

hi

i have configured wireguard and work ( after 3 weeks test because i'm noob user but is a secret ) .

wireguard worked but, is not possible lister and show windows or usb router shared storage.

what do you want on file for help me solve this problem ?

thank you

network file :


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '10.0.0.1'
	option ipv6 '0'

config interface 'wan'
	option device 'eth1'
	option proto 'dhcp'
	option ipv6 '0'

config switch
	option name 'switch0'
	option reset '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 4'
	option vid '1'

config interface 'wg0'
	option proto 'wireguard'
	list addresses '10.0.1.1/24'
	option listen_port '56718'
	option private_key 'IAxFXXXXXXXXXXXXXXXXXXXvxKXXXXXXXC3I='

config wireguard_wg0
	option description 'redmiseb'
	option public_key 'ZzK6MBJbcXXXXXXXXXuX/Vz5FyXwzA='
	list allowed_ips '10.0.1.2'

and firewall :

for the storage on router, i'm use KSMBD

[global]
	netbios name = |NAME|
	server string = |DESCRIPTION|
	workgroup = |WORKGROUP|
	interfaces = |INTERFACES|
	bind interfaces only = yes
	ipc timeout = 20
	deadtime = 15
	map to guest = Bad User
#	smb2 max read = 64K
#	smb2 max write = 64K
#	smb2 max trans = 64K
#	cache read buffers = no
#	cache trans buffers = no

may be you have to define interfaces with lan and wg0 and set bind interfaces only to no ?

https://www.samba.org/~tpot/articles/multiple-interfaces.html

https://wiki.samba.org/index.php/Configure_Samba_to_Bind_to_Specific_Interfaces
You may give it a try...

2 Likes

yes, is good,

my new config :

[global]
	netbios name = |NAME|
	server string = |DESCRIPTION|
	workgroup = |WORKGROUP|
        interfaces = br-lan
        interfaces = wg0
	bind interfaces only = no
#	interfaces = |INTERFACES|
#	bind interfaces only = yes
	ipc timeout = 20
	deadtime = 15
	map to guest = Bad User
#	smb2 max read = 64K
#	smb2 max write = 64K
#	smb2 max trans = 64K
#	cache read buffers = no
#	cache trans buffers = no

i have add line for interface, but i'm not sur if nessessary

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.