Wired but WiFi not working 100% on MTK MT7621AT

Hi,
I bought a router two months ago (MTK MT7621AT 802.11AC 1200Mbps 5G Wireless WiFi Gigabit Ethernet OPENWRT 19.07) on AliExpress, I had it setup to use my 4G connection via USB tethering, it was working without a hitch until one day last week it crash on its own accord. I reset it to factory settings and set up 4G tethering again, all good.

The only problem I am having now is with the devices that use WiFi, after a while I need to turn WiFi off and then on again to get Internet working. It's like the OpenWrt router turns off the Internet to WiFi devices after X hours. How can I disable this feature? I'm pretty new to OpenWrt, I don't know if connections should be bridged etc.

BusyBox v1.30.1 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 19.07.2, r10947-65030d81f3
 -----------------------------------------------------
root@OpenWrt:~# ls /etc/config
dhcp      dropbear  firewall  luci      network   rpcd      system    ucitrack  uhttpd    wireless
root@OpenWrt:~# ls /etc/config/network
/etc/config/network
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdbd:c5d5:b1a9::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option netmask '255.255.255.0'
root@OpenWrt:~# ls /etc/config
dhcp      dropbear  firewall  luci      network   rpcd      system    ucitrack  uhttpd    wireless
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdbd:c5d5:b1a9::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	list dns '192.168.1.16'
	option ipaddr '192.168.1.1'
	option gateway '255.255.255.0'
	option broadcast '192.168.1.255'
	option igmp_snooping '1'
	option stp '1'

config device 'lan_eth0_1_dev'
	option name 'eth0.1'
	option macaddr 'd4:ee:07:61:ac:86'

config interface 'wan'
	option proto 'dhcp'
	option ifname 'usb0'
	list dns '192.168.1.16'
	option peerdns '0'
	option type 'bridge'
	option stp '1'

config device 'wan_eth0_2_dev'
	option name 'eth0.2'
	option macaddr 'd4:ee:07:61:ac:87'

config interface 'wan6'
	option ifname 'eth0.2'
	option proto 'dhcpv6'
	list dns '192.168.1.16'
	option reqprefix 'auto'
	option reqaddress 'try'
	option peerdns '0'
	option type 'bridge'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6t'

config interface 'Tethering4G'
	option ifname 'usb0'
	option proto 'dhcp'
	option type 'bridge'
	list dns '192.168.1.16'
	option peerdns '0'

root@OpenWrt:~#

If your network is IPv4 only, remove or disable all IPv6 stuff. In particular remove the DHCPv6 server in /etc/config/dhcp.

You have two networks connected to the 4G modem, there should only be one, suggest deleting 'Tethering4G' and keeping wan.

Make sure it's not a problem with your pihole or whatever other special DNS server you have at 192.168.1.16. Set the DNS server in the wan section only, not in lan.

Hi,
Yes IPv4 only, so I deleted the IPv6. The network only has internet access (so I'm keeping it) via Tethering4G, that connection was the result of following the Smartphone USB tethering tutorial :

The router has a WAN connection on the back of it but since I don't use WAN I deleted the interface for simplicity. So at the moment I just have Tethering4G and LAN interfaces.

Should I include Tethering4G & LAN in one firewall zone?
Also, I need to turn WiFi off & then on again on mobile devices to get Internet access... why is this? It's like there is some kind of polling rate where a device will no longer receive internet access after a set amount of time. I remember doing something about it when I bought the router but forget.

The modem should be in the wan zone so that NAT works properly.

Troubleshoot why the mobile device is showing no internet, it could be

  • lack of connection to the router (ping router LAN IP)
  • inability to DNS (try pinging an Internet site by name vs by number)
  • or the router not routing them to the Internet (can ping router, but can't ping site by number).

oh, i will try to put it in the WAN zone. WAN is kind of confusing when your not using the WAN connection but I guess its describing two networks (the 4G phone and LAN)?

I'm getting full bars in my devices (iPod touch, Windows laptop & Android Tablet) but there is no actual Internet connection, I couldn't ping on the laptop. I just needed to switch off/on WiFi after a session. The DNS is pointing to 192.168.1.16 which is pi-hole but pi-hole not causing any trouble for wired devices and can even speed things up.

There must be some setting on the router, I will try a few things.

I have the same problem with I think is the same hardware (Newifi-D2).

Randomically the wireless connected devices (more often android smartphones rather PC), loos network connectivity even if WiFi conneciton is up.

I need to disconnect-reconnect from the device to restore

Sounds like my recent problem with a certain IoT device connected to my OpenWRT router. The IoT client seems to have buggy power saving behavior messing up the WiFi connection after a few days. For me, the following OpenWRT option seems to have solved it:

option disassoc_low_ack '0'

(the option is also available as clickbox in LuCi somewhere in the advanced wifi section of each radio)

1 Like