Win 10 Static IP drops link with The DHCP Server sent a DHCPNACK

A few weeks back I brought my old WDR3600 from home where it is no longer fast enough to run on my FTTH flashed with 21.02 to my Mum's place to replace her ISP provided years old Netgear router. Got pretty much everything set up.

I've had SSH access to her PC for sometime and use it to tunnel RDP over when I have to remotely sort out things for her. Noticed that after I got back to where I am staying if I did make an SSH connection it dropped after a few minutes, tried from the Wireguard VPN I'd set on the router so effectively I am local and same. Tried RDP from the Wireguard too and that drops at the sametime as the SSH if I have two windows open.

Anyway got back to her house and after checking the event log I see every 3 minutes this warning

The IP address lease for the Network Card with network address 0xD850E64AB4CE has been denied by the DHCP server (The DHCP Server sent a DHCPNACK message

The PC has a static address set in the router with an 8 hour lease time. Setting the address static in Windows stops the drops but not sure what is going on here I suspect Windows, I have the slightly earlier version on my home Pi as a router and 3 devices I can SSH to with no problem but they are all Linux of some description.

Any thoughts? Or just write it off as a MS idiocracy.

1 Like

So you have a working solution! Tell me is there a reason the DHCP on router has to be anything other than infinite ?

config host
	option dns '1'
	option name 'whats4dinner'
	option ip ''
	option leasetime 'infinite'

You can always run a packet capture to check the DHCP packets and find out where the problem is.
opkg update; opkg install tcpdump; tcpdump -i br-lan -evn udp port 67 and ether host MAC_ADDR_OF WIN

What do the logs on the router say?

It was curiosity as to the why of it failing and the small chance it might be a Router bug but 99.9% it is Windows. I'll give it a go switching to infinite, I've left now flying home shortly so will be at some point when I know it is not in use. Prob a day or two until I can check and verify.

The only reference I see to DHCP in the logs is

Thu May 26 08:51:30 2022 dnsmasq-dhcp[13065]: DHCPREQUEST(br-lan) d8:50:e6:4a:b4:ce
Thu May 26 08:51:30 2022 dnsmasq-dhcp[13065]: DHCPACK(br-lan) d8:50:e6:4a:b4:ce Desktop

I did notice going to the DHCP page in the router the desktop shows say 2 mins lease remaining, then when it gets to 1 min reverts back to 2, whereas a mobile that is also registered looks to have a reasonable time but since it is > 4 hours I'll not be able to watch and see,

Sadly no space left, there's only about 250kb spare.

What about tcpdump-mini ?

Did check but not quite enough room even for that. I did wonder about moving some to a USB stick but didn't have room for the drivers but hey it was my spare router retired when my home line went 500mbps and is an upgrade for my Mum.

Switched it as you suggested to infinite and removed the fixed in Windows and all is good. Don't know if it is a problem with Win10 generally or maybe her Network card.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.