Will adblock work on OpenWrt repeater

Before I spend weeks or months researching, can someone tell me will adblock work on an OpenWRT repeater setup? I travel and never have access to the actual routers and wish to block ads. If it does work, has anyone ever seen a link pointing to a complete cookbook for setting it up? My experience with OpenWRT is not to the level of understand dns masquerade, etc. Thanks.

1 Like

It will, as long as you use the device's IP as your DNS server.

Not sure what this means.

You install it:

#FOR ADBLOCKING INSTALL: adblock luci-app-adblock libustream-mbedtls libmbedtls

You then browse to the AdBlock page:

  • enable it
  • use uclient-fetch
  • select the blocklist sources you wish to use
  • reload AdBlock or reboot router
  • DONE!

Thank you very much .... I cannot find an option for uclient-fetch. I do see a box which offers "Force Local DNS", should that one be checked? Thanks

I have not used it, there are some threads on how this feature works. I'm not sure how it would function in your "repeater" setup.

I simply make sure all my devices use that DNS server (since it's necessary for local hostname resolutions anyways).

Please post the output of:

opkg list-installed | grep -E "^luci|^adblock"
ubus call system board

If you use your router as a travel router/routed client then "Yes" - but it's optional.

1 Like

I cannot find an option for uclient-fetch. I do see a box which offers "Force Local DNS"

I think you might just be looking in the wrong area, scroll up a bit and look in the dropdown menu for Download Utility.

1 Like

On the top I have Status, System Services, Network, Logout

When I open Services, Adblock I have only 3 tabs which say
Overview, View logfile, Advanced

There are no other drop-down boxes that I see.

Screenshot%20from%202018-09-04%2017-12-40


root@GL-AR300M:~# opkg list-installed | grep -E "^luci|^adblock"
adblock - 2.6.2-1
luci - git-17.290.79498-d3f0685-1
luci-app-adblock - git-17.290.79498-d3f0685-1
luci-app-dns-forwarder - 1.6.1-1
luci-app-firewall - git-17.290.79498-d3f0685-1
luci-app-mwan3 - 1.4-5
luci-app-qos - git-17.290.79498-d3f0685-1
luci-app-samba - git-17.290.79498-d3f0685-1
luci-app-shadowsocks - 1.8.2-1
luci-app-upnp - git-17.290.79498-d3f0685-1
luci-base - git-17.290.79498-d3f0685-1
luci-lib-ip - git-17.290.79498-d3f0685-1
luci-lib-json - git-17.290.79498-d3f0685-1
luci-lib-jsonc - git-17.290.79498-d3f0685-1
luci-lib-nixio - git-17.290.79498-d3f0685-1
luci-mod-admin-full - git-17.290.79498-d3f0685-1
luci-mod-rpc - git-17.290.79498-d3f0685-1
luci-proto-3g - git-17.290.79498-d3f0685-1
luci-proto-ipv6 - git-17.290.79498-d3f0685-1
luci-proto-ppp - git-17.290.79498-d3f0685-1
luci-theme-bootstrap - git-17.290.79498-d3f0685-1
root@GL-AR300M:~#
root@GL-AR300M:~# ubus call system board
{
        "kernel": "4.4.92",
        "hostname": "GL-AR300M",
        "system": "Qualcomm Atheros QCA9533 ver 2 rev 0",
        "model": "GL-AR300M",
        "board_name": "gl-ar300m",
        "release": {
                "distribution": "LEDE",
                "version": "17.01.4",
                "revision": "r3560-79f57e422d",
                "codename": "reboot",
                "target": "ar71xx\/nand",
                "description": "LEDE Reboot 17.01.4 r3560-79f57e422d"
        }
}
root@GL-AR300M:~#

Provide results of /etc/init.d/adblock status

Now I rebooted for the third time and found that Adbloc did not save to be enabled. When I clicked it and saved again, now I do get the
I see now, there is no selection for the Download Utility (SSL Library) because now, the words "uclient - fetch" do exist here but it is the default option as there is no drop down box with any other slections.

plus I receive:

For SSL protected blocklist sources you need a suitable SSL library, e.g. 'libustream-ssl' or the wget 'built-in'.

This is why I noted:

Install all packages:

opkg update
opkg install adblock luci-app-adblock libustream-mbedtls libmbedtls

I ran each one of those individually and each one said they were up to date which would indicate they were already installed.

Now after I rebooted once again, under each topic under "Runtime Information" (Status, Adblock, etc) each line is followed by in blue type the letters "n/a".

Do you have an IP, DNS server and Gateway assigned to the interface (so it can download)?

Uninstalled first adblock, then luci-app-adblock and then I re-installed adblock and then luci-app-adblock. Now all the n/a entries have gone away but still the entry for "Download Utility (SSL library) has an entry field and not editable drop down box, the non-changeable entry listed says that the default option selected is "uclient - fetch (libustream-ssl)

1 Like

It should look like this.

Screenshot%20from%202018-09-04%2017-42-57

Feel free to screenshot if needed.

requires libustream-mbedtls to be installed (or libustream-openssl or libustream-wolfssl).

1 Like

The Internet source for this router is a Alfa USB device which is configured as client and then I did a SCAN of available networks, and then a JOIN of a known network and entered the Passcode. This is the supplied source of Internet, the client side of the router. The OPKG commands work great in this environment. I haven't tried a WGET of anything, however.

Everything is going through this router with the client pulling in the local wifi and re-transmitting it to my laptop. I can do everything, watch movies, all on the laptop going through this OpenWRT configured as repeater.

1 Like
root@GL-AR300M:~# /etc/init.d/adblock status
::: adblock runtime information
 status          : active
 adblock_version : 2.6.2
 blocked_domains : 4063
 fetch_info      : uclient-fetch (libustream-ssl)
 dns_backend     : dnsmasq
 last_rundate    : 04.09.2018 16:34:25
 system          : LEDE Reboot 17.01.4 r3560-79f57e422d
root@GL-AR300M:~#
1 Like

:smile:

It appears to be running. Visit: https://ads-blocker.com/testing/