Wifi up and running no internet

I have a Laguna GW2382 board. Trying to connect wireless to a modem. wi-fi is enabled on my laguna board and but I cannot connect to the internet. below are some settings. Have seen similar problems on the forum but none have solved my issue.

Any help appreciated

config wifi-device 'radio0'
option type 'mac80211'
option channel '11'
option phy 'phy0'
option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
list ht_capab 'LDPC'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'TX-STBC'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option hwmode '11g'
option country 'IE'
option htmode 'HT20'
option txpower '28'

config wifi-iface
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'OpenWrtGateworks'
option encryption 'none'
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option ifname 'eth0'
option force_link '1'
option macaddr '20:28:18:a1:04:4a'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.2'
option netmask '255.255.255.0'
option ip6assign '60'
option gateway '192.168.1.1'

config interface 'wwan'
option proto 'dhcp'
option ipaddr '192.168.1.12'
option netmask '255.255.255.0'

With that configuration, your Laguna GW2372 is behaving as an access point for other devices to connect to it. If you want it to be a wireless client to connect to a different access point then you'll need to change the configuration.

You have the LAN and the WWAN on the same subnet. Change the IP of one of the routers to from 192.168.1.x to 192.168.2.x

And you shouldn't normally need to put in default gateway manually unless you have a reason.

Tried that didn't work.
The board is getting assigned an IP address automatically from the DHCP server of
192.168.1.100

Change the IP of the LAN interface.