WiFi on x86 - can't get it to work

Hi, recently installed openwrt on a new GK35 mini PC.
this device has built in WiFi/BT, but it's not detected.
running lspci I get:

01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 11)
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac PCIe Wireless Network Adapter

and a google search didn't come up with much on the RTL8821CE.
I tried installing kmod-rtl8821ae but the wifi device is still not detected (iw list returns empty).

am I missing something?

That's not a supported chip. Generally the OpenWrt wifi drivers are from the mainline kernel, which doesn't include this chip.


I see.
and what about this?

can we get a working driver from there?

Question is if you can...

I can try, but I have no idea what to do really.
as that repo is for linux drivers, I thought the road might be short to bring it to openwrt.
how can I go about that?

There is no road with Realtek wifi drivers…
you'd first have to carve into the mountains, before building one yourself, uphill in the snow, both ways.

Really, the vendors drivers are… not very useful [imagine a number of colourful expletives] and unsuitable for AP mode.