Wifi Mesh & Mesh11sd Questions

I have a two separate mesh setups at different locations. One is a five node mesh, a portal for gateway nodes. This was originally a power-line LAN setup of a router and four wireless points.

I switched over to a mesh over a year ago largely using the instructions provided by OneMarkFifty here: https://youtu.be/vVoZppb_FR0. Originally it was a TP-Link C7 based network but I found they were not quite up to the task. My biggest problem is that the wireless transmitters would shut down and need to be restarted. This was particularly true of the Portal.

I've since switched ot Linksys EA8300 routers and these run reliably for days on end. As a note, I used to run Mesh11sd v2.X but with the advent of 3.X, I had to give up on that for awhile.

This is a simplified diagram of the mesh. I have a number of physical constraints on where the routers are located so for now, the portal is located on one end of the building. The dark arrows are the primary paths of communications and the gray arrows are a secondary paths. I've set the RSSI thresholds to ignore weaker signals on each router individually.


Here's my first question: When I am logged into L2B, I can ping and login all of the other routers with the exception of L1B. If I move to L1B, I can reach all of the other routers including L2B

Is this normal? If a node is getting to the portal through an intermediate node, it's not possible to connect to that intermediate node?

Without setting the required HWMP mesh parameters, things will be very indeterminate. The problem is, these parameters cannot be set in the wireless config. This is where mesh11sd comes in.
Unfortunately, v3 of mesh11sd had a bug that made it do some auto-config even when auto-config was turned off. All fixed in v4 onwards.

Without mesh11sd, only single hop links will have any sort of reliability and even then can often be problematic.
I have a sneaky feeling that all your nodes can talk directly with L1A despite your carefully crafted rssi settings - rssi_threshold only applies at the instant of a connection attempt. If signal reflections/multipaths that are typical indoors result in a brief high signal, a node may connect and stay connected when the signal goes back to "normal".

If it works well enough for you, then fine, otherwise go back to mesh11sd (currently v4.0.1).

Thanks for your reply. One of the challenges I have is that this mesh setup is 45 minutes from where I live and it is setup for a charity group where I volunteer. There is no one on site who is technical and when I leave for the day, I need something more or less rock solid before I leave. I currently only visit about twice a month.

One of the items that I stumbled upon in setting up this mesh was that I am using the portal as a DHCP server to assign fixed addresses to the gateways and I quickly found they were all using the same MAC address. I fixed this by assigning each station a unique MAC address for the mesh. I later found out that the Hybrid Wireless Mesh Protocol protocol is based on ISO level 2 (based on MAC addresses).

I found that mesh11sd v3.11 made these MAC addresses random with auto-config set to off.

You mention setting the required HWMP mesh parameters. I'm assuming some of these are in the LUCI interface under advanced. I've been using the defaults which I assume are shown as light grey in the boxes.

As all the nodes are stationary, is there a way to manually optimize HWMP parameters that can be written to the wireless file? Also, if the additional HWMP parameters cannot be written to the configuration files, how is mesh11sd communicating these to the 802.11s firmware driver?

Does mesh11sd v4.0.1 with autoconfig set to off respect a manually set MAC address for the mesh channel of the router?

May I ask why is this? It this a short coming in 80.11s or the implementation in OpenWRT? Would implementing B.A.T.M.A.N. be an alternative solution to this routing issue between mesh nodes?

No. This is because this has to be set up after the mesh interface has come up and established. The contents of the wireless config are acted upon to start up wireless interfaces, so almost all mesh parameters set there will be ignored.

You can "set" some there and the predecessor to mesh11sd would pick them up, but the normal wireless interface startup does not / cannot use them.

It is using Linux utilites such as iw and ip to dynamically set and adjust things as required.

Yes, but it is essential the you set the mesh interface mac to a unique value.

In auto_config mode it will do this for you.

As I mentioned above, required mesh parameters can only be set after the mesh interface has come up. This is not a shortcoming in 802.11s, it is the way it works.
The implementation in OpenWrt is provided by the mesh11sd package.

You are only getting a "routing issue" because you have not configured it correctly after insisting on manually configuring.

Yes, you could use batman-adv instead of mesh11sd, but then you would have to configure that correctly too, and it is much more complex as it tunnels all your traffic over ipv6....