WiFi issues on WRT3200ACM

I initially installed OpenWRT on my WRT3200ACM because I was experiencing WiFi connection issues and I wanted the ability to perform scheduled reboots. After I installed OpenWRT, I put in a cron job to reboot the router every morning at 4:30AM. Oddly, it still has the exact same problem that the stock firmware did: the WiFi connection is intermittent. Even with the scheduled reboots, it's down most evenings for at least an hour or two. Sometimes it comes back on its own. Sometimes it doesn't. Sometimes a reboot helps. Sometimes it doesn't.

Performance via the wired Ethernet connections has always worked fine during these periods.

Any ideas what I should be looking for? I have browsed the system log and don't see any patterns during the times of connection troubles. My firmware version is OpenWrt 18.06.2 r7676-cddd7b4c77.

I'm thinking that the problem might not be in the router itself but in some other device causing interference on the network. It just seems weird that the same thing was happening with stock firmware AND that reboots don't always fix the problem. If so, how would I troubleshoot that?

Quick question:
Is it the 5GHz band, that is causing trouble?
Remember, that 5GHz is also used for some sort of Radar and if you are using channels which are occupied once in a while from the radar, your Wi-Fi will go down (or switch channels, not sure about that).
As a reference, please use this wikipedia articel and take a look, whether you are using channels, which are used from DFS as well.

Otherwise, I would use logread to see what's happening exactly when the Wi-Fi goes down.

I hope it helps.

1 Like

Thanks for the reply. The issue definitely occurs on the 2.4GHz band, but I'm not sure if it also happens on the 5GHz band.

2.4GHz devices (e.g. my Roomba or Ecobee) can't talk to the Internet. My iPhone, which supports both 2.4GHz and 5GHz, and has both networks set up, stays on the 2.4GHz network, but can't get to the Internet. I usually manually turn off WiFi to start using it again over 3G. I have not tried manually kicking it over to the 5GHz antenna to see if that works, but I will try that next time the network seems to be down.

logread seems to give the same results as looking at the System Log through the LuCI? I don't see anything enlightening there, but I don't know what I'm looking for. Any ideas of what I should look for?

For me it sounds like you haven't assigned the Wi-Fi interfaces to any zone.
Could you please check, whether a (and the proper one for your environment) zone is assigned to your Wi-Fi interfaces?

This can be looked up here:

Can you verify whether your wifi works at all - I mean, are you sure, it works once in a while?

Please post the outputs of logread as well as cat /etc/config/network and cat /etc/config/wireless - I might be able to help (cannot promise however!).

EDIT: Another issue could be that the firewall rules in place are incorrect.
Could you please also give me the output of iptables-save?
Thanks.

In the default / vanilla installation of OpenWRT, it created an interface called "LAN" and assigned eth0.1 (the hard-wire Ethernet ports) to it. I added radio0 and radio1 (the 5 GHz and 2.4GHz antennas) to this interface. Accordingly, regardless of whether you plug in or which WiFi you use, it "feels" like you're on the same network segment.

Everything is definitely working right now. FWIW, I titled my SSID as YoYo (because it goes up and down)... got to have a sense of humor. Will post the rest of the files you requested shortly.

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd24:2c8b:00a1::/48'

config interface 'lan'
option type 'bridge'
option ifname 'eth0.1'
option proto 'static'
option netmask '255.255.255.0'
option ip6assign '60'
option ipaddr '192.168.2.1'

config interface 'wan'
option ifname 'eth1.2'
option proto 'dhcp'
option hostname 'OpenWRT'

config interface 'wan6'
option ifname 'eth1.2'
option proto 'dhcpv6'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0 1 2 3 5t'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '4 6t'

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
option type 'mac80211'
option channel '36'
option hwmode '11a'
option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
option htmode 'VHT80'
option country 'US'
option legacy_rates '1'

config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option encryption 'psk2'
option key 'xxxxxxxxxx'
option ssid 'YoYo_5GHz'

config wifi-device 'radio1'
option type 'mac80211'
option channel '11'
option hwmode '11g'
option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
option htmode 'HT20'
option country 'US'
option legacy_rates '1'

config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid 'YoYo'
option encryption 'psk2'
option key 'xxxxxxxxxx'

config wifi-device 'radio2'
option type 'mac80211'
option hwmode '11a'
option path 'platform/soc/soc:internal-regs/f10d8000.sdhci/mmc_host/mmc0/mmc0:0001/mmc0:0001:1'
option htmode 'VHT80'
option country 'US'
option legacy_rates '1'
option channel 'auto'

config wifi-iface 'default_radio2'
option device 'radio2'
option network 'lan'
option mode 'ap'
option encryption 'none'
option disabled '1'
option ssid 'DisabledAllTheTime'

root@OpenWrt:~# iptables-save

Generated by iptables-save v1.6.2 on Thu May 30 15:05:18 2019

*nat
:PREROUTING ACCEPT [18816:2563696]
:INPUT ACCEPT [7817:1142667]
:OUTPUT ACCEPT [10973:749845]
:POSTROUTING ACCEPT [2873:209198]
:postrouting_lan_rule - [0:0]
:postrouting_rule - [0:0]
:postrouting_wan_rule - [0:0]
:prerouting_lan_rule - [0:0]
:prerouting_rule - [0:0]
:prerouting_wan_rule - [0:0]
:zone_lan_postrouting - [0:0]
:zone_lan_prerouting - [0:0]
:zone_wan_postrouting - [0:0]
:zone_wan_prerouting - [0:0]
-A PREROUTING -m comment --comment "!fw3: Custom prerouting rule chain" -j prerouting_rule
-A PREROUTING -i br-lan -m comment --comment "!fw3" -j zone_lan_prerouting
-A PREROUTING -i eth1.2 -m comment --comment "!fw3" -j zone_wan_prerouting
-A POSTROUTING -m comment --comment "!fw3: Custom postrouting rule chain" -j postrouting_rule
-A POSTROUTING -o br-lan -m comment --comment "!fw3" -j zone_lan_postrouting
-A POSTROUTING -o eth1.2 -m comment --comment "!fw3" -j zone_wan_postrouting
-A zone_lan_postrouting -m comment --comment "!fw3: Custom lan postrouting rule chain" -j postrouting_lan_rule
-A zone_lan_prerouting -m comment --comment "!fw3: Custom lan prerouting rule chain" -j prerouting_lan_rule
-A zone_wan_postrouting -m comment --comment "!fw3: Custom wan postrouting rule chain" -j postrouting_wan_rule
-A zone_wan_postrouting -m comment --comment "!fw3" -j MASQUERADE
-A zone_wan_prerouting -m comment --comment "!fw3: Custom wan prerouting rule chain" -j prerouting_wan_rule
COMMIT

Completed on Thu May 30 15:05:18 2019

Generated by iptables-save v1.6.2 on Thu May 30 15:05:18 2019

*mangle
:PREROUTING ACCEPT [2172390:1137022403]
:INPUT ACCEPT [186919:19171226]
:FORWARD ACCEPT [1982086:1116905741]
:OUTPUT ACCEPT [188707:33658311]
:POSTROUTING ACCEPT [2169594:1150518415]
-A FORWARD -o eth1.2 -p tcp -m tcp --tcp-flags SYN,RST SYN -m comment --comment "!fw3: Zone wan MTU fixing" -j TCPMSS --clamp-mss-to-pmtu
COMMIT

Completed on Thu May 30 15:05:18 2019

Generated by iptables-save v1.6.2 on Thu May 30 15:05:18 2019

*filter
:INPUT ACCEPT [0:0]
:FORWARD DROP [0:0]
:OUTPUT ACCEPT [0:0]
:forwarding_lan_rule - [0:0]
:forwarding_rule - [0:0]
:forwarding_wan_rule - [0:0]
:input_lan_rule - [0:0]
:input_rule - [0:0]
:input_wan_rule - [0:0]
:output_lan_rule - [0:0]
:output_rule - [0:0]
:output_wan_rule - [0:0]
:reject - [0:0]
:syn_flood - [0:0]
:zone_lan_dest_ACCEPT - [0:0]
:zone_lan_forward - [0:0]
:zone_lan_input - [0:0]
:zone_lan_output - [0:0]
:zone_lan_src_ACCEPT - [0:0]
:zone_wan_dest_ACCEPT - [0:0]
:zone_wan_dest_REJECT - [0:0]
:zone_wan_forward - [0:0]
:zone_wan_input - [0:0]
:zone_wan_output - [0:0]
:zone_wan_src_REJECT - [0:0]
-A INPUT -i lo -m comment --comment "!fw3" -j ACCEPT
-A INPUT -m comment --comment "!fw3: Custom input rule chain" -j input_rule
-A INPUT -m conntrack --ctstate RELATED,ESTABLISHED -m comment --comment "!fw3" -j ACCEPT
-A INPUT -p tcp -m tcp --tcp-flags FIN,SYN,RST,ACK SYN -m comment --comment "!fw3" -j syn_flood
-A INPUT -i br-lan -m comment --comment "!fw3" -j zone_lan_input
-A INPUT -i eth1.2 -m comment --comment "!fw3" -j zone_wan_input
-A FORWARD -m comment --comment "!fw3: Custom forwarding rule chain" -j forwarding_rule
-A FORWARD -m conntrack --ctstate RELATED,ESTABLISHED -m comment --comment "!fw3" -j ACCEPT
-A FORWARD -i br-lan -m comment --comment "!fw3" -j zone_lan_forward
-A FORWARD -i eth1.2 -m comment --comment "!fw3" -j zone_wan_forward
-A FORWARD -m comment --comment "!fw3" -j reject
-A OUTPUT -o lo -m comment --comment "!fw3" -j ACCEPT
-A OUTPUT -m comment --comment "!fw3: Custom output rule chain" -j output_rule
-A OUTPUT -m conntrack --ctstate RELATED,ESTABLISHED -m comment --comment "!fw3" -j ACCEPT
-A OUTPUT -o br-lan -m comment --comment "!fw3" -j zone_lan_output
-A OUTPUT -o eth1.2 -m comment --comment "!fw3" -j zone_wan_output
-A reject -p tcp -m comment --comment "!fw3" -j REJECT --reject-with tcp-reset
-A reject -m comment --comment "!fw3" -j REJECT --reject-with icmp-port-unreachable
-A syn_flood -p tcp -m tcp --tcp-flags FIN,SYN,RST,ACK SYN -m limit --limit 25/sec --limit-burst 50 -m comment --comment "!fw3" -j RETURN
-A syn_flood -m comment --comment "!fw3" -j DROP
-A zone_lan_dest_ACCEPT -o br-lan -m comment --comment "!fw3" -j ACCEPT
-A zone_lan_forward -m comment --comment "!fw3: Custom lan forwarding rule chain" -j forwarding_lan_rule
-A zone_lan_forward -m comment --comment "!fw3: Zone lan to wan forwarding policy" -j zone_wan_dest_ACCEPT
-A zone_lan_forward -m conntrack --ctstate DNAT -m comment --comment "!fw3: Accept port forwards" -j ACCEPT
-A zone_lan_forward -m comment --comment "!fw3" -j zone_lan_dest_ACCEPT
-A zone_lan_input -m comment --comment "!fw3: Custom lan input rule chain" -j input_lan_rule
-A zone_lan_input -m conntrack --ctstate DNAT -m comment --comment "!fw3: Accept port redirections" -j ACCEPT
-A zone_lan_input -m comment --comment "!fw3" -j zone_lan_src_ACCEPT
-A zone_lan_output -m comment --comment "!fw3: Custom lan output rule chain" -j output_lan_rule
-A zone_lan_output -m comment --comment "!fw3" -j zone_lan_dest_ACCEPT
-A zone_lan_src_ACCEPT -i br-lan -m conntrack --ctstate NEW,UNTRACKED -m comment --comment "!fw3" -j ACCEPT
-A zone_wan_dest_ACCEPT -o eth1.2 -m conntrack --ctstate INVALID -m comment --comment "!fw3: Prevent NAT leakage" -j DROP
-A zone_wan_dest_ACCEPT -o eth1.2 -m comment --comment "!fw3" -j ACCEPT
-A zone_wan_dest_REJECT -o eth1.2 -m comment --comment "!fw3" -j reject
-A zone_wan_forward -m comment --comment "!fw3: Custom wan forwarding rule chain" -j forwarding_wan_rule
-A zone_wan_forward -p esp -m comment --comment "!fw3: Allow-IPSec-ESP" -j zone_lan_dest_ACCEPT
-A zone_wan_forward -p udp -m udp --dport 500 -m comment --comment "!fw3: Allow-ISAKMP" -j zone_lan_dest_ACCEPT
-A zone_wan_forward -m conntrack --ctstate DNAT -m comment --comment "!fw3: Accept port forwards" -j ACCEPT
-A zone_wan_forward -m comment --comment "!fw3" -j zone_wan_dest_REJECT
-A zone_wan_input -m comment --comment "!fw3: Custom wan input rule chain" -j input_wan_rule
-A zone_wan_input -p udp -m udp --dport 68 -m comment --comment "!fw3: Allow-DHCP-Renew" -j ACCEPT
-A zone_wan_input -p icmp -m icmp --icmp-type 8 -m comment --comment "!fw3: Allow-Ping" -j ACCEPT
-A zone_wan_input -p igmp -m comment --comment "!fw3: Allow-IGMP" -j ACCEPT
-A zone_wan_input -m conntrack --ctstate DNAT -m comment --comment "!fw3: Accept port redirections" -j ACCEPT
-A zone_wan_input -m comment --comment "!fw3" -j zone_wan_src_REJECT
-A zone_wan_output -m comment --comment "!fw3: Custom wan output rule chain" -j output_wan_rule
-A zone_wan_output -m comment --comment "!fw3" -j zone_wan_dest_ACCEPT
-A zone_wan_src_REJECT -i eth1.2 -m comment --comment "!fw3" -j reject
COMMIT

Completed on Thu May 30 15:05:18 2019

The files you requested are listed above.

I'm not including logread results at this time because it doesn't show anything interesting right now. When I reboot the router, it clears out all the old log info, so all it shows right now is the router being booted and starting up, it shows a few devices getting DHCP renewals, and it shows me logging in. After the next time it goes down, I will get in and see what it says.

So the Internet just went down and I was able to confirm that the 5GHz band seems to work and it appears to be only the 2GHz band with issues. Here's the System Log for the past few hours. See anything noteworthy?

Thu May 30 11:49:09 2019 daemon.info dnsmasq-dhcp[2903]: DHCPREQUEST(br-lan) 192.168.2.73 fc:a6:67:87:99:56
Thu May 30 11:49:09 2019 daemon.info dnsmasq-dhcp[2903]: DHCPACK(br-lan) 192.168.2.73 fc:a6:67:87:99:56 amazon-5e716eb84
Thu May 30 12:02:34 2019 daemon.info dnsmasq-dhcp[2903]: DHCPREQUEST(br-lan) 192.168.2.83 f0:03:8c:b1:1e:49
Thu May 30 12:02:34 2019 daemon.info dnsmasq-dhcp[2903]: DHCPACK(br-lan) 192.168.2.83 f0:03:8c:b1:1e:49 Roomba-6977832021215560
Thu May 30 12:03:28 2019 daemon.warn odhcpd[1777]: DHCPV6 RENEW IA_NA from 0003000148ba4e6e6dc8 on br-lan: ok 2601:19b:4500:d2f1::499/128 fd24:2c8b:a1::499/128
Thu May 30 12:03:29 2019 daemon.info dnsmasq-dhcp[2903]: DHCPREQUEST(br-lan) 192.168.2.8 d8:0d:17:2b:63:f8
Thu May 30 12:03:29 2019 daemon.info dnsmasq-dhcp[2903]: DHCPACK(br-lan) 192.168.2.8 d8:0d:17:2b:63:f8 HS220
Thu May 30 12:03:30 2019 daemon.warn odhcpd[1777]: DHCPV6 RENEW IA_NA from 0003000100113216a9c5 on br-lan: ok 2601:19b:4500:d2f1::17d/128 fd24:2c8b:a1::17d/128
Thu May 30 12:03:33 2019 daemon.info dnsmasq-dhcp[2903]: DHCPREQUEST(br-lan) 192.168.2.52 d8:0d:17:b7:e6:03
Thu May 30 12:03:33 2019 daemon.info dnsmasq-dhcp[2903]: DHCPACK(br-lan) 192.168.2.52 d8:0d:17:b7:e6:03 HS200
Thu May 30 12:03:38 2019 daemon.info dnsmasq-dhcp[2903]: DHCPREQUEST(br-lan) 192.168.2.24 48:ba:4e:6e:6d:c7
Thu May 30 12:03:38 2019 daemon.info dnsmasq-dhcp[2903]: DHCPACK(br-lan) 192.168.2.24 48:ba:4e:6e:6d:c7 HP48BA4E6E6DC7
Thu May 30 12:03:40 2019 daemon.info dnsmasq-dhcp[2903]: DHCPREQUEST(br-lan) 192.168.2.75 b8:a1:75:d9:2e:32
Thu May 30 12:03:40 2019 daemon.info dnsmasq-dhcp[2903]: DHCPACK(br-lan) 192.168.2.75 b8:a1:75:d9:2e:32
Thu May 30 12:03:53 2019 daemon.info dnsmasq-dhcp[2903]: DHCPREQUEST(br-lan) 192.168.2.91 1c:4d:70:1b:8b:54
Thu May 30 12:03:53 2019 daemon.warn dnsmasq-dhcp[2903]: Ignoring domain utcaus.com for DHCP host name AI228831
Thu May 30 12:03:53 2019 daemon.info dnsmasq-dhcp[2903]: DHCPACK(br-lan) 192.168.2.91 1c:4d:70:1b:8b:54 AI228831
Thu May 30 12:03:58 2019 daemon.warn odhcpd[1777]: DHCPV6 RENEW IA_NA from 000100011fbd27c3a44cc81df0b5 on br-lan: ok 2601:19b:4500:d2f1::5a1/128 fd24:2c8b:a1::5a1/128
Thu May 30 12:04:02 2019 daemon.info dnsmasq-dhcp[2903]: DHCPREQUEST(br-lan) 192.168.2.57 50:f5:da:94:62:27
Thu May 30 12:04:02 2019 daemon.info dnsmasq-dhcp[2903]: DHCPACK(br-lan) 192.168.2.57 50:f5:da:94:62:27
Thu May 30 12:30:13 2019 kern.debug kernel: [23246.714722] ieee80211 phy0: staid 3 deleted
Thu May 30 12:30:13 2019 daemon.info hostapd: wlan0: STA 38:71:de:d4:bf:e9 IEEE 802.11: associated (aid 3)
Thu May 30 12:30:13 2019 daemon.notice hostapd: wlan0: AP-STA-CONNECTED 38:71:de:d4:bf:e9
Thu May 30 12:30:13 2019 daemon.info hostapd: wlan0: STA 38:71:de:d4:bf:e9 WPA: pairwise key handshake completed (RSN)
Thu May 30 12:30:13 2019 daemon.info dnsmasq-dhcp[2903]: DHCPREQUEST(br-lan) 192.168.2.56 38:71:de:d4:bf:e9
Thu May 30 12:30:13 2019 daemon.info dnsmasq-dhcp[2903]: DHCPACK(br-lan) 192.168.2.56 38:71:de:d4:bf:e9 iPhone
Thu May 30 12:30:14 2019 daemon.info hostapd: wlan0: STA 38:71:de:d4:bf:e9 IEEE 802.11: authenticated
Thu May 30 12:30:15 2019 daemon.info dnsmasq-dhcp[2903]: DHCPREQUEST(br-lan) 192.168.2.56 38:71:de:d4:bf:e9
Thu May 30 12:30:15 2019 daemon.info dnsmasq-dhcp[2903]: DHCPACK(br-lan) 192.168.2.56 38:71:de:d4:bf:e9 iPhone
Thu May 30 12:30:18 2019 daemon.info dnsmasq-dhcp[2903]: DHCPREQUEST(br-lan) 192.168.2.56 38:71:de:d4:bf:e9
Thu May 30 12:30:18 2019 daemon.info dnsmasq-dhcp[2903]: DHCPACK(br-lan) 192.168.2.56 38:71:de:d4:bf:e9 iPhone
Thu May 30 12:30:18 2019 daemon.warn odhcpd[1777]: DHCPV6 SOLICIT IA_NA from 000100011efec2163871ded4bfe9 on br-lan: ok 2601:19b:4500:d2f1::ddb/128 fd24:2c8b:a1::ddb/128
Thu May 30 12:30:19 2019 daemon.warn odhcpd[1777]: DHCPV6 REQUEST IA_NA from 000100011efec2163871ded4bfe9 on br-lan: ok 2601:19b:4500:d2f1::ddb/128 fd24:2c8b:a1::ddb/128
Thu May 30 12:40:54 2019 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED 38:71:de:d4:bf:e9
Thu May 30 12:40:54 2019 daemon.info hostapd: wlan0: STA 38:71:de:d4:bf:e9 IEEE 802.11: disassociated due to inactivity
Thu May 30 12:40:55 2019 daemon.info hostapd: wlan0: STA 38:71:de:d4:bf:e9 IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Thu May 30 12:40:55 2019 kern.debug kernel: [23888.984123] ieee80211 phy0: staid 3 deleted
Thu May 30 13:25:20 2019 daemon.info dnsmasq-dhcp[2903]: DHCPREQUEST(br-lan) 192.168.2.14 08:05:81:00:b1:fc
Thu May 30 13:25:20 2019 daemon.info dnsmasq-dhcp[2903]: DHCPACK(br-lan) 192.168.2.14 08:05:81:00:b1:fc
Thu May 30 14:36:02 2019 daemon.info hostapd: wlan1: STA 38:71:de:d4:bf:e9 IEEE 802.11: associated (aid 4)
Thu May 30 14:36:02 2019 daemon.info hostapd: wlan1: STA 38:71:de:d4:bf:e9 IEEE 802.11: authenticated
Thu May 30 14:36:03 2019 daemon.notice hostapd: wlan1: AP-STA-CONNECTED 38:71:de:d4:bf:e9
Thu May 30 14:36:03 2019 daemon.info hostapd: wlan1: STA 38:71:de:d4:bf:e9 WPA: pairwise key handshake completed (RSN)
Thu May 30 14:36:04 2019 daemon.info dnsmasq-dhcp[2903]: DHCPDISCOVER(br-lan) 38:71:de:d4:bf:e9
Thu May 30 14:36:04 2019 daemon.info dnsmasq-dhcp[2903]: DHCPOFFER(br-lan) 192.168.2.56 38:71:de:d4:bf:e9
Thu May 30 14:36:06 2019 daemon.info dnsmasq-dhcp[2903]: DHCPDISCOVER(br-lan) 38:71:de:d4:bf:e9
Thu May 30 14:36:06 2019 daemon.info dnsmasq-dhcp[2903]: DHCPOFFER(br-lan) 192.168.2.56 38:71:de:d4:bf:e9
Thu May 30 14:36:07 2019 daemon.warn odhcpd[1777]: DHCPV6 SOLICIT IA_NA from 000100011efec2163871ded4bfe9 on br-lan: ok 2601:19b:4500:d2f1::ddb/128 fd24:2c8b:a1::ddb/128
Thu May 30 14:36:08 2019 daemon.warn odhcpd[1777]: DHCPV6 REQUEST IA_NA from 000100011efec2163871ded4bfe9 on br-lan: ok 2601:19b:4500:d2f1::ddb/128 fd24:2c8b:a1::ddb/128
Thu May 30 14:36:19 2019 daemon.info dnsmasq-dhcp[2903]: DHCPDISCOVER(br-lan) 38:71:de:d4:bf:e9
Thu May 30 14:36:19 2019 daemon.info dnsmasq-dhcp[2903]: DHCPOFFER(br-lan) 192.168.2.56 38:71:de:d4:bf:e9
Thu May 30 14:36:21 2019 daemon.info dnsmasq-dhcp[2903]: DHCPREQUEST(br-lan) 192.168.2.56 38:71:de:d4:bf:e9
Thu May 30 14:36:21 2019 daemon.info dnsmasq-dhcp[2903]: DHCPACK(br-lan) 192.168.2.56 38:71:de:d4:bf:e9 iPhone
Thu May 30 14:38:57 2019 daemon.info hostapd: wlan1: STA 38:30:f9:13:c4:92 IEEE 802.11: associated (aid 10)
Thu May 30 14:38:57 2019 daemon.info hostapd: wlan1: STA 38:30:f9:13:c4:92 IEEE 802.11: authenticated
Thu May 30 14:38:59 2019 daemon.notice hostapd: wlan1: AP-STA-CONNECTED 38:30:f9:13:c4:92
Thu May 30 14:38:59 2019 daemon.info hostapd: wlan1: STA 38:30:f9:13:c4:92 WPA: pairwise key handshake completed (RSN)
Thu May 30 14:38:59 2019 daemon.info dnsmasq-dhcp[2903]: DHCPREQUEST(br-lan) 192.168.2.17 38:30:f9:13:c4:92
Thu May 30 14:38:59 2019 daemon.info dnsmasq-dhcp[2903]: DHCPACK(br-lan) 192.168.2.17 38:30:f9:13:c4:92 android-3a9a3a62a96eb398
Thu May 30 14:39:06 2019 daemon.info dnsmasq-dhcp[2903]: DHCPREQUEST(br-lan) 192.168.2.17 38:30:f9:13:c4:92
Thu May 30 14:39:06 2019 daemon.info dnsmasq-dhcp[2903]: DHCPACK(br-lan) 192.168.2.17 38:30:f9:13:c4:92 android-3a9a3a62a96eb398
Thu May 30 14:39:29 2019 daemon.info hostapd: wlan1: STA b4:4b:d2:e0:d3:66 IEEE 802.11: associated (aid 11)
Thu May 30 14:39:29 2019 daemon.info hostapd: wlan1: STA b4:4b:d2:e0:d3:66 IEEE 802.11: authenticated
Thu May 30 14:39:30 2019 daemon.notice hostapd: wlan1: AP-STA-CONNECTED b4:4b:d2:e0:d3:66
Thu May 30 14:39:30 2019 daemon.info hostapd: wlan1: STA b4:4b:d2:e0:d3:66 WPA: pairwise key handshake completed (RSN)
Thu May 30 14:39:34 2019 daemon.info dnsmasq-dhcp[2903]: DHCPDISCOVER(br-lan) b4:4b:d2:e0:d3:66
Thu May 30 14:39:34 2019 daemon.info dnsmasq-dhcp[2903]: DHCPOFFER(br-lan) 192.168.2.32 b4:4b:d2:e0:d3:66
Thu May 30 14:39:35 2019 daemon.info dnsmasq-dhcp[2903]: DHCPREQUEST(br-lan) 192.168.2.32 b4:4b:d2:e0:d3:66
Thu May 30 14:39:35 2019 daemon.info dnsmasq-dhcp[2903]: DHCPACK(br-lan) 192.168.2.32 b4:4b:d2:e0:d3:66 justi000siPhone
Thu May 30 14:39:36 2019 daemon.info dnsmasq-dhcp[2903]: DHCPREQUEST(br-lan) 192.168.2.32 b4:4b:d2:e0:d3:66
Thu May 30 14:39:36 2019 daemon.info dnsmasq-dhcp[2903]: DHCPACK(br-lan) 192.168.2.32 b4:4b:d2:e0:d3:66 justi000siPhone
Thu May 30 14:39:38 2019 daemon.info dnsmasq-dhcp[2903]: DHCPREQUEST(br-lan) 192.168.2.32 b4:4b:d2:e0:d3:66
Thu May 30 14:39:38 2019 daemon.info dnsmasq-dhcp[2903]: DHCPACK(br-lan) 192.168.2.32 b4:4b:d2:e0:d3:66 justi000siPhone
Thu May 30 14:39:39 2019 daemon.warn odhcpd[1777]: DHCPV6 SOLICIT IA_NA from 00010001214af392b44bd2e0d366 on br-lan: ok 2601:19b:4500:d2f1::1b9/128 fd24:2c8b:a1::1b9/128
Thu May 30 14:39:40 2019 daemon.warn odhcpd[1777]: DHCPV6 REQUEST IA_NA from 00010001214af392b44bd2e0d366 on br-lan: ok 2601:19b:4500:d2f1::1b9/128 fd24:2c8b:a1::1b9/128
Thu May 30 14:39:48 2019 daemon.info hostapd: wlan1: STA a4:db:30:d5:6a:1c IEEE 802.11: associated (aid 12)
Thu May 30 14:39:48 2019 daemon.notice hostapd: wlan1: AP-STA-CONNECTED a4:db:30:d5:6a:1c
Thu May 30 14:39:48 2019 daemon.info hostapd: wlan1: STA a4:db:30:d5:6a:1c WPA: pairwise key handshake completed (RSN)
Thu May 30 14:39:49 2019 daemon.info hostapd: wlan1: STA a4:db:30:d5:6a:1c IEEE 802.11: authenticated
Thu May 30 14:39:49 2019 daemon.info dnsmasq-dhcp[2903]: DHCPREQUEST(br-lan) 192.168.2.9 a4:db:30:d5:6a:1c
Thu May 30 14:39:49 2019 daemon.info dnsmasq-dhcp[2903]: DHCPACK(br-lan) 192.168.2.9 a4:db:30:d5:6a:1c Computer
Thu May 30 14:39:49 2019 daemon.info dnsmasq-dhcp[2903]: DHCPREQUEST(br-lan) 192.168.2.9 a4:db:30:d5:6a:1c
Thu May 30 14:39:49 2019 daemon.info dnsmasq-dhcp[2903]: DHCPACK(br-lan) 192.168.2.9 a4:db:30:d5:6a:1c Computer
Thu May 30 14:39:50 2019 daemon.warn odhcpd[1777]: DHCPV6 CONFIRM IA_NA from 000100011a209ba4201a06b1a037 on br-lan: not on-link 2601:19b:4500:d2f1::612/128 fd24:2c8b:a1::612/128
Thu May 30 14:39:52 2019 daemon.warn odhcpd[1777]: DHCPV6 SOLICIT IA_NA from 000100011a209ba4201a06b1a037 on br-lan: ok 2601:19b:4500:d2f1::612/128 fd24:2c8b:a1::612/128
Thu May 30 14:39:52 2019 daemon.info dnsmasq[2903]: read /etc/hosts - 4 addresses
Thu May 30 14:39:52 2019 daemon.info dnsmasq[2903]: read /tmp/hosts/odhcpd - 6 addresses
Thu May 30 14:39:52 2019 daemon.info dnsmasq[2903]: read /tmp/hosts/dhcp.cfg01411c - 7 addresses
Thu May 30 14:39:52 2019 daemon.info dnsmasq-dhcp[2903]: read /etc/ethers - 0 addresses
Thu May 30 14:39:53 2019 daemon.warn odhcpd[1777]: DHCPV6 REQUEST IA_NA from 000100011a209ba4201a06b1a037 on br-lan: ok 2601:19b:4500:d2f1::612/128 fd24:2c8b:a1::612/128
Thu May 30 14:39:53 2019 daemon.info dnsmasq[2903]: read /etc/hosts - 4 addresses
Thu May 30 14:39:53 2019 daemon.info dnsmasq[2903]: read /tmp/hosts/odhcpd - 8 addresses
Thu May 30 14:39:53 2019 daemon.info dnsmasq[2903]: read /tmp/hosts/dhcp.cfg01411c - 7 addresses
Thu May 30 14:39:53 2019 daemon.info dnsmasq-dhcp[2903]: read /etc/ethers - 0 addresses
Thu May 30 14:50:15 2019 daemon.err uhttpd[1851]: luci: accepted login on /admin/system/system for root from 192.168.2.9
Thu May 30 15:00:31 2019 authpriv.info dropbear[25178]: Child connection from 192.168.2.9:60014
Thu May 30 15:00:35 2019 authpriv.notice dropbear[25178]: Password auth succeeded for 'root' from 192.168.2.9:60014
Thu May 30 15:02:39 2019 auth.info login[25672]: root login on 'pts/0'
Thu May 30 15:31:28 2019 daemon.notice hostapd: wlan1: AP-STA-DISCONNECTED 38:30:f9:13:c4:92
Thu May 30 15:31:28 2019 daemon.info hostapd: wlan1: STA 38:30:f9:13:c4:92 IEEE 802.11: disassociated due to inactivity
Thu May 30 15:31:29 2019 daemon.info hostapd: wlan1: STA 38:30:f9:13:c4:92 IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Thu May 30 15:31:29 2019 kern.debug kernel: [34126.239887] ieee80211 phy1: staid 10 deleted
Thu May 30 15:31:29 2019 daemon.info hostapd: wlan1: STA 38:30:f9:13:c4:92 IEEE 802.11: associated (aid 10)
Thu May 30 15:31:29 2019 daemon.notice hostapd: wlan1: AP-STA-CONNECTED 38:30:f9:13:c4:92
Thu May 30 15:31:29 2019 daemon.info hostapd: wlan1: STA 38:30:f9:13:c4:92 WPA: pairwise key handshake completed (RSN)
Thu May 30 15:31:29 2019 daemon.info hostapd: wlan1: STA 38:30:f9:13:c4:92 IEEE 802.11: authenticated
Thu May 30 15:31:30 2019 daemon.info dnsmasq-dhcp[2903]: DHCPREQUEST(br-lan) 192.168.2.17 38:30:f9:13:c4:92
Thu May 30 15:31:30 2019 daemon.info dnsmasq-dhcp[2903]: DHCPACK(br-lan) 192.168.2.17 38:30:f9:13:c4:92 android-3a9a3a62a96eb398
Thu May 30 15:49:20 2019 daemon.notice hostapd: wlan1: AP-STA-DISCONNECTED 38:30:f9:13:c4:92
Thu May 30 15:49:20 2019 daemon.info hostapd: wlan1: STA 38:30:f9:13:c4:92 IEEE 802.11: disassociated due to inactivity
Thu May 30 15:49:21 2019 daemon.info hostapd: wlan1: STA 38:30:f9:13:c4:92 IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Thu May 30 15:49:21 2019 kern.debug kernel: [35198.877861] ieee80211 phy1: staid 10 deleted
Thu May 30 15:49:21 2019 daemon.info hostapd: wlan1: STA 38:30:f9:13:c4:92 IEEE 802.11: associated (aid 10)
Thu May 30 15:49:22 2019 daemon.notice hostapd: wlan1: AP-STA-CONNECTED 38:30:f9:13:c4:92
Thu May 30 15:49:22 2019 daemon.info hostapd: wlan1: STA 38:30:f9:13:c4:92 WPA: pairwise key handshake completed (RSN)
Thu May 30 15:49:22 2019 daemon.info hostapd: wlan1: STA 38:30:f9:13:c4:92 IEEE 802.11: authenticated
Thu May 30 15:49:22 2019 daemon.info dnsmasq-dhcp[2903]: DHCPREQUEST(br-lan) 192.168.2.17 38:30:f9:13:c4:92
Thu May 30 15:49:22 2019 daemon.info dnsmasq-dhcp[2903]: DHCPACK(br-lan) 192.168.2.17 38:30:f9:13:c4:92 android-3a9a3a62a96eb398
Thu May 30 16:09:00 2019 daemon.notice hostapd: wlan1: AP-STA-DISCONNECTED b4:4b:d2:e0:d3:66
Thu May 30 16:09:00 2019 daemon.info hostapd: wlan1: STA b4:4b:d2:e0:d3:66 IEEE 802.11: disassociated due to inactivity
Thu May 30 16:09:01 2019 daemon.info hostapd: wlan1: STA b4:4b:d2:e0:d3:66 IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Thu May 30 16:09:01 2019 kern.debug kernel: [36378.807075] ieee80211 phy1: staid 11 deleted
Thu May 30 16:09:21 2019 daemon.notice hostapd: wlan1: AP-STA-DISCONNECTED 38:30:f9:13:c4:92
Thu May 30 16:09:21 2019 daemon.info hostapd: wlan1: STA 38:30:f9:13:c4:92 IEEE 802.11: disassociated due to inactivity
Thu May 30 16:09:22 2019 daemon.info hostapd: wlan1: STA 38:30:f9:13:c4:92 IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Thu May 30 16:09:22 2019 kern.debug kernel: [36400.644893] ieee80211 phy1: staid 10 deleted
Thu May 30 16:17:38 2019 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED 1c:4d:70:1b:8b:54
Thu May 30 16:17:38 2019 kern.debug kernel: [36896.155561] ieee80211 phy0: staid 2 deleted
Thu May 30 16:19:02 2019 daemon.notice hostapd: wlan1: AP-STA-DISCONNECTED a4:db:30:d5:6a:1c
Thu May 30 16:19:02 2019 daemon.info hostapd: wlan1: STA a4:db:30:d5:6a:1c IEEE 802.11: disassociated
Thu May 30 16:19:02 2019 kern.debug kernel: [36979.981071] ieee80211 phy1: staid 12 deleted
Thu May 30 16:19:42 2019 daemon.notice hostapd: wlan1: AP-STA-DISCONNECTED 38:71:de:d4:bf:e9
Thu May 30 16:19:42 2019 daemon.info hostapd: wlan1: STA 38:71:de:d4:bf:e9 IEEE 802.11: disassociated
Thu May 30 16:19:42 2019 kern.debug kernel: [37020.491961] ieee80211 phy1: staid 4 deleted
Thu May 30 16:19:43 2019 daemon.info hostapd: wlan1: STA 38:71:de:d4:bf:e9 IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Thu May 30 16:22:42 2019 daemon.info hostapd: wlan1: STA a4:db:30:d5:6a:1c IEEE 802.11: associated (aid 4)
Thu May 30 16:22:42 2019 daemon.notice hostapd: wlan1: AP-STA-CONNECTED a4:db:30:d5:6a:1c
Thu May 30 16:22:42 2019 daemon.info hostapd: wlan1: STA a4:db:30:d5:6a:1c WPA: pairwise key handshake completed (RSN)
Thu May 30 16:22:42 2019 daemon.info dnsmasq-dhcp[2903]: DHCPREQUEST(br-lan) 192.168.2.9 a4:db:30:d5:6a:1c
Thu May 30 16:22:42 2019 daemon.info dnsmasq-dhcp[2903]: DHCPACK(br-lan) 192.168.2.9 a4:db:30:d5:6a:1c Computer
Thu May 30 16:22:42 2019 daemon.info hostapd: wlan1: STA a4:db:30:d5:6a:1c IEEE 802.11: authenticated
Thu May 30 16:22:42 2019 daemon.warn odhcpd[1777]: DHCPV6 SOLICIT IA_NA from 000100011a209ba4201a06b1a037 on br-lan: ok 2601:19b:4500:d2f1::612/128 fd24:2c8b:a1::612/128
Thu May 30 16:22:42 2019 daemon.info dnsmasq[2903]: read /etc/hosts - 4 addresses
Thu May 30 16:22:42 2019 daemon.info dnsmasq[2903]: read /tmp/hosts/odhcpd - 6 addresses
Thu May 30 16:22:42 2019 daemon.info dnsmasq[2903]: read /tmp/hosts/dhcp.cfg01411c - 7 addresses
Thu May 30 16:22:42 2019 daemon.info dnsmasq-dhcp[2903]: read /etc/ethers - 0 addresses
Thu May 30 16:22:42 2019 daemon.warn odhcpd[1777]: DHCPV6 SOLICIT IA_NA from 000100011a209ba4201a06b1a037 on br-lan: ok 2601:19b:4500:d2f1::612/128 fd24:2c8b:a1::612/128
Thu May 30 16:22:43 2019 daemon.warn odhcpd[1777]: DHCPV6 REQUEST IA_NA from 000100011a209ba4201a06b1a037 on br-lan: ok 2601:19b:4500:d2f1::612/128 fd24:2c8b:a1::612/128
Thu May 30 16:22:43 2019 daemon.info dnsmasq[2903]: read /etc/hosts - 4 addresses
Thu May 30 16:22:43 2019 daemon.info dnsmasq[2903]: read /tmp/hosts/odhcpd - 8 addresses
Thu May 30 16:22:43 2019 daemon.info dnsmasq[2903]: read /tmp/hosts/dhcp.cfg01411c - 7 addresses
Thu May 30 16:22:43 2019 daemon.info dnsmasq-dhcp[2903]: read /etc/ethers - 0 addresses
Thu May 30 16:23:03 2019 daemon.err uhttpd[1851]: luci: accepted login on / for root from 192.168.2.9

It does not look like there is an issue with the wifi (based on the log output) - i would guess the phone is actually the issue, not the wifi.

  • Your phone (MAC 38:71:de:d4:bf:e9) connects at 12:30:13 and disconnects at 12:40:54 again
  • Your phone connects again on 14:36:03 and disconnects again on 16:19:42
  • After that no more connection attempt is even made
  • The log does not show any issue whatsoever on the wlan0 device

My best guess is, that your phone has an issue.

I appreciate you taking the time to look through it, but the phone disconnects are because I turn off WiFi on my phone when I can't get through to the Internet via WiFi and I'm too lazy to get up to go do a reboot on the router.

It's definitely not just my phone because when my phone's WiFi stops working, my wife's doesn't work either (and neither does my Amazon Echo or my Roomba or my Ecobee).

However, it's also definitely not the Internet / WLAN connection; I have a home security system that is connected to the WRT3200ACM via an Ethernet cable. This system is monitored by a 3rd party company. When the Internet connection goes down, I get a text message. I can remotely arm/disarm the system, so the Internet / WLAN definitely stays up and it's just the WiFi that's down.

As I mentioned, I don't see anything in the logs that would indicate the WiFi interface going down... but the symptom is that the SSID still broadcasts, all the devices can still connect, but it just doesn't route through from WiFi to the Internet. From my laptop, when the Internet is dead, I can still connect to my local devices - a NAS, the router, etc. So I don't think it's traffic on the WiFi interface.

The oddest thing is I had the EXACT same problem with stock firmware... all my wireless devices just have the Internet connection die and (sometimes) randomly come back up. Any idea what else I can do? I was hoping the daily scheduled reboot would make it better, but it hasn't.

Seems not to be an OpenWrt issue then. Hardware problems??

Edit: The other thing might be some kind of interference from a neighbor, industrial equipment, ...

How do I troubleshoot (or solve) interference?

There are several cell-phone apps that display received signal power from all “visible” APs. Unfortunately they aren’t spectrum analyzers, so they don’t show non-802.11 signals. (Those are in the $10,000 range.)

Borrowing another 2.4 GHz AP, or purchasing an inexpensive one would be another way to determine if it is RFI or a hardware problem. A spare AP has come in handy for me on several occasions. There are some that start at under US$20 of good quality.

did you confirm that both the 2.4 and 5ghz bands are down at the same time? if so it's probably not interference...

this also indicates it's not interference, since you can transfer data over wifi... and when this happens you say wired devices still can access internet? if so it suggests some issue specific to wifi-to-internet path...

do you have ipv6 on your network? who is the ISP?

ISP is Comcast and it was giving out an IPv6 address... 5GHz band seemed to work.

I switched the Wireless interface from Channel 11 to Channel 1 and I disabled the WAN6 interface and disabled the LAN giving out IPv6 addresses. Will report back if either of those things seems to make it work better.

In the future, please use the </> button to paste code and console output.

so disabling ipv6 just cripples your network but can't be the problem if 5Ghz still works... reenable it and turn off 2.4GHz... see if you get the same results... if it's just 2.4ghz this is useful info

2 Likes