Wifi is enabled but No SSID broadcasting

I am setting OpenWrt on x86 hardware using Atheros QCA6174 Wireless Network Adapter. I installed both kmod-ath10k and ath10k-firmware-qca6174 packages. The wifi was enabled but I can not see the SSID on my computer or cellphone and it looks that radio0 is not active or broadcasting. Any help will be appreciated. Thanks in advance.


# cat /etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd2b:2519:f434::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option ifname 'eth1'
	option proto 'dhcp'
	option type 'bridge'

config interface 'wan6'
	option ifname 'eth1'
	option proto 'dhcpv6'
	option type 'bridge'
# cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'pci0000:00/0000:00:1d.0/0000:02:00.0'
	option txpower '17'
	option htmode 'VHT80'
	option country 'US'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option mode 'ap'
	option encryption 'none'
	option ssid 'OpenWrt-test'
	option network 'lan wan wan6'

Did you also install wpad-basic and hostapd-common?

1 Like

If those packages are present, the next step would be checking the logs (dmesg, logread) and then to test basic functionality of the wireless card (iwinfo radio0 scan).

2 Likes

@lleachii and @slh thanks for your help. I installed the wpad-basic and hostapd-common. There is some improvement but still not seeing the SSID. I will note that I have no antenna attached to wireless card but it is 5 feet away. Not sure if this makes a difference

# iwinfo radio0 scan
Cell 01 - Address: DA:31:34:33:46:8C
          ESSID: unknown
          Mode: Master  Channel: 36
          Signal: -86 dBm  Quality: 24/70
          Encryption: WPA2 PSK (CCMP)

Cell 02 - Address: 88:96:4E:77:77:D0
          ESSID: "SUPERMAN"
          Mode: Master  Channel: 1
          Signal: -75 dBm  Quality: 35/70
          Encryption: WPA2 PSK (CCMP)

Cell 03 - Address: 8A:96:4E:77:77:D1
          ESSID: "GtcGD5SGU"
          Mode: Master  Channel: 1
          Signal: -75 dBm  Quality: 35/70
          Encryption: WPA2 PSK (CCMP)

I am not sure what to look for in the logs?

I put the log read in pastebin https://pastebin.com/embed_js/HkLx9RYG

Your scan proves that the wireless card is now working - and your channel/ frequency settings are also looking better.

Antennas must be connected at all times while the device is powered on, leaving them off might permanently damage the hardware

2 Likes

Thank you very much @lleachii and @slh I connected the antenna and now I see the SSID

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.