Wifi extender problem when using client+master on same wifi if (Mi Router 3G)

Hello,

I currently use openwrt last build for mi Mi Router 3G (OpenWrt 19.07.2 r10947-65030d81f3)
I have the current setup:

  • One main internet router (192.168.1.1) with DHCP activated
  • My openwrt xiaomi used as a repeater/extender:
  • connected in 5ghz wifi to main router: if wlan1-client // ip 192.168.1.2 (defined by fixed dhcp with mac adress by main router) // network wwan // SSID BRIOVAIR-RDC
  • have 2.4ghz access point: if wlan0-AP // network lan // SSID BRIOVAIR-ETAGE
  • have 5ghz access point: if wlan1-AP // network lan // SSID BRIOVAIR-ETAGE
  • have an interface called "relay bridge" (relayd installed) configured to IP 192.168.1.2 and doing bridge between lan and wlan networks
  • firewall is disabled (was giving problems)

The config is working good with wlan1-client and wlan0-AP: I can connect to openwrt router in wifi or ethernet and get my IP attributed from main router, and devices from both router can see each other both way (initally I configured a second subrange for openwrt router, was working good except devices from main router couldn't see the ones from openwrt router)

My problem is that if I activate wlan1-AP it won't go up. wether I activate wlan0-AP or not. I don't get why, config seems right to me. so I can only connect to openwrt router in 2.4ghz for now, even if he is connected to main router in 5ghz.
Any idea why and what I can do about it? I'll see if I can join the logs/config files

One extra question: with this setup, if I transfer data between two computers connected to the openwrt router, will the data go to the main router and back to go from one computer to another (PC1=>openwrt router=>main router => openwrt router =>PC2 ?)? or just the IP are determinated by main router but the data will go from PC1=>openwrt router=>PC2 ?

my actual config files (everything on 2.4ghz - radio0 - is disabled because for now I just want to make things working on 5ghz - radio1 - interface):

DHCP FILE:

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'

config dhcp 'lan'
        option interface 'lan'
        option dhcpv6 'server'
        option ra 'server'
        option ra_management '1'
        option ignore '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

NETWORK FILE:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fde1:a3b1:22dd::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.2.1'
        option gateway '192.168.1.1'
        list dns '192.168.1.1'

config device 'lan_eth0_1_dev'
        option name 'eth0.1'
        option macaddr '78:11:dc:4a:58:74'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '6t 3 2 1'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '6t'
        option vid '2'

config interface 'wwan'
        option proto 'dhcp'

config interface 'repeater_bridge'
        option proto 'relay'
        list network 'lan'
        list network 'wwan'
        option ipaddr '192.168.1.2'

WIRELESS FILE:

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'HT40'
        option channel 'auto'
        option disabled '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option mode 'ap'
        option ssid 'BRIOVAIR-ETAGE'
        option encryption 'psk2'
        option key 'xxxxx'
        option ifname 'wlan0-AP'
        option disabled '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:01.0/0000:02:00.0'
        option htmode 'VHT80'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option mode 'ap'
        option ssid 'BRIOVAIR-ETAGE'
        option encryption 'psk2'
        option key 'xxxxx'
        option ifname 'wlan1-AP'

config wifi-iface 'wifinet2'
        option device 'radio0'
        option mode 'sta'
        option encryption 'psk2'
        option ssid 'BRIOVAIR-RDC'
        option key 'xxxxx'
        option disabled '1'
        option ifname 'wlan0-client'

config wifi-iface 'wifinet3'
        option ssid 'BRIOVAIR-RDC'
        option device 'radio1'
        option mode 'sta'
        option network 'wwan'
        option encryption 'psk2'
        option key 'xxxxx'
        option ifname 'wlan1-client'

I don't use relayd anymore, but when I did I noticed the same behavior, could use one band as client and the other as ap, but couldn't use the client band as ap, whether it's a limitation of hardware or relayd I don't know unfortunately, maybe someone who's been able to use client/ap on the same radio will be able to answer.

thanks mike for your reply, the weird thing, is that if I put everything in 2.4ghz it works fine (forget to mention that), ie client + AP on same wlan0 interface. maybe hardware limitation, but it wouldn't seem logic to me.

To answer myself, I figured my internet provider router was configured in 5G on a weird debug chanel (112). So, this is why it was not working - I guess - because meanwhile I got back to stock (not working) and then to padavan (where, while doing the config, I figured out that stupid issue).
But I bet it would work good on OpenWRT also, but I have now a good working conf and will stay on it :wink:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.