WiFi doesn't have a valid IP configuration

I've been using this router for a while with OpenWRT + Lede installed on it. Everything was fine until recently when the router stopped working wirelessly. I can still use ethernet connection with it but Wi-Fi connections stay broken. When I tried troubleshooting the issue with Windows 10 troubleshooter and it came back with error "WiFi doesn't have a valip IP configuration":

I am not very good with this system, I had to use it since default firmware on my router would literally have a stroke every 5 minutes and go down. But now I basically have no Wi-Fi. So I'd really appreciate if you could navigate me in the direction of possible issues.

I am not able to access the router wirelessly, only direct wired connection works. The only thing I've set up in the past was port forwarding to have a PC accessible in the local network. But that was a while ago, whilst the network stopped working only recently. Restarting it didn't help.

Can other devices, like smartphone, tablet, etc, connect to the wifi successfully?

1 Like

No, nothing can connect to it via WiFi at the moment. Also, I appreciate you replying, this is tough as I don't even know where to start.

Use ssh to connect to the device.

Please run the following commands (copy-paste the whole block) and paste the output here, using the "Preformatted text </> " button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have

ubus call system board; \
uci export network; uci export wireless; iw list

Thank you, here's the output

        "kernel": "4.4.50",
        "hostname": "LEDE",
        "system": "Qualcomm Atheros QCA956X ver 1 rev 0",
        "model": "TP-Link TL-WR1043N\/ND v4",
        "release": {
                "distribution": "LEDE",
                "version": "17.01.0",
                "revision": "r3205-59508e3",
                "codename": "reboot",
                "target": "ar71xx\/generic",
                "description": "LEDE Reboot 17.01.0 r3205-59508e3"
package network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr ''
        option netmask ''

config globals 'globals'
        option ula_prefix 'fdf4:b843:c1da::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr ''
        option netmask ''
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'
        option type 'bridge'

config device 'wan_dev'
        option name 'eth0.2'
        option macaddr '84:16:f9:c8:72:bb'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'
        option type 'bridge'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 0t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 0t'

package wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/qca956x_wmac'
        option htmode 'HT20'
        option country 'UA'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option mode 'ap'
        option ssid 'Apollo'
        option encryption 'psk2'
        option key 'password'
        option network 'lan wan wan6'

Wiphy phy0
        max # scan SSIDs: 4
        max scan IEs length: 2257 bytes
        max # sched scan SSIDs: 0
        max # match sets: 0
        max # scan plans: 1
        max scan plan interval: -1
        max scan plan iterations: 0
        Retry short limit: 7
        Retry long limit: 4
        Coverage class: 0 (up to 0m)
        Device supports AP-side u-APSD.
        Device supports T-DLS.
        Available Antennas: TX 0x7 RX 0x7
        Configured Antennas: TX 0x7 RX 0x7
        Supported interface modes:
                 * IBSS
                 * managed
                 * AP
                 * AP/VLAN
                 * WDS
                 * monitor
                 * mesh point
                 * P2P-client
                 * P2P-GO
                 * outside context of a BSS
        Band 1:
                Capabilities: 0x11ee
                        SM Power Save disabled
                        RX HT20 SGI
                        RX HT40 SGI
                        TX STBC
                        RX STBC 1-stream
                        Max AMSDU length: 3839 bytes
                        DSSS/CCK HT40
                Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
                Minimum RX AMPDU time spacing: 8 usec (0x06)
                HT TX/RX MCS rate indexes supported: 0-23
                        * 2412 MHz [1] (20.0 dBm)
                        * 2417 MHz [2] (20.0 dBm)
                        * 2422 MHz [3] (20.0 dBm)
                        * 2427 MHz [4] (20.0 dBm)
                        * 2432 MHz [5] (20.0 dBm)
                        * 2437 MHz [6] (20.0 dBm)
                        * 2442 MHz [7] (20.0 dBm)
                        * 2447 MHz [8] (20.0 dBm)
                        * 2452 MHz [9] (20.0 dBm)
                        * 2457 MHz [10] (20.0 dBm)
                        * 2462 MHz [11] (20.0 dBm)
                        * 2467 MHz [12] (20.0 dBm)
                        * 2472 MHz [13] (20.0 dBm)
                        * 2484 MHz [14] (disabled)
        valid interface combinations:
                 * #{ managed } <= 2048, #{ AP, mesh point } <= 8, #{ P2P-client, P2P-GO } <= 1, #{ IBSS } <= 1,
                   total <= 2048, #channels <= 1, STA/AP BI must match, radar detect widths: { 20 MHz (no HT), 20 MHz, 40 MHz }

                 * #{ WDS } <= 2048,
                   total <= 2048, #channels <= 1, STA/AP BI must match
        HT Capability overrides:
                 * MCS: ff ff ff ff ff ff ff ff ff ff
                 * maximum A-MSDU length
                 * supported channel width
                 * short GI for 40 MHz
                 * max A-MPDU length exponent
                 * min MPDU start spacing

17.01 is for long time not supported. You need to upgrade to a stable version.
Why is wan, wan6, and lan bridged with the wifi?


I'm learning the ways to upgrade at the moment. I installed this OS back when Lede project was separate from WRT, would I still be able to upgrade or should I reinstall the system instead? Not that there's a lot of configuration in there anyway.

I have no idea what this means. There are no other networks connected to this router so I believe all 3 of these should have no effect. I remember adding them when I broke the wi-fi in the past and after reinstalling the system I enabled all of these and since it worked I have never touched them again.

When you upgrade your device to OpenWrt 21.02.0, make sure you do not keep the old settings (there is a checkbox for this). That will reset your router to the default state which will be configured properly for the normal router mode. You will only need to login and enable WiFi and you will likely be up and running.

1 Like

Thank you. That's exactly what I did. The 21st version came with everything already set up for me. Though I wish I knew why the old one stopped working all of the sudden. Now, I guess, I'll never know..

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.