WiFi connection problem on MR8300 Snapshot and Release

I will come to the point without mincing words. I have an MR8300 to which I am trying to connect a new laptop with Intel Wi-Fi 6 AX201 160Mhz Wi-Fi card with updated drivers. The card connects to the router but does not browse as if the DNS or gateway were not set correctly, but this is not the case because the other devices connected to the router are working. First thing I thought, the notebook Wi-Fi was faulty. Since the MR8300 has two partitions and on one of them I have the original linksys software, I rebooted it with that and magic the Wi-Fi connects seamlessly and surfs. So it makes me think that there is something wrong with WRT. I also had this problem with the snapshot. I updated it hoping to fix, but nothing to do. Do you have any ideas what the reason may be? I also tried with an old D-Link USB Wi-Fi key, but that doesn't work either.

Hi
I have outboxed a MR8300 (OpenWrt 21.02.0) and a laptop with an Intel AX200 (not 201 however). I have tested both wifi0 (qca9886) and wifi2 (ipq4019) on 5GHz band : they linked at full speed (867 Mbit/s).
I was able to browse several websites, download an ubuntu ISO, and transfer files (wifi -> LAN) with a very good speed (50MB/s). That is what can be fully expected of such hardware (both router and laptop).

So as far as I can test, OpenWrt works fine. Assuming you don't have a hardware issue (you said it works fine with Linksys firmware), your issue is probably due to a bad setting.

  • which wifi interface are you using ?
  • do you have the documented wifi0 issue ?
  • any tricky setup in the wifi ? LAN zone ?
  • country and transmit power are set ?
  • any manually change in the wifi card options ?
  • sounds noob, but is the wifi card using DHCP from the router ?

Can you post /etc/config/network and /etc/config/wireless please ?
It is probably something tiny and not obvious.

Me too i think not is a hardware problem because work correctly with original firmware. The issue accoured bot static and dhcp (also assisted dhcp). Now updated the wlan driver with the last available on Intel site wich is 22.70.0 differently to windows default driver 22.0.1. But I noticed one thing. Now the connection seems to work and the navigation works but the windows icon does not have the "fan" but they remain with the "globe". At this point the problem appears to be in windows.


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fded:6dd8:adf9::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'
	option ipv6 '0'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.100.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	list dns '1.1.1.1'
	list dns '1.0.0.1'
	option gateway '10.100.100.110'

config interface 'wan'
	option device 'eth1'
	option proto 'static'
	option ipaddr '10.10.10.100'
	option netmask '255.255.255.0'
	option gateway '10.100.100.110'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 0'

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '100'
	option hwmode '11a'
	option path 'soc/40000000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
	option htmode 'VHT80'
	option disabled '1'
	option cell_density '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option encryption 'sae-mixed'
	option key '****'
	option ieee80211w '1'
	option ssid '****'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'platform/soc/a000000.wifi'
	option htmode 'HT20'
	option cell_density '0'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid '****'
	option key '****'
	option encryption 'sae-mixed'
	option ieee80211w '1'

config wifi-device 'radio2'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'platform/soc/a800000.wifi'
	option htmode 'VHT80'
	option cell_density '0'

config wifi-iface 'default_radio2'
	option device 'radio2'
	option network 'lan'
	option mode 'ap'
	option ssid '****'
	option key '****'
	option encryption 'sae-mixed'
	option ieee80211w '1'

Obviously, I have removed the useless data for analysis purposes.

Hi.
I also used the latest intel wifi drivers (22.7)
In wireless file I see no contry, transmit power and country setting, example:

option country 'FR'
option txpower '17'
option channel '108'

I also see that you use WPA3 as crypto, do you devices comply ?
The windows icon, sometimes this icon needs time to switch to "fan", don't worry. Just check if you can browse.

You seem close to solving.

WPA3 but not exclusive because i've both devices that uses WPA2 & 3. For now it works.

Ok, great. So state the thread as solved to end.
Have a nice day.

Ok we consider it solved. In case the problem recurs I will open a new thread.

The problem came back with another phone a few years old.. The connection go fine but does not navigate. The other devices it connects and browse. Is there a possibility to have a detailed log on the reason for this problem? This phone with the 19.x.x connected regularly. It looks like something related to DNS but I have no further data to confirm it.

Maybe (I use the conditional term voluntarily) I found the problem. If the problem on the laptop described at the beginning of the post seems to have been solved using the latest version of the driver available on the Intel website (the manufacturer's one was a little older), the problem happened to me on two android phones. In these mobile phones the use of the private DNS was set which on the cellular network works regularly but on WiFi gave the problem that the phone connected but did not surf. Half successful because the connection works but it is not possible to use that DNS function over WiFi. I am writing this to give the possibility to those who develop perhaps to give us an eye to understand if the problem can actually occur to others with these conditions.