Wifi Configuration

Hi there.
I'm new here and Im having a problem during my LEDE configuration.
I have installed on my Dlink Dir 600 the LEDE Reboot 17.01.4 r3560-79f57e422d / LuCI lede-17.01 branch (git-17.290.79498-d3f0685) firmware.

I have my ISP router configurated in Bridge mode and works fine. I configured the connection for LAN and WAN and via Ethernet is working perfect, the problem is when I try to active Wifi. My configuration is on the Pics that attached.

The SSID is working fine, I can connect devices to the wifi, but I cant use Internet, something is configurate wrong because via LAN Ethernet I have Internet, but via WIFI no.

Please if you can help me I will appreciate

Thanks in Advance.

Pictures kind of small (I guess is the same for the ones I post)

I am taking a risk here because I don't know a lot about these stuff

but I think you need to choose only only one between Network Lan and Wan.

Try selecting only Lan then save and apply and check it

then do the same for wan.

Let us know how it goes, maybe somebody else can help betterScreenshot%20from%202018-11-22%2017-35-20

You have to distil the option of wan because the wireless clients would receive a public IP if you have several available (I doubt it). Therefore, only the lan option should be checked to receive a private IP.

Forwarding Internet requests from the LAN to the WAN is done by the firewall subsystem. Local users (wired or wireless) should be connected only to the LAN network.

Hi there, Many thanks for the answer.

  I tried to set only LAN and nothing... and then only WAN and the same, I dont have Internet connection... Only I have via LAN Ethernet no with Wifi...

  I attached below a Print Screen for my WAN settings... may be can help..

screenshot went missing reattach

read first


You should find somewhere on the interface the country settings for the wifi radio

be sure You use the ones that apply to your region

Hi Pippo and community.

  I tested to add the Code Country as you told me and still with out working... Only via LAN the Internet works.. If I try on WirelessLan nothing... Then I saw the URL you send me with this guide and I have the same settings.

  I configured only for LAN and then tried with WAN (in the Wireless settings) and nothing... Is so strange..

Can I help attaching some pic from my router configuration?

Thanks in advance

Attaching pictures is not a good idea when you want your configuration sorted out. You need to attach your configuration in code. For that use a SSH client like putty if you use windows. If you use Linux then just ssh root@X.X.X.X (put your ip in place).

Then do cat /etc/config/network and cat /etc/config/wireless and show us the output.

what does the



ifconfig -a

outputs ?

on Openwrt menu

open Network tab select Interfaces

edit button on the Lan interface row

Physical Setting tab

is the box next to Bridge interfaces checked ?


wireless settings can you show us that page

or just the output of

cat etc/config/wireless

ifconfig is used for displaying information about current available/connected interfaces on your router. Use ifconfig --help for more information.

@Pippo Please dont ask for any screenshots. The crucial information gets omitted. LuCI only displays a handful of information which a basic user would need to modify/configure. In case of troubleshooting, we need to know what is actually wrong and that info comes from the full config files.

Oks, So what would be the configuration for this?

so Marto should start from here:


SSH Access for Newcomers

This wiki describes several terminal emulators to initiate a SSH connection

Here is the interface setting.

Hi Ahmar16,

  Yes, I know about IPCONFIG, when i run this command on my shell shows me my Ethernet Adapter and is setting good, assigns me and IPv4 address in the same network that my gateway.

What do you want to know about this?

There is.

brctl show should show the LAN bridge (br-lan) and the interfaces included in it. There should be one Ethernet and the one wifi.

Having LAN wifi users go to the Internet is something that should just work with a very basic configuration. You could consider resetting to default configuration, set up your WAN, and start up an AP on the LAN. That really is all that needs to be done for a basic setup that works like stock firmware. Then you can grow from there.

I cant use Putty to connect the Router via SSH... appears an error when I try to make the login.

It is possible to export the configuration without SSH?