Wifi configuration problem

Hello everyone,

I installed OpenWrt on my router(D-Link DWR-921, version C1), I followed the various tutorials to configure the LTE connection, it seems that the connection is established because I can ping.

When I connect via wifi to the router it seems that I have no internet yet.

Some details about my configuration:

root@OpenWRT:~# uci export network
package network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd7c:0dd9:a214::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config device
        option name 'eth0.1'
        option macaddr '10:be:f5:82:60:d1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'eth0.2'
        option macaddr '10:be:f5:82:60:d0'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6t'

config interface 'WWAN'
        option proto 'modemmanager'
        option device '/sys/devices/platform/101c0000.ehci/usb1/1-1'
        option pincode 'xxxx'
        option iptype 'ipv4v6'
        option apn 'internet'
        option auth 'pap'


Did you add your wwan interface to a firewall zone?

3 Likes

I'm sorry, I've been trying to get OpenWRT to work for three days, I've scoured the web and the forum, I've tried a lot of things but nothing has worked.
I decided to put back the original firmware.
Thanks for trying to help me, I'm sorry it didn't work. Maybe I will try again sometime.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.