Wifi beyond the WRT1900AC?

My trusty WRT1900AC feels to be no longer up to the task of the increasing amounts of devices and distances in my home. What does life beyond this look like for me?

Must have:
Broadband throughput at least as good as the WRT1900AC.
Guest/Additional WIFIs
Top class wifi performance / coverage

Would the guidance below still be appropriate? I'm not massively concerned about supporting upto my 1Gpbs download from my provider, but the performance of the 1900AC has been okay in that regard.

Your 1900 is one of the fastest devices available as an all in one and this is why the performance has been good

I would suggest to turn off the wifi on your device and use it as a wired only router, then add 2 wifi access points. This will fix the wifi issues you're having.

1 Like

Excellent idea. Why do I need two? That's the bit I'm missing.
I'm looking at adding at least one TP-Link Omada EAP225 . It looks to me that as I can Tag the VLANS on the switch ports out to the EAP225 so it can run multiple SSIDs back into the WRT1900 ?

My assumption is that if you're having wifi issues, then you probably need better coverage than what you're getting with just one device. If you have 800sqft you can probably do one AP, if you have 1600 probably 2, if you have multi-levels or want access in the yard or something, 3

Also, run them at 40MHz channels on 5GHz, and 20MHz channels on 2.4GHz, you'll have diversity and won't have issues with multiple devices all trying to get service on a single radio.

Also, yes you can use tagged VLANs to provide multiple SSIDs.

Thank you. indoor coverage is the main objective, around 1,500 sq.feet, timber frame house.....so I might go for two.

Thank you.

Got an express delivery on a pair of EAP225s. Got one configured already (need to do some research on the mesh setup)...and wooohooo...it blows the built in WRT1900 radios away ...it's in the same location too so no bias there.

Yeah, my experience as well. The linux drivers for the WRT series were not very good and caused all kinds of problems. Turn off the wifi on the WRT and just use it wired.

On the EAP225s I run the stock firmware, which is updated regularly because it's for commercial clients. It has airtime fairness and a variety of other things, it's quite good.

I'm not really that familiar with the details of the wifi tech now, would you recommend turning on airtime fariness? I've done the 2.4 20Mhz and 5 ghz 40mhz as well as enabled Band Steering (same SSIDs settings on both 2.4 and 5). I also have the typical mix of older and newer devices on my network.

I am pleasantly surprised by the stock firmware in the EAP225, it does seem very responsive and quite robust. The release notes from TPLink are comprehensive too, it does have the feel of a business grade product.

If it's the WRT1900AC v1, just replace its mini-PCIe Wi-Fi cards (yes, they're in slots) with better ones.

I like the Airtime Fairness when there are a mix of devices (fast laptops, slow IoT devices, phones, etc).

I personally turn the tx power down to medium, and use 2 APs to get coverage, and enable the Fast Roaming options (though I don't know which client devices actually support it). I also set the minimum data rates to 12Mbps (though you might not do this if you get disconnected, or you might do it for all SSIDs except one 2.4GHz radio you allow for "long distance")

In general these days I never have wifi problems except in the extremes of the property (back corner, or out on the street). If I cared, I could move the devices a little and get more complete coverage, but I don't care.

Really great information, thanks again. do you have both your APs wired back to your router or are you extending 'mesh style'?
Wiring the second AP back to my router if I choose/need to deploy it could be problematic (although would be my preferred option).

Both of them wired. Mesh is better than nothing but wired is the way to go if possible.

1 Like

Thanks, will have to have some cat 6 run under the house to make it happen.... if you use the Omada controller where do you enable 'Airtime fairness' in there, i found it no problem with the AP in standalone mode but cannot seem to find the option in the Omada controller.