Wifi adapter is up, but cant find it, Netgear AC1200 R6120

I recently flashed a Netgear R6120 with OpenWrt, and have got almost everything working (lan, wan). The only thing is that I can enable my wifi network, but my devices cannot find it. Hide SSID is turned off, and power output/distance to device do not affect this. After removing and adding the wireless device, I once briefly saw the OpenWrt network, but only once. Also, the device seems to hang if I change the power output. Is there anything known about the R6120 being buggy with OpenWrt? I can't find anything on the forums related to my problem, and the R6120 seems like a relatively new device. I have also flashed the sysupgrade to the device, this did not fix the problem either.

What does dmesg or logread say? That should provide some clues.

root@OpenWrt:~# dmesg
[    0.000000] Linux version 4.14.78 (buildbot@crazyhorse) (gcc version 7.3.0 (OpenWrt GCC 7.3.0 r8393-dd9da51)) #0 Tue Oct 30 19:38:34 2018
[    0.000000] Board has DDR2
[    0.000000] Analog PMU set to hw control
[    0.000000] Digital PMU set to hw control
[    0.000000] SoC Type: MediaTek MT7628AN ver:1 eco:2
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 00019655 (MIPS 24KEc)
[    0.000000] MIPS: machine is Netgear AC1200 R6120
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 04000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x0000000000000000-0x0000000003ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x0000000000000000-0x0000000003ffffff]
[    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000003ffffff]
[    0.000000] On node 0 totalpages: 16384
[    0.000000] free_area_init_node: node 0, pgdat 804c4fb0, node_mem_map 81000040
[    0.000000]   Normal zone: 128 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 16384 pages, LIFO batch:3
[    0.000000] random: get_random_bytes called from start_kernel+0x8c/0x47c with crng_init=0
[    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[    0.000000] pcpu-alloc: [0] 0 
[    0.000000] Built 1 zonelists, mobility grouping on.  Total pages: 16256
[    0.000000] Kernel command line: console=ttyS0,57600 rootfstype=squashfs,jffs2
[    0.000000] PID hash table entries: 256 (order: -2, 1024 bytes)
[    0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
[    0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Writing ErrCtl register=0004000f
[    0.000000] Readback ErrCtl register=0004000f
[    0.000000] Memory: 59608K/65536K available (3827K kernel code, 177K rwdata, 884K rodata, 160K init, 206K bss, 5928K reserved, 0K cma-reserved)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS: 256
[    0.000000] intc: using register map from devicetree
[    0.000000] CPU Clock: 580MHz
[    0.000000] timer_probe: no matching timers found
[    0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 6590553264 ns
[    0.000012] sched_clock: 32 bits at 290MHz, resolution 3ns, wraps every 7405115902ns
[    0.015381] Calibrating delay loop... 385.84 BogoMIPS (lpj=1929216)
[    0.087587] pid_max: default: 32768 minimum: 301
[    0.096940] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.109899] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.129707] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[    0.149087] futex hash table entries: 256 (order: -1, 3072 bytes)
[    0.161185] pinctrl core: initialized pinctrl subsystem
[    0.172737] NET: Registered protocol family 16
[    0.289763] mt7620-pci 10140000.pcie: Port 0 N_FTS = 1b105000
[    0.450786] PCI host bridge /pcie@10140000 ranges:
[    0.460128]  MEM 0x0000000020000000..0x000000002fffffff
[    0.470441]   IO 0x0000000010160000..0x000000001016ffff
[    0.498048] mt7621_gpio 10000600.gpio: registering 32 gpios
[    0.509263] mt7621_gpio 10000600.gpio: registering 32 gpios
[    0.520407] mt7621_gpio 10000600.gpio: registering 32 gpios
[    0.532263] PCI host bridge to bus 0000:00
[    0.540232] pci_bus 0000:00: root bus resource [mem 0x20000000-0x2fffffff]
[    0.553860] pci_bus 0000:00: root bus resource [io  0xffffffff]
[    0.565515] pci_bus 0000:00: root bus resource [??? 0x00000000 flags 0x0]
[    0.578930] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff]
[    0.594626] pci 0000:00:00.0: [14c3:0801] type 01 class 0x060400
[    0.594668] pci 0000:00:00.0: reg 0x10: [mem 0x00000000-0x7fffffff]
[    0.594683] pci 0000:00:00.0: reg 0x14: [mem 0x00000000-0x0000ffff]
[    0.594767] pci 0000:00:00.0: supports D1
[    0.594778] pci 0000:00:00.0: PME# supported from D0 D1 D3hot
[    0.595061] pci 0000:00:00.0: bridge configuration invalid ([bus 00-00]), reconfiguring
[    0.611014] pci 0000:01:00.0: [14c3:7662] type 00 class 0x028000
[    0.611091] pci 0000:01:00.0: reg 0x10: [mem 0x00000000-0x000fffff 64bit]
[    0.611149] pci 0000:01:00.0: reg 0x30: [mem 0x00000000-0x0000ffff pref]
[    0.611263] pci 0000:01:00.0: PME# supported from D0 D3hot D3cold
[    0.611484] pci_bus 0000:01: busn_res: [bus 01-ff] end is updated to 01
[    0.611504] pci_bus 0000:00: busn_res: [bus 00-ff] end is updated to 01
[    0.611555] pci 0000:00:00.0: BAR 0: no space for [mem size 0x80000000]
[    0.624541] pci 0000:00:00.0: BAR 0: failed to assign [mem size 0x80000000]
[    0.638269] pci 0000:00:00.0: BAR 8: assigned [mem 0x20000000-0x200fffff]
[    0.651687] pci 0000:00:00.0: BAR 9: assigned [mem 0x20100000-0x201fffff pref]
[    0.665962] pci 0000:00:00.0: BAR 1: assigned [mem 0x20200000-0x2020ffff]
[    0.679385] pci 0000:01:00.0: BAR 0: assigned [mem 0x20000000-0x200fffff 64bit]
[    0.693844] pci 0000:01:00.0: BAR 6: assigned [mem 0x20100000-0x2010ffff pref]
[    0.708101] pci 0000:00:00.0: PCI bridge to [bus 01]
[    0.717896] pci 0000:00:00.0:   bridge window [mem 0x20000000-0x200fffff]
[    0.731321] pci 0000:00:00.0:   bridge window [mem 0x20100000-0x201fffff pref]
[    0.750409] clocksource: Switched to clocksource MIPS
[    0.761526] NET: Registered protocol family 2
[    0.771050] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
[    0.784758] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[    0.797269] TCP: Hash tables configured (established 1024 bind 1024)
[    0.809963] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.821428] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.834046] NET: Registered protocol family 1
[    0.842627] PCI: CLS 0 bytes, default 32
[    0.846049] Crashlog allocated RAM at address 0x3f00000
[    0.857938] workingset: timestamp_bits=30 max_order=14 bucket_order=0
[    0.876407] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.887854] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.917881] io scheduler noop registered
[    0.925556] io scheduler deadline registered (default)
[    0.936565] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[    0.951941] console [ttyS0] disabled
[    0.958909] 10000c00.uartlite: ttyS0 at MMIO 0x10000c00 (irq = 28, base_baud = 2500000) is a 16550A
[    0.976837] console [ttyS0] enabled
[    0.990525] bootconsole [early0] disabled
[    1.006956] cacheinfo: Failed to find cpu0 device node
[    1.017167] cacheinfo: Unable to detect cache hierarchy for CPU 0
[    1.029998] spi-mt7621 10000b00.spi: sys_freq: 193333333
[    1.047747] m25p80 spi0.0: mx25l12805d (16384 Kbytes)
[    1.057867] 5 fixed-partitions partitions found on MTD device spi0.0
[    1.070458] Creating 5 MTD partitions on "spi0.0":
[    1.079945] 0x000000000000-0x000000040000 : "u-boot"
[    1.090814] 0x000000040000-0x000000060000 : "factory"
[    1.101744] 0x000000060000-0x000000090000 : "nvram"
[    1.112330] 0x000000090000-0x000000ff0000 : "firmware"
[    1.196007] 2 uimage-fw partitions found on MTD device firmware
[    1.207776] 0x000000090000-0x000000230000 : "kernel"
[    1.218528] 0x000000230000-0x000000ff0000 : "rootfs"
[    1.229226] mtd: device 5 (rootfs) set to be root filesystem
[    1.242027] 1 squashfs-split partitions found on MTD device rootfs
[    1.254333] 0x000000440000-0x000000ff0000 : "rootfs_data"
[    1.265957] 0x000000ff0000-0x000001000000 : "reserved"
[    1.277756] libphy: Fixed MDIO Bus: probed
[    1.297749] rt3050-esw 10110000.esw: link changed 0x00
[    1.309566] mtk_soc_eth 10100000.ethernet eth0: mediatek frame engine at 0xb0100000, irq 5
[    1.327807] NET: Registered protocol family 10
[    1.340894] Segment Routing with IPv6
[    1.348256] NET: Registered protocol family 17
[    1.357151] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
[    1.382828] 8021q: 802.1Q VLAN Support v1.8
[    1.401203] VFS: Mounted root (squashfs filesystem) readonly on device 31:5.
[    1.416062] Freeing unused kernel memory: 160K
[    1.424887] This architecture does not have kernel memory protection.
[    2.483008] init: Console is alive
[    2.489964] init: - watchdog -
[    2.640419] random: fast init done
[    3.838451] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[    4.057884] usbcore: registered new interface driver usbfs
[    4.068901] usbcore: registered new interface driver hub
[    4.079563] usbcore: registered new device driver usb
[    4.095915] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    4.110794] ehci-platform: EHCI generic platform driver
[    4.131474] phy phy-10120000.usbphy.0: remote usb device wakeup disabled
[    4.144760] phy phy-10120000.usbphy.0: UTMI 16bit 30MHz
[    4.155130] ehci-platform 101c0000.ehci: EHCI Host Controller
[    4.166552] ehci-platform 101c0000.ehci: new USB bus registered, assigned bus number 1
[    4.182374] ehci-platform 101c0000.ehci: irq 26, io mem 0x101c0000
[    4.220446] ehci-platform 101c0000.ehci: USB 2.0 started, EHCI 1.00
[    4.233881] hub 1-0:1.0: USB hub found
[    4.241767] hub 1-0:1.0: 1 port detected
[    4.253101] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    4.267112] ohci-platform: OHCI generic platform driver
[    4.277806] ohci-platform 101c1000.ohci: Generic Platform OHCI controller
[    4.291334] ohci-platform 101c1000.ohci: new USB bus registered, assigned bus number 2
[    4.307112] ohci-platform 101c1000.ohci: irq 26, io mem 0x101c1000
[    4.385398] hub 2-0:1.0: USB hub found
[    4.393337] hub 2-0:1.0: 1 port detected
[    4.406324] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[    4.431204] init: - preinit -
[    5.934933] rt3050-esw 10110000.esw: link changed 0x00
[    6.117851] random: procd: uninitialized urandom read (4 bytes read)
[    9.455194] rt3050-esw 10110000.esw: link changed 0x08
[    9.522561] jffs2: notice: (397) jffs2_build_xattr_subsystem: complete building xattr subsystem, 27 of xdatum (3 unchecked, 24 orphan) and 56 of xref (24 dead, 0 orphan) found.
[    9.558916] mount_root: switching to jffs2 overlay
[    9.596294] overlayfs: upper fs does not support tmpfile.
[    9.619023] urandom-seed: Seeding with /etc/urandom.seed
[    9.791948] procd: - early -
[    9.797755] procd: - watchdog -
[    9.946588] rt3050-esw 10110000.esw: link changed 0x18
[   10.442324] procd: - watchdog -
[   10.448824] procd: - ubus -
[   10.518046] random: ubusd: uninitialized urandom read (4 bytes read)
[   10.613221] random: ubusd: uninitialized urandom read (4 bytes read)
[   10.626407] random: ubusd: uninitialized urandom read (4 bytes read)
[   10.640057] procd: - init -
[   11.050810] kmodloader: loading kernel modules from /etc/modules.d/*
[   11.068670] ip6_tables: (C) 2000-2006 Netfilter Core Team
[   11.093016] Loading modules backported from Linux version v4.19-rc5-0-g6bf4ca7fbc85
[   11.108254] Backport generated by backports.git v4.19-rc5-1-0-g05571dcd
[   11.124903] ip_tables: (C) 2000-2006 Netfilter Core Team
[   11.145713] nf_conntrack version 0.5.0 (1024 buckets, 4096 max)
[   11.235322] xt_time: kernel timezone is -0000
[   11.402084] mt76_wmac 10300000.wmac: ASIC revision: 76280001
[   11.419788] mt76_wmac 10300000.wmac: Firmware Version: 20151201
[   11.431598] mt76_wmac 10300000.wmac: Build Time: 20151201183641
[   11.460424] firmware init done
[   11.627406] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[   11.664824] mt76x2e 0000:01:00.0: card - bus=0x1, slot = 0x0 irq=4
[   11.677348] mt76x2e 0000:01:00.0: ASIC revision: 76120044
[   12.698238] mt76x2e 0000:01:00.0: ROM patch build: 20141115060606a
[   12.716463] mt76x2e 0000:01:00.0: Firmware Version: 0.0.00
[   12.727401] mt76x2e 0000:01:00.0: Build: 1
[   12.735520] mt76x2e 0000:01:00.0: Build Time: 201507311614____
[   12.770429] mt76x2e 0000:01:00.0: Firmware running!
[   12.783337] ieee80211 phy1: Selected rate control algorithm 'minstrel_ht'
[   12.806407] PPP generic driver version 2.4.2
[   12.825803] NET: Registered protocol family 24
[   12.854328] kmodloader: done loading kernel modules from /etc/modules.d/*
[   13.763377] urandom_read: 5 callbacks suppressed
[   13.763387] random: jshn: uninitialized urandom read (4 bytes read)
[   16.776915] rt3050-esw 10110000.esw: link changed 0x00
[   20.301410] rt3050-esw 10110000.esw: link changed 0x08
[   20.809185] rt3050-esw 10110000.esw: link changed 0x18
[   23.281424] br-lan: port 1(eth0.1) entered blocking state
[   23.292188] br-lan: port 1(eth0.1) entered disabled state
[   23.303431] device eth0.1 entered promiscuous mode
[   23.312977] device eth0 entered promiscuous mode
[   23.440107] br-lan: port 1(eth0.1) entered blocking state
[   23.450869] br-lan: port 1(eth0.1) entered forwarding state
[   23.462186] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
[   23.642492] br-wan: port 1(eth0.2) entered blocking state
[   23.653280] br-wan: port 1(eth0.2) entered disabled state
[   23.664361] device eth0.2 entered promiscuous mode
[   23.800861] br-wan: port 1(eth0.2) entered blocking state
[   23.811622] br-wan: port 1(eth0.2) entered forwarding state
[   24.320837] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[   29.389421] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   29.430063] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   48.574723] random: crng init done
[   11.402084] mt76_wmac 10300000.wmac: ASIC revision: 76280001
[   11.419788] mt76_wmac 10300000.wmac: Firmware Version: 20151201
[   11.431598] mt76_wmac 10300000.wmac: Build Time: 20151201183641

mt76 info page mentions newer MediaTek chips aren’t supported. This device is from 2018, and the firmware seems to be from 2015. Might this be the issue?

Also, these:

Thu Nov  1 10:15:26 2018 daemon.notice netifd: wan (1208): udhcpc: started, v1.29.3
Thu Nov  1 10:15:27 2018 daemon.err odhcp6c[1220]: Failed to send RS (Permission denied)
Thu Nov  1 10:15:27 2018 daemon.err odhcp6c[1220]: Failed to send DHCPV6 message to ff02::1:2 (Permission denied)
Thu Nov  1 10:15:28 2018 user.notice mac80211: Failed command: iw phy phy1 set antenna all all
Thu Nov  1 10:15:28 2018 daemon.err odhcp6c[1220]: Failed to send DHCPV6 message to ff02::1:2 (Permission denied)
Thu Nov  1 10:15:28 2018 user.notice mac80211: Failed command: iw phy phy0 set antenna all all

and

Thu Nov  1 13:22:44 2018 daemon.err odhcp6c[1220]: Failed to send DHCPV6 message to ff02::1:2 (Permission denied)
Thu Nov  1 13:22:44 2018 daemon.err odhcp6c[1220]: Failed to send RS (Permission denied)
Thu Nov  1 13:22:48 2018 daemon.err odhcp6c[1220]: Failed to send RS (Permission denied)
Thu Nov  1 13:22:52 2018 daemon.err odhcp6c[1220]: Failed to send DHCPV6 message to ff02::1:2 (Permission denied)
Thu Nov  1 13:22:53 2018 authpriv.info dropbear[1583]: Child connection from 192.168.0.27:65032
Thu Nov  1 13:22:58 2018 authpriv.notice dropbear[1583]: Password auth succeeded for 'root' from 192.168.0.27:65032
Thu Nov  1 13:23:00 2018 kern.notice kernel: [   48.574723] random: crng init done
Thu Nov  1 13:23:08 2018 daemon.err odhcp6c[1220]: Failed to send DHCPV6 message to ff02::1:2 (Permission denied)

A little more digging (post from November 2017):

The R6120 has a MediaTek MT7628A, quite possibly the issue.

https://openwrt.org/toh/hwdata/netgear/netgear_r6120

https://wireless.wiki.kernel.org/en/users/drivers/mediatek

https://wikidevi.com/wiki/Mt76

Correction:
WLAN Hardware
MediaTek MT7628A, MediaTek MT7612E

Rereading the MT76 post I see:

7620/7628/7610/7612/7603/7615 will be added soon. 

so perhaps I am wrong.

This might be it, though I don't know the cause of the error:

Thu Nov  1 10:15:28 2018 user.notice mac80211: Failed command: iw phy phy1 set antenna all all
Thu Nov  1 10:15:28 2018 user.notice mac80211: Failed command: iw phy phy0 set antenna all all

Reading documentation I see failed antenna commands may be the case because radios are already up. Also, according to openwrt shell, command should be

iw phy phy1 set antenna all

After:

wifi down
root@OpenWrt:~# iw phy phy0 set antenna all
command failed: Not supported (-122)
root@OpenWrt:~#

I can confirm that at least with "OpenWrt SNAPSHOT r9355-94993a7" for the r6120 everything is working very well now ...

not sure if that did the trick: http://lists.openwrt.org/pipermail/openwrt-devel/2019-February/015687.html

1 Like

Confirmed, update fixed the issue. Thanks for letting me know.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.