Wi-Fi hot spot wont accept clients

Hi all,
This is my config:
Open VPN with kill switch.
Wire guard with kill switch.
I use one or the other.
If connected on cable all is OK. Router is TP link TL-WR802N.

However wifi hotspot wont accept clients. I can see they connect under wireless, but on device I am not getting IP and the connection is not successful.

What might be the issue? What do you need from me in terms of config files and how to produce them?

You’ve given no details that can be used to help.

Let’s see your config info:

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
2 Likes

Thanks for the reply.
This is what I have.

root@OpenWrt:~# ubus call system board
{
	"kernel": "5.10.176",
	"hostname": "OpenWrt",
	"system": "MediaTek MT7628AN ver:1 eco:2",
	"model": "TP-Link TL-WR802N v4",
	"board_name": "tplink,tl-wr802n-v4",
	"rootfs_type": "squashfs",
	"release": {
		"distribution": "OpenWrt",
		"version": "22.03.5",
		"revision": "r20134-5f15225c1e",
		"target": "ramips/mt76x8",
		"description": "OpenWrt 22.03.5 r20134-5f15225c1e"
	}
}
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd78:0908:e44e::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.99.1'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '0'

config interface 'Petvas_wifi'
	option proto 'dhcp'
	option metric '10'

config interface 'WG_ABZ'
	option proto 'wireguard'
	option private_key 'XXX'
	list addresses '10.9.71.3'
	option metric '5'
	option auto '0'

config wireguard_WG_ABZ
	option description 'OPENWRT'
	option public_key 'XXX'
	option private_key 'XXX'
	option preshared_key 'XXXX'
	list allowed_ips '0.0.0.0/0'
	option route_allowed_ips '1'
	option endpoint_host 'XXXXXX'
	option endpoint_port 'XXXX'
	option persistent_keepalive '25'

config interface 'OVPNIF'
	option proto 'none'
	option device 'tun0'

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/10300000.wmac'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option cell_density '0'

config wifi-iface 'wifinet0'
	option device 'radio0'
	option mode 'ap'
	option encryption 'none'
	option ssid 'OpenWrt-v4'

config wifi-iface 'wifinet1'
	option device 'radio0'
	option mode 'sta'
	option network 'Petvas_wifi'
	option ssid 'petvasabz'
	option encryption 'psk2'
	option key 'XXXX'

root@OpenWrt:~# cat /etc/config/dhcp

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'server'
	option ra 'server'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

Is this the network that has issues? It would be expected that this wouldn’t work because the network doesn’t have an address. What is the intent of this network (as compared to the predefined lan)?

1 Like

This is the syslog:

Sat Sep 16 15:59:07 2023 daemon.info hostapd: wlan0-1: STA 60:67:20:f2:82:00 IEEE 802.11: authenticated
Sat Sep 16 15:59:07 2023 daemon.info hostapd: wlan0-1: STA 60:67:20:f2:82:00 IEEE 802.11: authenticated
Sat Sep 16 15:59:07 2023 daemon.info hostapd: wlan0-1: STA 60:67:20:f2:82:00 IEEE 802.11: associated (aid 1)
Sat Sep 16 15:59:07 2023 daemon.notice hostapd: wlan0-1: AP-STA-CONNECTED 60:67:20:f2:82:00
Sat Sep 16 15:59:07 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan0-1 which has no address
Sat Sep 16 15:59:10 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan0-1 which has no address
Sat Sep 16 15:59:15 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan0-1 which has no address

This is exactly as I described.

2 Likes

Yes, this is it.
Router has only one port. I dont use it.
Set up is that wifi adapter is both AP and STA. STA is connected to my WI-FI at home (or a hotel). AP shares this internet to my clients.
It seems it is something to do with DHCP as clients hand at 'getting IP address' part.

I have also another configuration where I only have OVPN and this setup works.

What do you mean?
This is my wireless page. I can not see the IP of the STA, that must be given by my main router.

OpenWRT-v4 is the AP.

When trying to connect a client to it I got this for ~30 seconds:

Strange, the IP is 1.198 where it must be 192.168.99.XX

You cannot bridge WiFi sta to wifi ap. This needs to be routed, or configured as a Wds ir relayd.

2 Likes

I am not sure what you mean. :slight_smile:
I am not good with networks.
Could it have something to do I have wire guard interface? Using only OVPN, this AP works fine.

What are you trying to achieve. We will start with the purpose of this device and then we can figure out how your device should be configured.

2 Likes

I am trying to build a travel router with OPVN and WG VPN with kill switch.

OVPN configuration works OK, but it is too slow. I have WIFI sta which connects to a hotel WIFI and and AP which I connect my laptop to (getting 192.168.99.XX IP).
I added WG VPN. If connected on cable I can use either VPN and kill switch works.
However AP wont assign IP to client in this setup.

Maybe you should try the basic functions without the VPN.
One recommended thing is to use the travelmate package.
Please refer to this.

3 Likes

I think this is an overkill for what I need.
I am sure it is an easy solution to have AP and STA and wire guard.
Could anyone help with that?