Why there is a major verion at the end of package name?

Hey guys,
When I compiled some customized ipk package, I found the satisfy_dependencies package names are end with major version:

Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for libXXXX:
  • libpcap1 * libjson-c4 * libconfig11 *

So for example, when I tried to install the ipk, it told me libpcap1 is not installed, but actually libpcap is installed already. Any thought?


(Moved to the For Developers section.)

I'm guessing you didn't compile all the dependencies too...but I hope someone that compiles full packages often will chime in.

I am pretty sure these depended packages are installed.

Did you find where these got installed to?

What do you get when running echo $LD_LIBRARY_PATH ? Might just need to add the directory where those libs are into the ld_library_path variable.

This actually failed in the process of image builder. I tried to get this customized ipk into the BIN image by a imager builder. However, It told me these packages (with major version inside) not installed.

Maybe I can ask the question in this way, during the compilation of the packages, for same code, why sometime it gives something like libconfig11_xxxx.ipk, sometime it gives libconfig_xxx.ipk?

I’ve not run across that before. Can you link an example that’s done this?