Why is 2.4 Ghz so slow? (Fast 5 Ghz and Fast Ethernet)

I recently upgraded to OpenWrt 19.07.2 r10947-65030d81f3 and I can't figure out why the 2.4 Ghz is so slow on all devices. My ISP connection is 100 Mbps and I am able to get pretty close to that on 5 Ghz and via Ethernet, but the 2.4 Ghz network speed is variable, always maxing out between 10 - 25 Mbps no matter how close I am to the router. Bitrate on the 2.4 Ghz radio shows up as above 90 Mbp/s while 5 Ghz radio shows up as 60 Mbp/s.

So why is the 2.4 Ghz network so slow? I don't recall this being such a big difference before upgrading the firmware.

I've tried:
Scanning and switching from Channel 1 to 11 and back (no change)
Switching from 20 MHz to 40 MHz and back (no change)
Switched from N to legacy mode (download speeds dropped from 10 Mbp/s to 2 Mbp/s)

Have not:
Changed encryption mode from WPA2 PSK (CCMP) (I don't recall what mode I was using before the firmware update)
Changed transmission power (problem exists no matter how close I am to the router)
Tried moving clients over to 5 Ghz network (currently 9 clients connected via 2.4 and only 1 on the 5 Ghz. I thought maybe the load was using up bandwidth, but then why would switching to 5 Ghz still allow almost full speeds? The issue is some devices can't connect to 5 Ghz and it would be great to take advantage of the larger footprint of 2.4 Ghz).
Haven't changed any of the other settings under encryption or advanced tabs.

Details on my setup:
Hardware: TP-Link Archer C5 v1 (Qualcomm Atheros QCA9558 ver 1 rev 0)
OpenWrt 19.07.2 r10947-65030d81f3
Updated and with clean setup without reusing any previous configurations
Wifi Mode on both LAN radios: Access Point
Separate SSID for 2.4 Ghz and 5 Ghz networks
WMM Mode: On
SQM Qos is installed with download limit set to 0 and upload limit set to 4800 kbp/s (ISP caps at 5 Mbp/s and cloud backups were bringing the network down)

For the sake of experimenting, try with only one or two devices connected to the 2.4 GHz and see what you get.

Have you tried moving the location of your router/AP? Out of any closet in an open area is best. Wall construction can be problematic. Also look for a central area to the location being serviced. If it is one AP in a two-story home, place centrally on the top floor. Have you used a scanning tool such as WiFi Analyzer to assess the wifi traffic in your area? This can help you select channels with less traffic. SQM needs to be calibrated based on your download and upload speed. Good luck.

1 Like

How many other wireless systems can the router see on its scan?
I was just wondering if the problem could be interference on 2.4GHz.

2.4Ghz is susceptible to congestion which includes Bluetooth.

https://www.codejourney.net/2017/04/wifi-and-bluetooth-interference-diagnosing-and-fixing/

My understanding is to try to be 3 channels away from other channels in use. I use 8 as there were many channel 11 in my area - I think it is the default for many routers. Doing a local scan can help you pick a channel.

My understanding is that it's (almost) always best to stick to one of the non-overlapping channels : 1, 6, or 11.

For most of the world, "1, 6, or 11" is the obsolete advice. The modern one is "1, 5, 9, or 13", provided that you disabled 802.11b compatibility (otherwise the channels do overlap) and live in a country where channel 13 is legal.

1 Like

Sadly, no. You need to follow your environment - and commercial vendors stick to 1-6-11, the values guaranteed to be legal anywhere. While 1-5-9-13 would be better (outside of North America), that doesn't help you at all, unless all of your neighbours aren't doing the same.

1 Like

another flawed theory. try all 13 and set the one that give best range/speed. or fix your driver to work with auto setting

OK I finally had a chance to try everyone's suggestions (COVID-19 shelter in place means everyone in the house wants to use the internet ALL THE TIME lol).

  • Proximity and different locations of the router don't affect slow 2.4 Ghz speeds
  • The spectrum appears to be very congested across almost all channels. My neighbors apparently love their 2.4 Ghz, including one neighbor who is broadcasting at 40 Mhz across several channels (81 networks found, 44 displayed here)
  • Changing the channel to 1, 2, 3, 5, 8, 11 or the channel width to force 40 Mhz also does not affect speeds

Does it matter what band radio0 or radio1 are operating? Right now I have radio0 for 5 Ghz and radio1 for 2.4 Ghz, and radio0 says " Qualcomm Atheros QCA9880 802.11nac" and radio1 says " Generic 802.11bgn". Why does radio1 get the generic driver??

UPDATE: I reset to default settings, and when I saw that radio1 still said Generic 802.11bgn I decided to reinstall firmware. I reinstalled firmware from the same system upgrade .bin file I used the first time (maybe I should have redownloaded it) and set up everything like new. Generic driver still listed under radio1 for 2.4 Ghz network.

Result is the problem still persists: The 2.4 Ghz network is only 5%-20% as fast as the 5 Ghz network. UGGGGHHHHH. Thanks for all the suggestions!

It can be a good idea to edit the subject line of the topic to mention the router's model; maybe someone who has the same router would notice it, and then they can tell you if they have the same issue about the speed or the generic radio.