Why can't I build OpenWrt squashfs only on rpi(x)?

If I disable the ext4 option, I can no longer build ANY firmware. I never use the ext4 version, and it greatly increases my disk and memory usage. Is there any way to build the firmware w/o having ext4 enabled and not having everything break? This is specficially for a bcm2708 build target (all versions 18.04 and current) seem to be affacted.

That could be at least either the ext4 kernel modules built into the kernel, the same as "stand-alone" modules, or the ext4 image set.

Knowing which might help guide to a solution.

Without having looked into the RPi target, I would assume it to use ext4 for the overlay.

1 Like

Interestingly that is NOT the case. They use f2fs as the overlay for rpi.

When I go to the 'ext4' option in menuconfig, Its only a * can't do a 'module'. when I 'untick' it the image creation options for the root file system disappear.

As a final follow up to this new versions of openwrt seem to no longer have this problem.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.