Which Image for Ubiquiti AC AP Pro Gen2


I am trying to install the openwrt image on an Ubiquiti AC AP Pro Generation 2.

But I am not sure if this is the right image for the Generation 2?


Have anybody already installed it on a generation 2?

Thank you

Which second generation?
I have a UAP-AC PRO that I bought used, it's the round one,
with 2 ethernet port. If your's is the same,
You should be able to use that generic firmware.
I do however, build from source also creating a generic firmware.

I have three old generation and they are running fine on openwrt image. See picture

And the new generation 2 has an usb port to.

Picture old one

Picture generation 2 with usb port

on the top of the left hand site there is gen2

For clarification:

  • OLD = UniFi AP PRO (UAP-Pro)
  • NEW = UniFi AP AC PRO (UAP-AC-Pro) = Gen2

See the Table of Hardware: Firmware downloads for OpenWrt download links for both devices.

That is the same one I have, and the generic firmware works on it.

It might be a good idea to install pin header for the serial port since you
already have it open. :slight_smile:

Thanks a lot.

I tried it without TTL. I have pressed and hold the reset button, turned it on and after eight seconds the blue and white LED alternately blinking.

Next step I have successfully put the image with pumpin to the AP.
After restart the Stock firmware is still running.

On which port (J11, J1, J2) I have to install the pin header for the TTL?

mhel how did you flash it?

Thank you

It's been a while, I followed the Non Invasive procedure found here:

But I had to use serial port when I can't access the router because of bad settings,
I made and no access to web ui.

Also while your AP is still open, I suggest placing a heatsink on the QCA chips,
those chips heats up (I read somewhere it's one of major cause of fault for it), it doesn't hurt
if you put one there, the copper heatsink they sell for Raspberry Pi's are perfect for it.

If I remember it correctly you have to downgrade the original firmware if it's already using the latest.

It's interesting that this is also gen2:

but different jumper layout.
If I'm not mistaken I use J1 for the serial, but I can't confirm it I gave the hardware
to my nephew and it's halfway arround the world :slight_smile: now I only have occassional access to it
by teamviewer.
Oh and make sure you use a 3.3v for your serial connection ( I'm assuming you're using USB to serial converter ). Learnt it the hardway.

Thank you a lot.

I have downgraded it to 3.7.58.

I was connected by serial connection. It is J1.
Next I stopped the Boot.

I have used the steps from https://openwrt.org/toh/ubiquiti/unifiac

Part: Using U-Boot with serial console

I have set the ip address. My IP address is
But I can not transfer the new image?

Where is my mistake?

Thank you a lot


I am using pumpkin as TFTP transfer tool

It's been a while since I've done it.

Did you try the 'ssh / scp' instead?

Sorry I was very busy last time.

Now it is working fine. I did it with:

Non-invasive method using mtd

After that I have to change the network settings to get DHCP.
I have took the network item by TFTP and changed it.
Next step was to download the luci files to get the gui.

This topic is solved.

Thank`s a lot

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.