Where is a telnet *client*?

Hello.
subj or what can I use instead?

1 Like

There are many telnet clients out there. On Windows, I use Putty ( http://www.putty.org/ ) for a telnet client and WinSCP ( https://winscp.net/eng/download.php ) to move files back and forth.

Aaron Z

I can access to router. I would like to have something like "opkg install telnetc". Is it possible?

I'm sure that generally you'd be encouraged to use ssh instead. However opkg find *telnet* lists a few options, have you tried them?

There is nothing which allows for example "telnet IP 25".
I could find only mac-telnet.

Previously telnet client was part of the busybox multi-utility, but when the "telnet server" was disabled in 2015 and ssh was set to be the only login method, also the "telnet client" capability was removed.

https://github.com/openwrt/openwrt/commit/a35a7afc9f15b4c084c996ab0dbcd833b45f30d5

If you want to have telnet client easily available, compiling a firmware that has modified busybox options so that telnet is again in busybox is maybe the easiest option.

(I have not tried to look for separate telnet packages.)

And I am a huge fan of Cmder (www.cmder.net) on Windows. It offers all that Putty does, with an attractive GUI, built-in Linux-like shell and utilities, both telnet and ssh clients, and, oh, by the way, free.

1 Like

There is netcat (nc) in the Image.

You can use netcat like telnet.

By default the newline char is \n but you can send \r\n using CTRL+V + CTRL+M in the terminal.

For debugging SMTP/IMAP etc.pp it works out of the box:

TCP: nc host port
UDP: nc -u host port (this does not seem to supported out of the box)

4 Likes

There is simple stand alone telnet client.

Rejoyce, there's a telnet client soon in the repo :wink:

Diizzy,

I'd like to be able to install your package.

I see the last comment on the pull request is:

@wertarbyte
Do you still want this?

So I guess this means it's not going to be added to the repository of packages?

Thanks.

Scott

There is already a command to use telnet in LEDE. The command nc $IP $PORT can be used to ssh or telnet from the router itself.

nc 192.168.2.1 23
nc 192.168.3.1 22

1 Like

As I'm not really interested in being a maintainer which seems for be a requirement it remains unmerged, it does still work perfectly fine and is most likely "effortless" to maintain is there's nothing to update possibly apart from the breakage newer versions of GCC causes...