What shoud /etc/openwrt_release have?


#1

I have OpenMesh OM2P device, trying to upgrade it from 18.06.0 to 18.06.1, I tried using the GUI web interface and sysupgrade, but the version seems to be stuck at 18.06.0.

I also tried to force upgrade using sysupgrade -F -n flags.

root@OpenWrt:~# cat /etc/openwrt_release
DISTRIB_ID='OpenWrt'
DISTRIB_RELEASE='18.06.0'
DISTRIB_REVISION='r7188-b0b5c64c22'
DISTRIB_TARGET='ar71xx/generic'
DISTRIB_ARCH='mips_24kc'
DISTRIB_DESCRIPTION='OpenWrt 18.06.0 r7188-b0b5c64c22'
DISTRIB_TAINTS=''
root@OpenWrt:~#
root@OpenWrt:~# cat /etc/openwrt_version
r7188-b0b5c64c22
root@OpenWrt:~#
root@OpenWrt:~# cat /etc/opkg/distfeeds.conf
src/gz openwrt_core http://downloads.openwrt.org/releases/18.06.0/targets/ar71xx/generic/packages
src/gz openwrt_base http://downloads.openwrt.org/releases/18.06.0/packages/mips_24kc/base
src/gz openwrt_luci http://downloads.openwrt.org/releases/18.06.0/packages/mips_24kc/luci
src/gz openwrt_packages http://downloads.openwrt.org/releases/18.06.0/packages/mips_24kc/packages
src/gz openwrt_routing http://downloads.openwrt.org/releases/18.06.0/packages/mips_24kc/routing
src/gz openwrt_telephony http://downloads.openwrt.org/releases/18.06.0/packages/mips_24kc/telephony

#2

I'm not sure what issue you want to resolve here, are you looking to fix the upgrade problem or just asking for the info on the release file?


#3

Looks like you did not update after all.


#4

I'm asking for info, I want to know if the upgrade is successful and whether it is expected behavior or not?


#5

Every time time you sign into your router through SSH (or LuCI) you should see the current firmware version below the OpenWrt banner (or the status info) . So that should be enough for any user to spot if the upgrade process completed successfully or not.


#6

My Linksys ea3500 isn't able to upgrade to 18.06.1 for some reason, it's possible your device has the same problem, as others have already pointed out it would show 18.06.1 if the upgrade was successful.


#7

If your upgrade was successful, then "/etc/openwrt_release" should have been updated.


#8

Everything (including LuCI) shows the old version, it didn't actually upgrade then, thanks.


#9

I'll try to downgrade to 17.01.x then upgrade to 18.06.1 directly.

Is there away to flash other than sysupgrade that is more forceful? Maybe using mtd, but I'm afraid of bricking my router.


#10

I think tftp is pretty much forceful - its done by the bootloader enviromment so


#11

Finally got the time to get back to this, I used ap51-flash which uses tftp (I think) and it worked.


#12

We are now on 18.06.2


closed #13

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.