What routers will support WAN VLAN tagging?

I currently have a WRT1200AC on v15 Chaos Calmer w/ LuCi
I believe i have tried v17 and the VLAN tagging did not work but v15 does. I've had so much trouble in this regard that I'm ready to buy a new router.

Can anyone suggest a router where they know for sure VLAN tagging for the WAN port is working with LEDE?

Or better yet offer some advice on how to make LEDE work on my current router with the working bits of v15?

I have two models of devices I use quite regularly with OpenWRT. They both contain the Atheros AR8327 switch. I've never had issues with the AR8327.

I see your devices use a Marvel switch...I've only heard of success with Atheros devices. YMMV.

1 Like

As @lleachii points out, it is often more of a question of "how many" and not "if" on VLANs, at least with the well-supported Atheros switch chips.

I'd first try updating to a current version of LEDE/OpenWRT to see what your hardware reveals through the current drivers. Given that 17.01.4 is rather old, compared to current master, and that @jow just announced that kernel modules for snapshots are going to be available for some reasonable period of time after the build, I'd try a snapshot to see what might be coming in a "stable" build. (I run master builds all the time, with very few issues of any consequence.)

If the current drivers are not working, is there any way to inject whatever was in the v15 build that makes it work? DD-WRT just flat does not work for WAN vLAN tagging.

My ISP requires tagging packets on my WAN port with VLAN 201 to connect to their network. There is no modem for my ISP. The setting is under the WAN interface in LuCi and is pretty simple to set up but when it doesn't work, the WAN port will not get an IP address so no internet :frowning:

An x86 pc, with a tp link sg108e or zyxel gs1900 series smart switch

I would check that you have all your "config" files in a backup with

# sysupgrade -l

(lowercase "ell"), adding to /etc/sysupgrade.conf, if needed, then backup your configuration to your "desktop". You can then try a snapshot build and go back to Chaos Calmer if you need to (it's over two years old now). Backporting to Chaos Calmer would likely be anywhere from difficult to impossible, as the kernel has been updated since then across major versions (3.18 => 4.x).

You wouldn't set this on Interface, you'd set it on Switch.

And you probably need to change the WAN from untagged to tagged.

1 Like

What makes you think that the drivers are not working?
Have you searched the forum already? There are some topics where users report working VLAN tagging on WAN on a WRT1200AC.

1 Like


Again, that picture is under Interfaces... and it appears you already set the VLAN ID to 201. As I noted:

So, now you need to browse to Network > Switch, and as I stated:

EDIT: BTW your WAN6 needs to be changed as well. Its setting should had been "@wan". And that's version 15...NOT 17!

How I have this set up is working just fine in v15. I was just posting the picture so people know what I am talking about.
Also there is no Network > Switch page in this version I have.

I'll have to look into the new version again this weekend when I have all day to mess around with it.

VLAN tagging on wan should work on any router, even on ones where wan is a dedicated non-switch interface. Could you maybe share your current, non-working /etc/config/network? Maybe we can spot some obvious problem.

1 Like

I might start playing with it tonight but I'll post what I find out.

You need to add the switch manually to the /etc/config/network and then once it's there, LuCi will notice it and add a switch page to the menus, I think.

@naps1saps someone else had a similar setup need as you, follow the thread at Bypassing and removing CenturyLink Fiber Modem. The person had a wrt1900 but it's based on a marvel chipset as well. The thread used lede 17 as well.

OMG Alen, sir you win this round. At first it wasnt working then suddenly it did but the pictures made all the difference to boost my confidence. V15 doesn't have a switch page so that is why I just couldn't figure it out last time ROFL.

Can I load my backup from v15 into v17?

Unfortunately I don't think you should load backups from v15 to v17 because of some incompatibilities. You should at least take your backups from v15 just in case v17 doesn't work for you.

Guess not. The switch page is gone now and things are kinda messed up. Sigh.

Gotta figure out how to set up cloudflare again. It was annoying the first time -_-
Nevermind. Had to actually type IGNORE for the ssl cert instead of "ignoring" it