What is the utility of the bridge

To configure an AP-WLAN bridged with the Ethernet i need just to create an interface lan (WITHOUT option 'bridge') and an interface wan. what it makes "the bridge" really is these lines in the firewall

config forwarding
        option src              lan
        option dest             wan

/etc/config/network

config interface 'lan'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'

/etc/config/wireless

config wifi-iface
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrtAP'
	option encryption 'psk2'
	option key 'OpenWrtAP123'

What is the utility of the "option type bridge" in the interface 'lan'?

bridged interfaces work like one network. hence devices on the wired-lan and wifi will be able to "see" each other (think windows-filesharing, apple-tv, chromecast ...).

without the bridge, there will be two distinct networks with different adress ranges and you have to setup firewall rules for passing traffic.

2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.