What is the correct setup for a side Router running on LEDE

Dear Forum. I've got an master Router on, DNS connected with a LEDE side Router via phyical LAN cable(eth0).
LEDE set on static IP, DNS connected to a wireless AP via LAN (eth1). gateway Now, LEDE has internet access itself (can Ping openwrt.org), but wireless AP has no internet access at all, no matter DHCP on or off.

AP is fine as if I connect it directly to Master router, it works.

Is there anything i was missing here ?

Is this what you're trying to achieve?


1 Like

Your "side router" should not be routing anything, it is as @jeff said a dumb AP. You want to put all the ports in the same network bridge (either by hardware with the Ethernet switch or by software with the kernel br-lan bridge) and turn off the DHCP server. The only DHCP server on the network should be the one in the main network.

1 Like

I did switch off the DHCP on the "side" router but still no internet access.

Until you know how to reconfigure the "WAN" Ethernet port to be in the LAN bridge, don't use it. Connect the feed from your main router to one of the LAN ports.

I guess this might be the problem but I'm not sure.
As demonstrated in the figure below ESXi is on a HPE G10 microserver which only has two Ethernet port namely "eth0" and "eth1". "eth0" was phically attached to one of the LAN port in Linksys WRT3200ACM router (master router). In LEDE, "eth0" is assigned to LAN, "eth1" is not assigned to any, WAN was deleted. Perform like a switch I guess.

I then brideged "eth1" with LAN port "eth0" in the LAN interface setting. "eth1" was physicaly atached to a wireless AP mean to provide internet access.

Was this configuration problematic ?

You can check a few things:

  1. If you connect a laptop to eth1, do you get internet access?
  2. Is the AP getting IP?
  1. If you connect a laptop to eth1, do you get internet access?

no internet access

  1. Is the AP getting IP?

yes, It has got an IP

Your LEDE routers config is a bit unusual.
I would keep eth0 as WAN if not mandatory otherwise; so that config changes are minimal.
May be you can start with that first.
Once internet is working through the AP, just move eth0 from wan to lan, disable DHCP on lan, and then check.

Another thing you can try right now is, stop firewall and check.
"/etc/init.d/firewall stop"