What file to use when flashing from serial? (TL-WR740N)


I bricked my TP-Link TL-WR740N

When i have a serial connection to the router what image am i suppose to flash to the router the squashfs-factory.bin or the squashfs-sysupgrade.bin ?

I could very well be wrong, but I believe for serial, it's always the factory bin, as my understanding is the sysupgrade images don't have the kernel image (again I could very well be wrong, but that's been my understanding)

Usually the sysupgrade images do contain kernel. The only difference for most routers is extra packaging for factory so that OEM flash routine accepts the image.

For most routers factory = sysupgrade + OEM header.

Based on wiki, I think that sysupgrade version would be the right one for this router, as you apparently bypass the OEM GUI flash routine.

But that is just based on wiki and my gut feeling.




I'll try to flash the sysupgrade image.

Before doing a serial flash, you might try the following tutorial on the TP-Link forums...


Rename the stock TP-Link firmware file wr740vX_tp_recovery.bin

...replacing X with the version number of your router.

After recovering to stock, flash LEDE using squashfs-factory.bin

Tried it I have version 4.21 looks like this version doesn't have TFTP recovery.

I think it does...

Did you follow the tutorial? What happened when you tried it?

For flashing from the bootloader serial console (tftpboot from your TFTP server to RAM, erase flash, cp.b to flash), use a sysupgrade bin. The sysupgrade is byte for byte what should be placed in the flash chip, with no extra headers.

Most TP-Link models have a 128kbyte bootloader, and the firmware goes immediately after that (at location 9F020000). Be very careful not to erase or overwrite your bootloader or ART sections of flash.

1 Like

When i turn it on and hold reset the lock led is suppose to light up ... but it doesn't

After that lights up its suppose to get the firmware from the TFTP Server but it doesn't do that either :frowning:

Ok I'll do that.

Tnx :smiley:

Common issues I see when it doesn't work...

  1. TFTP server running on the attached computer does not have permissions through the firewall.

  2. Router not powered off first.

  3. Reset button not held in for at least 10 seconds after the router is powered on.

This is whats suppose to happen

(this is the TL-WR741ND but the same thing is suppose to happen)

But when I hold the reset button the lock doesn't light up, I tried multiple times, I think the TL-WR740N V4.21 version doesn't have this :frowning:

That video doesn't really show anything about using a TFTP server running on an attached computer to flash the router....it's just turning on the router and pressing the reset button.

Another reference, specific to the TL-WR740N...

If your router is hard-bricked, serial is your only other option.

Followed that exact article, didn't work. :frowning:

TL-WR740N's can be recovered using TFTP...unfortunately, yours is beyond that phase of recovery.

A USB to TTL cable may be your new best friend.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.