Websites load slow and video buffering all time

Hello, first of all I want to tell you my specs:

  • Model: Xiaomi AIoT AC2350
  • Update version: OpenWrt 22.03.3 r20028-43d71ad93e
  • Mode: PPPoE
  • Kernel: 5.10.161

Today I use my router with OpenWrt as main network router (previous I had router from provider Orange named Funbox 6).
I set up new router, it works but I'm getting annoying things:

  1. My internet speed decresed about ~100Mbps. I had stable 300Mbps previous, now getting around 204 Mbps. Tried to enable: Software flow offloading and Packet Steering but nothing helped me.

  2. After switch to new router every website, every youtube video/stream bufforing for like 30 sec. Sometimes images loads really slow. Why it's happens? How can I fix that? Currently it's really uncomfortable to even surf internet. :confused:

I will be gratefull for every help from you.

Could be an issue with the MTU of your new router. In practice, I had issues with the combination of some Fritzbox modems in combination with OpenWrt routers runming wireguard behind them. Lowering the mtu on wireguard interface to 1300 solved the issue of slow loading websites, buffering videos, etc. Might be worth to try on your outward facing interface.

1 Like

If you are using the device in router mode, then it seems this throughput is to be expected. While in theory the wifi 5 radio could reach 867 Mbps, real world speeds seem way lower. See here:

If this is a hard to swallow pill and you look for improvements, maybe OpenWrt master snapshot has improved on that front, so you could try that, or do some further digging and find out why and if the problems are fixable. I have read somewhere there is only limited open source support by some of the major chipset manufacturers. Qualcomm seems to be one of them.

The other alternative is to switch to another device. If so, I would recommend to do a quick check in the forum before you procure another device.

1 Like

I'm really sorry guys but I gave up. It was really annoying to even use Internet like this, and I cannot find way to fix that. Maybe in future I'll try with newer firmware but for now I've back to default setup which is not the best but for daily use stable.
I really appreciate that you wanted to help and thanks for yours replies.
Thanks and greetings.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.