WE826 (RV Wifi+4GX) running OpenWRT 18.06 WAN Port with Starlink

We have a WE826 (RV Wifi+4GX) running OpenWRT 18.06 which has the following configured.

We are trying to define a physical WAN0 port (Wan is currently used by WWAN0 which is the 4G), want to uplink a Starlink Dishy which has been setup as ethernet (192.168.100.1) to be physically connected to WAN port on the router, it isnt defined anywhere even like eth0.2 for wan, could i get some pointers on how we can add the physical wan port into the configuration and define it, also we need to setup dual routes with metrics, 0 and 10, preferring the starlink connection and if starlink is down route via 4G interface.

root@rvwifi:/etc/config# cat network

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option ifname 'eth0'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option ip6assign '60'
option ipaddr '192.168.1.1'

config interface 'wan'
option proto 'qmi'
option device '/dev/cdc-wdm0'

config globals 'globals'
option ula_prefix 'fd67:259e:cc26::/48'

==========================================================================

root@rvwifi:/etc/config# uci show network
network.loopback=interface
network.loopback.ifname='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.lan=interface
network.lan.ifname='eth0'
network.lan.type='bridge'
network.lan.proto='static'
network.lan.netmask='255.255.255.0'
network.lan.ip6assign='60'
network.lan.ipaddr='192.168.1.1'
network.wan=interface
network.wan.proto='qmi'
network.wan.device='/dev/cdc-wdm0'
network.globals=globals
network.globals.ula_prefix='fd67:259e:cc26::/48'
root@rvwifi:/etc/config#
root@rvwifi:/etc/config# ubus list network.interface.*
network.interface.lan
network.interface.loopback
network.interface.wan
network.interface.wan_4

This is a very old version that is EOL and unsupported. I'd recommend that you upgrade to 22.03 which is the current stable release, and your device is supported. In the process, you'll need to reset to defaults, so this should restore the wan port in the config, and then you should be good to go (you'll need to install the QMI packages and then reconfigure, of course, but that shouldn't be much of an issue; make a backup of your 18.06 config and you can use that as a reference while you reconfigure from scratch).

Thanks Mate. T it is. I just need to find out about the config and QMI Packages. I'll give it a crack after doing some more reading.

Ok so a bit of an Issue. The setup I am trying to achieve is 4G failback with Starlink as the primary. I think Openwrt 22.03.5 has a routing bug. When the router is configured without 4g The default route works fine through wwan0.
As soon as 4G is configured it takes over the default route and the wwan0 route is not re-issued.
Kernel IP routing table
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
default 10.174.211.172 0.0.0.0 UG 10 0 0 wwan0
10.174.211.168 * 255.255.255.248 U 10 0 0 wwan0
34.120.255.244 * 255.255.255.255 UH 0 0 0 eth0.2
100.64.0.0 * 255.192.0.0 U 0 0 0 eth0.2
192.168.1.0 * 255.255.255.0 U 0 0 0 br-lan
192.168.100.1 * 255.255.255.255 UH 0 0 0 eth0.2

Now if I disable "Use Default Gateway on the 4G WWAN0 interface. A default route is not added for eth0.2

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
default 10.174.211.172 0.0.0.0 UG 10 0 0 wwan0
10.174.211.168 * 255.255.255.248 U 10 0 0 wwan0
34.120.255.244 * 255.255.255.255 UH 0 0 0 eth0.2
100.64.0.0 * 255.192.0.0 U 0 0 0 eth0.2
192.168.1.0 * 255.255.255.0 U 0 0 0 br-lan
192.168.100.1 * 255.255.255.255 UH 0 0 0 eth0.2
root@OpenWrt:~#

No traffic is routed out either of the gateways. Tried to configure Mwan3 but that failed with routing also. Surely there is a simpler way than Mwan3 to have a primary route out eth0.2 and if i power off the starlink due to the monthly costs or in a populated area. I can have the data routed out the 4G wwan0 interface.

Thanks for all your help!

@Aussie Did you get this working?
I have the same router, and am looking to do the same upgrade so I can put Starlink on the WAN as primary and 4G as fail-over.