WDS fails on a pair of ax3000t devices

Hi,
I have two ax3000t devices, one router+ap, and the other, trying to set as a WDS client.
I followed https://openwrt.org/docs/guide-user/network/wifi/wifiextenders/wds exactly, and it seems that initially a simple ping test works, but immediately when I try to initiate some more traffic (e.g. visit google.com), the connection drops, the PC (client, connected by wire to the WDS client) loses IP address, and it takes 20-40 seconds for everything to be back up.
this happens over and over again, and if no usage is done at all, it will still happen every few minutes.
essentially, this setup is not usable at all at its current state.

unfortunately, nothing meaningful to me shows up in the logs. I marked the disconnection points of time in <DISCONNECTION>.

logs from the main AP:

Sun Jul  7 21:14:48 2024 kern.info kernel: [516943.617634] device phy1-ap0.sta1 entered promiscuous mode
Sun Jul  7 21:14:48 2024 kern.info kernel: [516943.623557] br-lan: port 10(phy1-ap0.sta1) entered blocking state
Sun Jul  7 21:14:48 2024 kern.info kernel: [516943.630038] br-lan: port 10(phy1-ap0.sta1) entered forwarding state
Sun Jul  7 21:14:48 2024 daemon.notice netifd: Network device 'phy1-ap0.sta1' link is up
Sun Jul  7 21:14:48 2024 daemon.notice hostapd: phy1-ap0: AP-STA-CONNECTED 46:f7:70:13:c2:1f auth_alg=open
Sun Jul  7 21:14:48 2024 daemon.info hostapd: phy1-ap0: STA 46:f7:70:13:c2:1f WPA: pairwise key handshake completed (RSN)
Sun Jul  7 21:14:48 2024 daemon.notice hostapd: phy1-ap0: EAPOL-4WAY-HS-COMPLETED 46:f7:70:13:c2:1f
Sun Jul  7 21:15:06 2024 daemon.info dnsmasq[1]: read /etc/hosts - 12 names
Sun Jul  7 21:15:06 2024 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 44 names
Sun Jul  7 21:15:06 2024 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 4 names
Sun Jul  7 21:15:06 2024 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Sun Jul  7 21:15:18 2024 user.notice pbr: Reloading pbr wan6 interface routing due to ifupdate of wan6 (wan)
Sun Jul  7 21:15:53 2024 daemon.notice hostapd: phy0-ap1: AP-STA-POLL-OK b4:60:ed:45:62:8b
Sun Jul  7 21:16:01 2024 daemon.info dnsmasq[1]: read /etc/hosts - 12 names
Sun Jul  7 21:16:01 2024 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 44 names
Sun Jul  7 21:16:01 2024 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 8 names
Sun Jul  7 21:16:01 2024 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Sun Jul  7 21:16:02 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.1) 0c:37:96:81:69:d6
Sun Jul  7 21:16:02 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.1) 192.168.1.170 0c:37:96:81:69:d6
Sun Jul  7 21:16:02 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan.1) 192.168.1.170 0c:37:96:81:69:d6
Sun Jul  7 21:16:02 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan.1) 192.168.1.170 0c:37:96:81:69:d6 user
<DISCONNECTION>
Sun Jul  7 21:19:58 2024 user.notice pbr: Reloading pbr wan6 interface routing due to ifupdate of wan6 (wan)
Sun Jul  7 21:20:49 2024 daemon.info dnsmasq[1]: read /etc/hosts - 12 names
Sun Jul  7 21:20:49 2024 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 44 names
Sun Jul  7 21:20:49 2024 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 4 names
Sun Jul  7 21:20:49 2024 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Sun Jul  7 21:20:50 2024 daemon.info dnsmasq[1]: read /etc/hosts - 12 names
Sun Jul  7 21:20:50 2024 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 44 names
Sun Jul  7 21:20:50 2024 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 8 names
Sun Jul  7 21:20:50 2024 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses

logs from the WDS client:

Sun Jul  7 21:15:29 2024 kern.info kernel: [   61.830290] mt7530-mdio mdio-bus:1f lan2: Link is Up - 1Gbps/Full - flow control rx/tx
Sun Jul  7 21:15:29 2024 kern.info kernel: [   61.838515] br-lan: port 1(lan2) entered blocking state
Sun Jul  7 21:15:29 2024 kern.info kernel: [   61.843994] br-lan: port 1(lan2) entered listening state
Sun Jul  7 21:15:29 2024 daemon.notice netifd: Network device 'lan2' link is up
Sun Jul  7 21:15:37 2024 kern.info kernel: [   70.235180] br-lan: port 1(lan2) entered learning state
Sun Jul  7 21:15:45 2024 kern.info kernel: [   78.555229] br-lan: port 1(lan2) entered forwarding state
Sun Jul  7 21:15:45 2024 kern.info kernel: [   78.560900] br-lan: topology change detected, propagating
<DISCONNECTION>
Sun Jul  7 21:17:52 2024 daemon.err uhttpd[1869]: [info] luci: accepted login on / for root from 192.168.1.170
Sun Jul  7 21:20:24 2024 kern.info kernel: [  356.963371] mt7530-mdio mdio-bus:1f lan2: Link is Down
Sun Jul  7 21:20:24 2024 kern.info kernel: [  356.968833] br-lan: port 1(lan2) entered disabled state
Sun Jul  7 21:20:24 2024 daemon.notice netifd: Network device 'lan2' link is down
Sun Jul  7 21:20:26 2024 kern.info kernel: [  359.346226] mt7530-mdio mdio-bus:1f lan2: Link is Up - 1Gbps/Full - flow control rx/tx
Sun Jul  7 21:20:26 2024 kern.info kernel: [  359.354463] br-lan: port 1(lan2) entered blocking state
Sun Jul  7 21:20:26 2024 kern.info kernel: [  359.359944] br-lan: port 1(lan2) entered listening state
Sun Jul  7 21:20:26 2024 daemon.notice netifd: Network device 'lan2' link is up
Sun Jul  7 21:20:35 2024 kern.info kernel: [  367.779427] br-lan: port 1(lan2) entered learning state
Sun Jul  7 21:20:43 2024 kern.info kernel: [  376.096946] br-lan: port 1(lan2) entered forwarding state
Sun Jul  7 21:20:43 2024 kern.info kernel: [  376.102620] br-lan: topology change detected, propagating

I thought it might be related to STP, I tried following WDS network - setting STP right - #4 by trendy but didn't help.

AP configurations:

root@AP:~# cat /etc/config/network
config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd93:427f:522f::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        option stp '1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.20'
        option netmask '255.255.255.0'
        option ip6assign '60'
        list dns '192.168.1.1'
        option gateway '192.168.1.1'

root@AP:~# cat /etc/config/wireless
config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/18000000.wifi'
        option channel '2'
        option band '2g'
        option htmode 'HE40'
        option country 'PA'
        option cell_density '0'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/18000000.wifi+1'
        option channel '100'
        option band '5g'
        option htmode 'HE160'
        option country 'PA'
        option cell_density '0'

config wifi-iface 'wifinet2'
        option device 'radio1'
        option mode 'sta'
        option network 'lan'
        option ssid 'AP_SSID'
        option encryption 'psk2'
        option key 'AP_KEY'
        option wds '1'

root@AP:~# cat /etc/config/dhcp
config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'
root@AP:~# cat /etc/config/firewall
config defaults
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'
        option flow_offloading '1'
        option flow_offloading_hw '1'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'

any help is appreciated

Which SNAPSHOT version are you using?

the AP is on 23.05.3 (self build), and I tried the WDS client on both 23.05.3 and latest snapshot from today

Disable offloading?

it's enabled on both units, but I assume you mean the WDS client right?
why should it make a difference?

both, hw offload may not handle 4addr well

1 Like

thank you, could you drop the bandwidth to HE80 on the WDS master, I assume you are actually in Panama due to the country code chosen?

after turning OFF HW offloading and WED on both routers, and setting HE80, the problem persists.
this time, the disconnections are not immediate, there is connectivity for ~5 minutes, and then it drops.
clients lose IP address, unable to get DHCP address, and it takes a long time for it to come back (had to manually reset the ethernet adapter twice for it to come back on my Windows PC).
I switched to US/channel 36 for testing - same result.

some logs:

WDS Client:

Mon Jul  8 18:49:31 2024 kern.info kernel: [72998.947588] phy1-sta0: associated
Mon Jul  8 18:49:31 2024 daemon.notice netifd: Network device 'phy1-sta0' link is up
Mon Jul  8 18:49:31 2024 daemon.notice wpa_supplicant[1531]: phy1-sta0: Associated with a4:a9:30:ce:b5:ef
Mon Jul  8 18:49:31 2024 daemon.notice wpa_supplicant[1531]: phy1-sta0: CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
Mon Jul  8 18:49:31 2024 daemon.notice wpa_supplicant[1531]: phy1-sta0: Unknown event 37
Mon Jul  8 18:49:31 2024 kern.debug kernel: [72998.963864] phy1-sta0: Limiting TX power to 21 (24 - 3) dBm as advertised by a4:a9:30:ce:b5:ef
Mon Jul  8 18:49:31 2024 daemon.notice wpa_supplicant[1531]: phy1-sta0: WPA: Key negotiation completed with a4:a9:30:ce:b5:ef [PTK=CCMP GTK=CCMP]
Mon Jul  8 18:49:31 2024 daemon.notice wpa_supplicant[1531]: phy1-sta0: CTRL-EVENT-CONNECTED - Connection to a4:a9:30:ce:b5:ef completed [id=2 id_str=]
Mon Jul  8 18:49:31 2024 kern.info kernel: [72999.070133] IPv6: ADDRCONF(NETDEV_CHANGE): phy1-sta0: link becomes ready
Mon Jul  8 18:49:31 2024 kern.info kernel: [72999.077230] br-lan: port 4(phy1-sta0) entered blocking state
Mon Jul  8 18:49:31 2024 kern.info kernel: [72999.083176] br-lan: port 4(phy1-sta0) entered forwarding state
Mon Jul  8 18:49:31 2024 daemon.notice wpa_supplicant[1531]: phy1-sta0: Unknown event 37
Mon Jul  8 18:50:02 2024 daemon.notice netifd: Interface 'lan' is now down
Mon Jul  8 18:50:02 2024 daemon.warn dnsmasq[1]: no servers found in /tmp/resolv.conf.d/resolv.conf.auto, will retry
Mon Jul  8 18:50:02 2024 kern.info kernel: [73029.625660] br-lan: port 4(phy1-sta0) entered disabled state
Mon Jul  8 18:50:02 2024 kern.info kernel: [73029.631708] br-lan: port 3(lan4) entered disabled state
Mon Jul  8 18:50:02 2024 kern.info kernel: [73029.637274] br-lan: port 2(lan3) entered disabled state
Mon Jul  8 18:50:02 2024 kern.info kernel: [73029.642837] br-lan: port 1(lan2) entered disabled state
Mon Jul  8 18:50:02 2024 kern.info kernel: [73029.650164] device lan2 left promiscuous mode
Mon Jul  8 18:50:02 2024 kern.info kernel: [73029.654944] br-lan: port 1(lan2) entered disabled state
Mon Jul  8 18:50:02 2024 kern.info kernel: [73029.763406] mt7530-mdio mdio-bus:1f lan2: Link is Down
Mon Jul  8 18:50:02 2024 kern.info kernel: [73029.772927] device lan3 left promiscuous mode
Mon Jul  8 18:50:02 2024 kern.info kernel: [73029.777645] br-lan: port 2(lan3) entered disabled state
Mon Jul  8 18:50:02 2024 kern.info kernel: [73029.823891] mt7530-mdio mdio-bus:1f lan3: Link is Down
Mon Jul  8 18:50:02 2024 kern.info kernel: [73029.865210] device lan4 left promiscuous mode
Mon Jul  8 18:50:02 2024 kern.info kernel: [73029.869928] br-lan: port 3(lan4) entered disabled state
Mon Jul  8 18:50:02 2024 kern.info kernel: [73029.913975] mt7530-mdio mdio-bus:1f lan4: Link is Down
Mon Jul  8 18:50:02 2024 kern.info kernel: [73029.921086] mtk_soc_eth 15100000.ethernet eth0: Link is Down
Mon Jul  8 18:50:02 2024 kern.info kernel: [73029.935365] device phy1-sta0 left promiscuous mode
Mon Jul  8 18:50:02 2024 kern.info kernel: [73029.940482] br-lan: port 4(phy1-sta0) entered disabled state
Mon Jul  8 18:50:02 2024 daemon.notice netifd: Interface 'lan' is disabled
Mon Jul  8 18:50:02 2024 daemon.notice netifd: Interface 'lan' has link connectivity loss
Mon Jul  8 18:50:02 2024 daemon.notice netifd: Interface 'lan' has link connectivity
Mon Jul  8 18:50:02 2024 kern.info kernel: [73030.248206] mtk_soc_eth 15100000.ethernet eth0: configuring for fixed/2500base-x link mode
Mon Jul  8 18:50:02 2024 kern.info kernel: [73030.256941] device eth0 left promiscuous mode
Mon Jul  8 18:50:02 2024 kern.info kernel: [73030.261726] mtk_soc_eth 15100000.ethernet eth0: Link is Up - 2.5Gbps/Full - flow control rx/tx
Mon Jul  8 18:50:02 2024 kern.info kernel: [73030.291951] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Mon Jul  8 18:50:02 2024 kern.info kernel: [73030.302592] mt7530-mdio mdio-bus:1f lan2: configuring for phy/gmii link mode
Mon Jul  8 18:50:02 2024 kern.info kernel: [73030.312857] br-lan: port 1(lan2) entered blocking state
Mon Jul  8 18:50:02 2024 kern.info kernel: [73030.318350] br-lan: port 1(lan2) entered disabled state
Mon Jul  8 18:50:02 2024 kern.info kernel: [73030.325133] device lan2 entered promiscuous mode
Mon Jul  8 18:50:02 2024 kern.info kernel: [73030.330014] device eth0 entered promiscuous mode
Mon Jul  8 18:50:02 2024 kern.info kernel: [73030.343034] mt7530-mdio mdio-bus:1f lan3: configuring for phy/gmii link mode
Mon Jul  8 18:50:02 2024 kern.info kernel: [73030.391902] br-lan: port 2(lan3) entered blocking state
Mon Jul  8 18:50:02 2024 kern.info kernel: [73030.397429] br-lan: port 2(lan3) entered disabled state
Mon Jul  8 18:50:02 2024 kern.info kernel: [73030.404462] device lan3 entered promiscuous mode
Mon Jul  8 18:50:02 2024 kern.info kernel: [73030.455623] mt7530-mdio mdio-bus:1f lan4: configuring for phy/gmii link mode
Mon Jul  8 18:50:02 2024 kern.info kernel: [73030.465905] br-lan: port 3(lan4) entered blocking state
Mon Jul  8 18:50:02 2024 kern.info kernel: [73030.471396] br-lan: port 3(lan4) entered disabled state
Mon Jul  8 18:50:02 2024 kern.info kernel: [73030.478634] device lan4 entered promiscuous mode
Mon Jul  8 18:50:02 2024 kern.info kernel: [73030.542112] br-lan: port 4(phy1-sta0) entered blocking state
Mon Jul  8 18:50:02 2024 kern.info kernel: [73030.548039] br-lan: port 4(phy1-sta0) entered disabled state
Mon Jul  8 18:50:02 2024 kern.info kernel: [73030.554194] device phy1-sta0 entered promiscuous mode
Mon Jul  8 18:50:03 2024 kern.info kernel: [73030.602024] br-lan: port 4(phy1-sta0) entered blocking state
Mon Jul  8 18:50:03 2024 kern.info kernel: [73030.607952] br-lan: port 4(phy1-sta0) entered forwarding state
Mon Jul  8 18:50:03 2024 kern.info kernel: [73030.614114] br-lan: port 3(lan4) entered blocking state
Mon Jul  8 18:50:03 2024 kern.info kernel: [73030.619602] br-lan: port 3(lan4) entered forwarding state
Mon Jul  8 18:50:03 2024 kern.info kernel: [73030.625327] br-lan: port 2(lan3) entered blocking state
Mon Jul  8 18:50:03 2024 kern.info kernel: [73030.630814] br-lan: port 2(lan3) entered forwarding state
Mon Jul  8 18:50:03 2024 kern.info kernel: [73030.636528] br-lan: port 1(lan2) entered blocking state
Mon Jul  8 18:50:03 2024 daemon.notice netifd: Interface 'lan' is enabled
Mon Jul  8 18:50:03 2024 daemon.notice netifd: Interface 'lan' is setting up now
Mon Jul  8 18:50:03 2024 kern.info kernel: [73030.642032] br-lan: port 1(lan2) entered forwarding state
Mon Jul  8 18:50:03 2024 daemon.notice netifd: Interface 'lan' is now up
Mon Jul  8 18:50:03 2024 daemon.info dnsmasq[1]: reading /tmp/resolv.conf.d/resolv.conf.auto
Mon Jul  8 18:50:03 2024 daemon.info dnsmasq[1]: using nameserver 192.168.1.1#53
Mon Jul  8 18:50:03 2024 daemon.info dnsmasq[1]: using only locally-known addresses for test
Mon Jul  8 18:50:03 2024 daemon.notice netifd: bridge 'br-lan' link is down
Mon Jul  8 18:50:03 2024 daemon.info dnsmasq[1]: using only locally-known addresses for onion
Mon Jul  8 18:50:03 2024 daemon.notice netifd: Interface 'lan' has link connectivity loss
Mon Jul  8 18:50:03 2024 daemon.info dnsmasq[1]: using only locally-known addresses for localhost
Mon Jul  8 18:50:03 2024 daemon.info dnsmasq[1]: using only locally-known addresses for local
Mon Jul  8 18:50:03 2024 daemon.info dnsmasq[1]: using only locally-known addresses for invalid
Mon Jul  8 18:50:03 2024 daemon.info dnsmasq[1]: using only locally-known addresses for bind
Mon Jul  8 18:50:03 2024 daemon.info dnsmasq[1]: using only locally-known addresses for lan
Mon Jul  8 18:50:03 2024 daemon.notice netifd: Network device 'lan2' link is down
Mon Jul  8 18:50:03 2024 daemon.notice netifd: Network device 'lan3' link is down
Mon Jul  8 18:50:03 2024 daemon.notice netifd: Network device 'lan4' link is down
Mon Jul  8 18:50:03 2024 daemon.notice netifd: Network device 'eth0' link is down
Mon Jul  8 18:50:03 2024 daemon.notice netifd: Network device 'eth0' link is up
Mon Jul  8 18:50:03 2024 daemon.notice netifd: bridge 'br-lan' link is up
Mon Jul  8 18:50:03 2024 daemon.notice netifd: Interface 'lan' has link connectivity
Mon Jul  8 18:50:03 2024 kern.info kernel: [73030.722859] br-lan: port 1(lan2) entered disabled state
Mon Jul  8 18:50:03 2024 kern.info kernel: [73030.730506] br-lan: port 2(lan3) entered disabled state
Mon Jul  8 18:50:03 2024 kern.info kernel: [73030.740452] br-lan: port 3(lan4) entered disabled state
Mon Jul  8 18:50:03 2024 user.notice firewall: Reloading firewall due to ifup of lan (br-lan)
Mon Jul  8 18:50:03 2024 daemon.info dnsmasq[1]: read /etc/hosts - 12 names
Mon Jul  8 18:50:03 2024 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 0 names
Mon Jul  8 18:50:05 2024 kern.info kernel: [73033.143345] mt7530-mdio mdio-bus:1f lan4: Link is Up - 1Gbps/Full - flow control rx/tx
Mon Jul  8 18:50:05 2024 kern.info kernel: [73033.151556] br-lan: port 3(lan4) entered blocking state
Mon Jul  8 18:50:05 2024 kern.info kernel: [73033.157034] br-lan: port 3(lan4) entered forwarding state
Mon Jul  8 18:50:05 2024 daemon.notice netifd: Network device 'lan4' link is up
Mon Jul  8 18:50:05 2024 kern.info kernel: [73033.185014] mt7530-mdio mdio-bus:1f lan3: Link is Up - 1Gbps/Full - flow control rx/tx
Mon Jul  8 18:50:05 2024 kern.info kernel: [73033.193236] br-lan: port 2(lan3) entered blocking state
Mon Jul  8 18:50:05 2024 kern.info kernel: [73033.198713] br-lan: port 2(lan3) entered forwarding state
Mon Jul  8 18:50:05 2024 daemon.notice netifd: Network device 'lan3' link is up
Mon Jul  8 18:50:05 2024 kern.info kernel: [73033.275042] mt7530-mdio mdio-bus:1f lan2: Link is Up - 1Gbps/Full - flow control off
Mon Jul  8 18:50:05 2024 kern.info kernel: [73033.283085] br-lan: port 1(lan2) entered blocking state
Mon Jul  8 18:50:05 2024 kern.info kernel: [73033.288563] br-lan: port 1(lan2) entered forwarding state
Mon Jul  8 18:50:05 2024 daemon.notice netifd: Network device 'lan2' link is up
Mon Jul  8 18:50:20 2024 daemon.notice netifd: Interface 'lan' is now down
Mon Jul  8 18:50:20 2024 daemon.warn dnsmasq[1]: no servers found in /tmp/resolv.conf.d/resolv.conf.auto, will retry
Mon Jul  8 18:50:20 2024 kern.info kernel: [73048.214435] br-lan: port 4(phy1-sta0) entered disabled state
Mon Jul  8 18:50:20 2024 kern.info kernel: [73048.220512] br-lan: port 3(lan4) entered disabled state
Mon Jul  8 18:50:20 2024 kern.info kernel: [73048.226056] br-lan: port 2(lan3) entered disabled state
Mon Jul  8 18:50:20 2024 kern.info kernel: [73048.231639] br-lan: port 1(lan2) entered disabled state
Mon Jul  8 18:50:20 2024 kern.info kernel: [73048.244206] device lan2 left promiscuous mode
Mon Jul  8 18:50:20 2024 kern.info kernel: [73048.249027] br-lan: port 1(lan2) entered disabled state
Mon Jul  8 18:50:20 2024 kern.info kernel: [73048.328728] mt7530-mdio mdio-bus:1f lan2: Link is Down
Mon Jul  8 18:50:20 2024 kern.info kernel: [73048.339155] device lan3 left promiscuous mode
Mon Jul  8 18:50:20 2024 kern.info kernel: [73048.343876] br-lan: port 2(lan3) entered disabled state
Mon Jul  8 18:50:20 2024 kern.info kernel: [73048.427933] mt7530-mdio mdio-bus:1f lan3: Link is Down
Mon Jul  8 18:50:20 2024 kern.info kernel: [73048.437635] device lan4 left promiscuous mode
Mon Jul  8 18:50:20 2024 kern.info kernel: [73048.442355] br-lan: port 3(lan4) entered disabled state
Mon Jul  8 18:50:20 2024 kern.info kernel: [73048.489076] mt7530-mdio mdio-bus:1f lan4: Link is Down
Mon Jul  8 18:50:20 2024 kern.info kernel: [73048.496217] mtk_soc_eth 15100000.ethernet eth0: Link is Down
Mon Jul  8 18:50:20 2024 kern.info kernel: [73048.543333] device phy1-sta0 left promiscuous mode
Mon Jul  8 18:50:20 2024 kern.info kernel: [73048.548484] br-lan: port 4(phy1-sta0) entered disabled state
Mon Jul  8 18:50:21 2024 daemon.notice netifd: Interface 'lan' is disabled
Mon Jul  8 18:50:21 2024 kern.info kernel: [73048.785145] mtk_soc_eth 15100000.ethernet eth0: configuring for fixed/2500base-x link mode
Mon Jul  8 18:50:21 2024 kern.info kernel: [73048.795075] device eth0 left promiscuous mode
Mon Jul  8 18:50:21 2024 kern.info kernel: [73048.799898] mtk_soc_eth 15100000.ethernet eth0: Link is Up - 2.5Gbps/Full - flow control rx/tx
Mon Jul  8 18:50:21 2024 kern.info kernel: [73048.806007] mt7530-mdio mdio-bus:1f lan2: configuring for phy/gmii link mode
Mon Jul  8 18:50:21 2024 kern.info kernel: [73048.859457] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Mon Jul  8 18:50:21 2024 kern.info kernel: [73048.866155] br-lan: port 1(lan2) entered blocking state
Mon Jul  8 18:50:21 2024 kern.info kernel: [73048.871697] br-lan: port 1(lan2) entered disabled state
Mon Jul  8 18:50:21 2024 kern.info kernel: [73048.878352] device lan2 entered promiscuous mode
Mon Jul  8 18:50:21 2024 kern.info kernel: [73048.883231] device eth0 entered promiscuous mode
Mon Jul  8 18:50:21 2024 kern.info kernel: [73048.933117] mt7530-mdio mdio-bus:1f lan3: configuring for phy/gmii link mode
Mon Jul  8 18:50:21 2024 kern.info kernel: [73048.943384] br-lan: port 2(lan3) entered blocking state
Mon Jul  8 18:50:21 2024 kern.info kernel: [73048.948911] br-lan: port 2(lan3) entered disabled state
Mon Jul  8 18:50:21 2024 kern.info kernel: [73048.955865] device lan3 entered promiscuous mode
Mon Jul  8 18:50:21 2024 kern.info kernel: [73049.021007] mt7530-mdio mdio-bus:1f lan4: configuring for phy/gmii link mode
Mon Jul  8 18:50:21 2024 kern.info kernel: [73049.031297] br-lan: port 3(lan4) entered blocking state
Mon Jul  8 18:50:21 2024 kern.info kernel: [73049.036789] br-lan: port 3(lan4) entered disabled state
Mon Jul  8 18:50:21 2024 kern.info kernel: [73049.043969] device lan4 entered promiscuous mode
Mon Jul  8 18:50:21 2024 kern.info kernel: [73049.117582] br-lan: port 4(phy1-sta0) entered blocking state
Mon Jul  8 18:50:21 2024 kern.info kernel: [73049.123507] br-lan: port 4(phy1-sta0) entered disabled state
Mon Jul  8 18:50:21 2024 kern.info kernel: [73049.129690] device phy1-sta0 entered promiscuous mode
Mon Jul  8 18:50:21 2024 kern.info kernel: [73049.187415] br-lan: port 4(phy1-sta0) entered blocking state
Mon Jul  8 18:50:21 2024 kern.info kernel: [73049.193343] br-lan: port 4(phy1-sta0) entered listening state
Mon Jul  8 18:50:21 2024 kern.info kernel: [73049.199424] br-lan: port 3(lan4) entered blocking state
Mon Jul  8 18:50:21 2024 kern.info kernel: [73049.204912] br-lan: port 3(lan4) entered listening state
Mon Jul  8 18:50:21 2024 kern.info kernel: [73049.210545] br-lan: port 2(lan3) entered blocking state
Mon Jul  8 18:50:21 2024 kern.info kernel: [73049.216031] br-lan: port 2(lan3) entered listening state
Mon Jul  8 18:50:21 2024 daemon.notice netifd: Interface 'lan' is enabled
Mon Jul  8 18:50:21 2024 daemon.notice netifd: Interface 'lan' is setting up now
Mon Jul  8 18:50:21 2024 daemon.notice netifd: Interface 'lan' is now up
Mon Jul  8 18:50:21 2024 daemon.info dnsmasq[1]: reading /tmp/resolv.conf.d/resolv.conf.auto
Mon Jul  8 18:50:21 2024 daemon.info dnsmasq[1]: using nameserver 192.168.1.1#53
Mon Jul  8 18:50:21 2024 daemon.info dnsmasq[1]: using only locally-known addresses for test
Mon Jul  8 18:50:21 2024 daemon.info dnsmasq[1]: using only locally-known addresses for onion
Mon Jul  8 18:50:21 2024 daemon.info dnsmasq[1]: using only locally-known addresses for localhost
Mon Jul  8 18:50:21 2024 daemon.info dnsmasq[1]: using only locally-known addresses for local
Mon Jul  8 18:50:21 2024 daemon.info dnsmasq[1]: using only locally-known addresses for invalid
Mon Jul  8 18:50:21 2024 daemon.info dnsmasq[1]: using only locally-known addresses for bind
Mon Jul  8 18:50:21 2024 daemon.info dnsmasq[1]: using only locally-known addresses for lan
Mon Jul  8 18:50:21 2024 daemon.notice netifd: bridge 'br-lan' link is down
Mon Jul  8 18:50:21 2024 daemon.notice netifd: Interface 'lan' has link connectivity loss
Mon Jul  8 18:50:21 2024 daemon.notice netifd: Network device 'lan2' link is down
Mon Jul  8 18:50:21 2024 daemon.notice netifd: Network device 'lan3' link is down
Mon Jul  8 18:50:21 2024 daemon.notice netifd: Network device 'lan4' link is down
Mon Jul  8 18:50:21 2024 daemon.notice netifd: Network device 'eth0' link is down
Mon Jul  8 18:50:21 2024 daemon.notice netifd: Network device 'eth0' link is up
Mon Jul  8 18:50:21 2024 kern.info kernel: [73049.297449] br-lan: port 2(lan3) entered disabled state
Mon Jul  8 18:50:21 2024 kern.info kernel: [73049.305203] br-lan: port 3(lan4) entered disabled state
Mon Jul  8 18:50:21 2024 user.notice firewall: Reloading firewall due to ifup of lan (br-lan)
Mon Jul  8 18:50:21 2024 daemon.info dnsmasq[1]: read /etc/hosts - 12 names
Mon Jul  8 18:50:21 2024 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 0 names
Mon Jul  8 18:50:24 2024 kern.info kernel: [73051.735206] mt7530-mdio mdio-bus:1f lan4: Link is Up - 1Gbps/Full - flow control rx/tx
Mon Jul  8 18:50:24 2024 kern.info kernel: [73051.743427] br-lan: port 3(lan4) entered blocking state
Mon Jul  8 18:50:24 2024 kern.info kernel: [73051.748919] br-lan: port 3(lan4) entered listening state
Mon Jul  8 18:50:24 2024 daemon.notice netifd: Network device 'lan4' link is up
Mon Jul  8 18:50:24 2024 kern.info kernel: [73051.963051] mt7530-mdio mdio-bus:1f lan3: Link is Up - 1Gbps/Full - flow control rx/tx
Mon Jul  8 18:50:24 2024 kern.info kernel: [73051.971273] br-lan: port 2(lan3) entered blocking state
Mon Jul  8 18:50:24 2024 kern.info kernel: [73051.976762] br-lan: port 2(lan3) entered listening state
Mon Jul  8 18:50:24 2024 daemon.notice netifd: Network device 'lan3' link is up
Mon Jul  8 18:50:24 2024 kern.info kernel: [73052.186578] mt7530-mdio mdio-bus:1f lan2: Link is Up - 1Gbps/Full - flow control off
Mon Jul  8 18:50:24 2024 kern.info kernel: [73052.194608] br-lan: port 1(lan2) entered blocking state
Mon Jul  8 18:50:24 2024 kern.info kernel: [73052.200104] br-lan: port 1(lan2) entered listening state
Mon Jul  8 18:50:24 2024 daemon.notice netifd: Network device 'lan2' link is up
Mon Jul  8 18:50:30 2024 kern.info kernel: [73057.555088] br-lan: port 4(phy1-sta0) entered learning state
Mon Jul  8 18:50:32 2024 kern.info kernel: [73060.114463] br-lan: port 2(lan3) entered learning state
Mon Jul  8 18:50:32 2024 kern.info kernel: [73060.120013] br-lan: port 3(lan4) entered learning state
Mon Jul  8 18:50:33 2024 kern.info kernel: [73060.754302] br-lan: port 1(lan2) entered learning state
Mon Jul  8 18:50:38 2024 kern.info kernel: [73065.873027] br-lan: port 4(phy1-sta0) entered forwarding state
Mon Jul  8 18:50:38 2024 kern.info kernel: [73065.879131] br-lan: topology change detected, sending tcn bpdu
Mon Jul  8 18:50:38 2024 daemon.notice netifd: bridge 'br-lan' link is up
Mon Jul  8 18:50:38 2024 daemon.notice netifd: Interface 'lan' has link connectivity
Mon Jul  8 18:50:38 2024 kern.info kernel: [73065.885329] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
Mon Jul  8 18:50:40 2024 kern.info kernel: [73068.432396] br-lan: port 3(lan4) entered forwarding state
Mon Jul  8 18:50:40 2024 kern.info kernel: [73068.438069] br-lan: topology change detected, sending tcn bpdu
Mon Jul  8 18:50:40 2024 kern.info kernel: [73068.444237] br-lan: port 2(lan3) entered forwarding state
Mon Jul  8 18:50:40 2024 kern.info kernel: [73068.449900] br-lan: topology change detected, sending tcn bpdu
Mon Jul  8 18:50:41 2024 kern.info kernel: [73069.072229] br-lan: port 1(lan2) entered forwarding state
Mon Jul  8 18:50:41 2024 kern.info kernel: [73069.077893] br-lan: topology change detected, sending tcn bpdu
Mon Jul  8 18:55:54 2024 daemon.notice netifd: Network device 'lan4' link is down
Mon Jul  8 18:55:54 2024 kern.info kernel: [73382.362652] br-lan: port 3(lan4) entered disabled state
Mon Jul  8 18:55:54 2024 kern.info kernel: [73382.363758] mt7530-mdio mdio-bus:1f lan4: Link is Down
Mon Jul  8 18:55:58 2024 kern.info kernel: [73386.255782] mt7530-mdio mdio-bus:1f lan4: Link is Up - 1Gbps/Full - flow control rx/tx
Mon Jul  8 18:55:58 2024 kern.info kernel: [73386.263994] br-lan: port 3(lan4) entered blocking state
Mon Jul  8 18:55:58 2024 kern.info kernel: [73386.269472] br-lan: port 3(lan4) entered listening state
Mon Jul  8 18:55:58 2024 daemon.notice netifd: Network device 'lan4' link is up
Mon Jul  8 18:56:07 2024 kern.info kernel: [73394.751484] br-lan: port 3(lan4) entered learning state
Mon Jul  8 18:56:15 2024 kern.info kernel: [73403.069428] br-lan: port 3(lan4) entered forwarding state
Mon Jul  8 18:56:15 2024 kern.info kernel: [73403.075098] br-lan: topology change detected, sending tcn bpdu
Mon Jul  8 19:04:52 2024 kern.warn kernel: [73919.741246] ------------[ cut here ]------------
Mon Jul  8 19:04:52 2024 kern.info kernel: [73919.746126] NETDEV WATCHDOG: eth0 (mtk_soc_eth): transmit queue 4 timed out
Mon Jul  8 19:04:52 2024 kern.warn kernel: [73919.753370] WARNING: CPU: 1 PID: 0 at 0xffffffc0086c46d4
Mon Jul  8 19:04:52 2024 kern.debug kernel: [73919.758935] Modules linked in: pppoe ppp_async nft_fib_inet nf_flow_table_ipv6 nf_flow_table_ipv4 nf_flow_table_inet pppox ppp_generic nft_reject_ipv6 nft_reject_ipv4 nft_reject_inet nft_reject nft_redir nft_quota nft_objref nft_numgen nft_nat nft_masq nft_log nft_limit nft_hash nft_flow_offload nft_fib_ipv6 nft_fib_ipv4 nft_fib nft_ct nft_counter nft_chain_nat nf_tables nf_nat nf_flow_table nf_conntrack mt7915e mt76_connac_lib mt76 mac80211 cfg80211 slhc nfnetlink nf_reject_ipv6 nf_reject_ipv4 nf_log_syslog nf_defrag_ipv6 nf_defrag_ipv4 libcrc32c compat cls_flower act_vlan crypto_safexcel cls_bpf act_bpf sch_tbf sch_ingress sch_htb sch_hfsc em_u32 cls_u32 cls_route cls_matchall cls_fw cls_flow cls_basic act_skbedit act_mirred act_gact sha1_generic seqiv md5 des_generic libdes authencesn authenc leds_gpio gpio_button_hotplug aquantia crc_ccitt
Mon Jul  8 19:04:52 2024 kern.debug kernel: [73919.833964] CPU: 1 PID: 0 Comm: swapper/1 Not tainted 5.15.150 #0
Mon Jul  8 19:04:52 2024 kern.debug kernel: [73919.840306] Hardware name: Xiaomi Mi Router AX3000T (OpenWrt U-Boot layout) (DT)
Mon Jul  8 19:04:52 2024 kern.debug kernel: [73919.847947] pstate: 40400005 (nZcv daif +PAN -UAO -TCO -DIT -SSBS BTYPE=--)
Mon Jul  8 19:04:52 2024 kern.debug kernel: [73919.855155] pc : 0xffffffc0086c46d4
Mon Jul  8 19:04:52 2024 kern.debug kernel: [73919.858892] lr : 0xffffffc0086c46d4
Mon Jul  8 19:04:52 2024 kern.debug kernel: [73919.862628] sp : ffffffc00800bdb0
Mon Jul  8 19:04:52 2024 kern.debug kernel: [73919.866191] x29: ffffffc00800bdb0 x28: 0000000000000140 x27: 00000000ffffffff
Mon Jul  8 19:04:52 2024 kern.debug kernel: [73919.873577] x26: 0000000000000000 x25: 0000000000000001 x24: ffffff8000c604c0
Mon Jul  8 19:04:52 2024 kern.debug kernel: [73919.880962] x23: 0000000000000000 x22: 0000000000000001 x21: ffffffc008a36000
Mon Jul  8 19:04:52 2024 kern.debug kernel: [73919.888346] x20: ffffff8000c60000 x19: 0000000000000004 x18: ffffffc008a4a2a8
Mon Jul  8 19:04:52 2024 kern.debug kernel: [73919.895731] x17: ffffffc007522000 x16: ffffffc008008000 x15: 00000000000006d8
Mon Jul  8 19:04:52 2024 kern.debug kernel: [73919.903117] x14: 0000000000000248 x13: ffffffc00800bae8 x12: ffffffc008aa22a8
Mon Jul  8 19:04:52 2024 kern.debug kernel: [73919.910502] x11: 712074696d736e61 x10: ffffffc008aa22a8 x9 : 0000000000000000
Mon Jul  8 19:04:52 2024 kern.debug kernel: [73919.917887] x8 : ffffffc008a4a258 x7 : ffffffc008a4a2a8 x6 : 0000000000000001
Mon Jul  8 19:04:52 2024 kern.debug kernel: [73919.925271] x5 : 0000000000000000 x4 : 0000000000000000 x3 : 0000000000000000
Mon Jul  8 19:04:52 2024 kern.debug kernel: [73919.932656] x2 : ffffff800ff40090 x1 : ffffffc007522000 x0 : 000000000000003f
Mon Jul  8 19:04:52 2024 kern.debug kernel: [73919.940042] Call trace:
Mon Jul  8 19:04:52 2024 kern.debug kernel: [73919.942737]  0xffffffc0086c46d4
Mon Jul  8 19:04:52 2024 kern.debug kernel: [73919.946126]  0xffffffc0080a5c50
Mon Jul  8 19:04:52 2024 kern.debug kernel: [73919.949516]  0xffffffc0080a64c8
Mon Jul  8 19:04:52 2024 kern.debug kernel: [73919.952905]  0xffffffc0080a6e18
Mon Jul  8 19:04:52 2024 kern.debug kernel: [73919.956295]  0xffffffc0080102bc
Mon Jul  8 19:04:52 2024 kern.debug kernel: [73919.959683]  0xffffffc00803b280
Mon Jul  8 19:04:52 2024 kern.debug kernel: [73919.963073]  0xffffffc00803b3a0
Mon Jul  8 19:04:52 2024 kern.debug kernel: [73919.966462]  0xffffffc008089564
Mon Jul  8 19:04:52 2024 kern.debug kernel: [73919.969851]  0xffffffc0080100e0
Mon Jul  8 19:04:52 2024 kern.debug kernel: [73919.973239]  0xffffffc00801584c
Mon Jul  8 19:04:52 2024 kern.debug kernel: [73919.976629]  0xffffffc00801614c
Mon Jul  8 19:04:52 2024 kern.debug kernel: [73919.980017]  0xffffffc008834770
Mon Jul  8 19:04:52 2024 kern.debug kernel: [73919.983406]  0xffffffc008834f24
Mon Jul  8 19:04:52 2024 kern.debug kernel: [73919.986795]  0xffffffc008011374
Mon Jul  8 19:04:52 2024 kern.debug kernel: [73919.990184]  0xffffffc008835504
Mon Jul  8 19:04:52 2024 kern.debug kernel: [73919.993573]  0xffffffc008069390
Mon Jul  8 19:04:52 2024 kern.debug kernel: [73919.996962]  0xffffffc0080695a4
Mon Jul  8 19:04:52 2024 kern.debug kernel: [73920.000351]  0xffffffc00801ebe0
Mon Jul  8 19:04:52 2024 kern.debug kernel: [73920.003740]  0xffffffc00883e2cc
Mon Jul  8 19:04:52 2024 kern.warn kernel: [73920.007130] ---[ end trace 23c73f70ccced5dc ]---
Mon Jul  8 19:08:08 2024 daemon.notice netifd: Network device 'lan4' link is down
Mon Jul  8 19:08:08 2024 kern.info kernel: [74115.753112] br-lan: port 3(lan4) entered disabled state
Mon Jul  8 19:08:08 2024 kern.info kernel: [74115.758960] mt7530-mdio mdio-bus:1f lan4: Link is Down
Mon Jul  8 19:08:12 2024 kern.info kernel: [74120.213689] mt7530-mdio mdio-bus:1f lan4: Link is Up - 1Gbps/Full - flow control rx/tx
Mon Jul  8 19:08:12 2024 kern.info kernel: [74120.221901] br-lan: port 3(lan4) entered blocking state
Mon Jul  8 19:08:12 2024 kern.info kernel: [74120.227378] br-lan: port 3(lan4) entered listening state
Mon Jul  8 19:08:12 2024 daemon.notice netifd: Network device 'lan4' link is up
Mon Jul  8 19:08:21 2024 kern.info kernel: [74128.649425] br-lan: port 3(lan4) entered learning state
Mon Jul  8 19:08:29 2024 kern.info kernel: [74136.967350] br-lan: port 3(lan4) entered forwarding state
Mon Jul  8 19:08:29 2024 kern.info kernel: [74136.973014] br-lan: topology change detected, sending tcn bpdu
Mon Jul  8 19:09:08 2024 daemon.notice netifd: Network device 'lan4' link is down
Mon Jul  8 19:09:08 2024 kern.info kernel: [74175.391551] br-lan: port 3(lan4) entered disabled state
Mon Jul  8 19:09:08 2024 kern.info kernel: [74175.397435] mt7530-mdio mdio-bus:1f lan4: Link is Down
Mon Jul  8 19:09:15 2024 kern.info kernel: [74183.076208] mt7530-mdio mdio-bus:1f lan4: Link is Up - 1Gbps/Full - flow control rx/tx
Mon Jul  8 19:09:15 2024 kern.info kernel: [74183.084412] br-lan: port 3(lan4) entered blocking state
Mon Jul  8 19:09:15 2024 kern.info kernel: [74183.089903] br-lan: port 3(lan4) entered listening state
Mon Jul  8 19:09:15 2024 daemon.notice netifd: Network device 'lan4' link is up
Mon Jul  8 19:09:24 2024 kern.info kernel: [74191.353856] br-lan: port 3(lan4) entered learning state
Mon Jul  8 19:09:32 2024 kern.info kernel: [74199.671802] br-lan: port 3(lan4) entered forwarding state
Mon Jul  8 19:09:32 2024 kern.info kernel: [74199.677472] br-lan: topology change detected, sending tcn bpdu

AP:

Mon Jul  8 18:49:25 2024 daemon.notice hostapd: phy1-ap0: AP-STA-DISCONNECTED 44:f7:70:13:c2:1f
Mon Jul  8 18:49:31 2024 daemon.info hostapd: phy1-ap0: STA 44:f7:70:13:c2:1f IEEE 802.11: authenticated
Mon Jul  8 18:49:31 2024 daemon.info hostapd: phy1-ap0: STA 44:f7:70:13:c2:1f IEEE 802.11: associated (aid 1)
Mon Jul  8 18:49:31 2024 daemon.notice hostapd: phy1-ap0: WDS-STA-INTERFACE-ADDED ifname=phy1-ap0.sta1 sta_addr=44:f7:70:13:c2:1f
Mon Jul  8 18:49:31 2024 kern.info kernel: [ 2688.665319] br-lan: port 10(phy1-ap0.sta1) entered blocking state
Mon Jul  8 18:49:31 2024 kern.info kernel: [ 2688.671705] br-lan: port 10(phy1-ap0.sta1) entered disabled state
Mon Jul  8 18:49:31 2024 kern.info kernel: [ 2688.678268] device phy1-ap0.sta1 entered promiscuous mode
Mon Jul  8 18:49:31 2024 kern.info kernel: [ 2688.684037] br-lan: port 10(phy1-ap0.sta1) entered blocking state
Mon Jul  8 18:49:31 2024 kern.info kernel: [ 2688.690435] br-lan: port 10(phy1-ap0.sta1) entered listening state
Mon Jul  8 18:49:31 2024 daemon.notice netifd: Network device 'phy1-ap0.sta1' link is up
Mon Jul  8 18:49:31 2024 daemon.notice hostapd: phy1-ap0: AP-STA-CONNECTED 44:f7:70:13:c2:1f auth_alg=open
Mon Jul  8 18:49:31 2024 daemon.info hostapd: phy1-ap0: STA 44:f7:70:13:c2:1f WPA: pairwise key handshake completed (RSN)
Mon Jul  8 18:49:31 2024 daemon.notice hostapd: phy1-ap0: EAPOL-4WAY-HS-COMPLETED 44:f7:70:13:c2:1f
Mon Jul  8 18:49:39 2024 kern.info kernel: [ 2696.785817] br-lan: port 10(phy1-ap0.sta1) entered learning state
Mon Jul  8 18:49:47 2024 kern.info kernel: [ 2705.103419] br-lan: port 10(phy1-ap0.sta1) entered forwarding state
Mon Jul  8 18:49:47 2024 kern.info kernel: [ 2705.109951] br-lan: topology change detected, propagating
Mon Jul  8 18:49:54 2024 daemon.info dnsmasq[1]: read /etc/hosts - 12 names
Mon Jul  8 18:49:54 2024 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 44 names
Mon Jul  8 18:49:54 2024 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 8 names
Mon Jul  8 18:49:54 2024 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Mon Jul  8 18:50:07 2024 daemon.info dnsmasq[1]: read /etc/hosts - 12 names
Mon Jul  8 18:50:07 2024 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 44 names
Mon Jul  8 18:50:07 2024 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 12 names
Mon Jul  8 18:50:07 2024 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Mon Jul  8 18:50:16 2024 daemon.info dnsmasq[1]: read /etc/hosts - 12 names
Mon Jul  8 18:50:16 2024 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 44 names
Mon Jul  8 18:50:16 2024 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 8 names
Mon Jul  8 18:50:16 2024 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Mon Jul  8 18:50:17 2024 daemon.info dnsmasq[1]: read /etc/hosts - 12 names
Mon Jul  8 18:50:17 2024 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 44 names
Mon Jul  8 18:50:17 2024 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 12 names
Mon Jul  8 18:50:17 2024 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Mon Jul  8 18:50:38 2024 kern.info kernel: [ 2755.593597] br-lan: port 10(phy1-ap0.sta1) received tcn bpdu
Mon Jul  8 18:50:38 2024 kern.info kernel: [ 2755.599535] br-lan: topology change detected, propagating
Mon Jul  8 18:50:40 2024 kern.info kernel: [ 2758.164366] br-lan: port 10(phy1-ap0.sta1) received tcn bpdu
Mon Jul  8 18:50:40 2024 kern.info kernel: [ 2758.170303] br-lan: topology change detected, propagating
Mon Jul  8 18:50:41 2024 kern.info kernel: [ 2758.792325] br-lan: port 10(phy1-ap0.sta1) received tcn bpdu
Mon Jul  8 18:50:41 2024 kern.info kernel: [ 2758.798248] br-lan: topology change detected, propagating
Mon Jul  8 18:50:47 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.1) 0c:37:96:81:69:d6
Mon Jul  8 18:50:47 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.1) 192.168.1.170 0c:37:96:81:69:d6
Mon Jul  8 18:50:47 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.1) 0c:37:96:81:69:d6
Mon Jul  8 18:50:47 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.1) 192.168.1.170 0c:37:96:81:69:d6
Mon Jul  8 18:50:47 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan.1) 192.168.1.170 0c:37:96:81:69:d6
Mon Jul  8 18:50:47 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan.1) 192.168.1.170 0c:37:96:81:69:d6 user
Mon Jul  8 18:50:48 2024 daemon.info dnsmasq[1]: read /etc/hosts - 12 names
Mon Jul  8 18:50:48 2024 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 44 names
Mon Jul  8 18:50:48 2024 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 12 names
Mon Jul  8 18:50:48 2024 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Mon Jul  8 18:50:48 2024 daemon.info dnsmasq[1]: read /etc/hosts - 12 names
Mon Jul  8 18:50:48 2024 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 44 names
Mon Jul  8 18:50:48 2024 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 12 names
Mon Jul  8 18:50:48 2024 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Mon Jul  8 18:50:57 2024 daemon.warn dnsmasq[1]: possible DNS-rebind attack detected: dns.msftncsi.com
Mon Jul  8 18:53:57 2024 user.notice pbr: Reloading pbr wan6 interface routing due to ifupdate of wan6 (wan)
Mon Jul  8 18:54:03 2024 user.notice pbr: Reloading pbr wan6 interface routing due to ifupdate of wan6 (wan)
Mon Jul  8 18:56:15 2024 kern.info kernel: [ 3092.788695] br-lan: port 10(phy1-ap0.sta1) received tcn bpdu
Mon Jul  8 18:56:15 2024 kern.info kernel: [ 3092.794628] br-lan: topology change detected, propagating
Mon Jul  8 18:56:16 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan.1) 192.168.1.170 0c:37:96:81:69:d6
Mon Jul  8 18:56:16 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan.1) 192.168.1.170 0c:37:96:81:69:d6 user
Mon Jul  8 18:56:17 2024 daemon.info dnsmasq[1]: read /etc/hosts - 12 names
Mon Jul  8 18:56:17 2024 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 44 names
Mon Jul  8 18:56:17 2024 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 8 names
Mon Jul  8 18:56:17 2024 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Mon Jul  8 18:56:18 2024 daemon.info dnsmasq[1]: read /etc/hosts - 12 names
Mon Jul  8 18:56:18 2024 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 44 names
Mon Jul  8 18:56:18 2024 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 12 names
Mon Jul  8 18:56:18 2024 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Mon Jul  8 18:57:05 2024 user.notice pbr: Reloading pbr wan6 interface routing due to ifupdate of wan6 (wan)
Mon Jul  8 19:01:16 2024 kern.info kernel: [ 3393.682464] TCP: request_sock_TCPv6: Possible SYN flooding on port 53. Sending cookies.  Check SNMP counters.
Mon Jul  8 19:01:36 2024 user.notice pbr: Reloading pbr wan6 interface routing due to ifupdate of wan6 (wan)
Mon Jul  8 19:01:44 2024 user.notice pbr: Reloading pbr wan6 interface routing due to ifupdate of wan6 (wan)
Mon Jul  8 19:01:54 2024 user.notice pbr: Reloading pbr wan6 interface routing due to ifupdate of wan6 (wan)

but these logs are not consistent, most of the time when there are disconnections, it looks like the logs in the first post

Thermal issues?

could be, but seems unreasonable.
using relayd on HE160 with HW offloading under heavier loads, there's no sudden disconnect issues (there are other issues though, which led me to trying WDS).

looking that error up, brings some github issues where the recommendation is using ethtool -K eth0 tso off, but I've no idea what it does.

is the AP configuration at all relevant?

This is related to the issue I'm having

Can you try patching and building from source? The patch needs to be done on the AP.

my AP does have VLANs, but my tests weren't done on any of them.
does it still apply?
p.s. do you have a branch with the patch, or simply the patch?

Here is one that can be applied on top of 23.05.3

save it in package/kernel/mac80211/patches/subsys as 900-mac80211-replace-xmit-func.patch

From 7a3d02e209d2aeec593354f8cbe8aeea3f222365 Mon Sep 17 00:00:00 2001
From: Filip Milivojevic <zekica@gmail.com>
Date: Tue, 9 Jul 2024 07:51:48 +0200
Subject: [PATCH] Replace ieee80211_subif_start_xmit with offload version

MT7681 has a firmware bug crashing when sending packets 482 bytes or smaller
so this patch replaces the normal subif_start_xmit with one
sending packets with 802.3 header.
---
 net/mac80211/iface.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/net/mac80211/iface.c b/net/mac80211/iface.c
index 8dd3c10..5ab8ef5 100644
--- a/net/mac80211/iface.c
+++ b/net/mac80211/iface.c
@@ -830,7 +830,7 @@ static const struct net_device_ops ieee80211_dataif_ops = {
 	.ndo_open		= ieee80211_open,
 	.ndo_stop		= ieee80211_stop,
 	.ndo_uninit		= ieee80211_uninit,
-	.ndo_start_xmit		= ieee80211_subif_start_xmit,
+	.ndo_start_xmit		= ieee80211_subif_start_xmit_8023,
 	.ndo_set_rx_mode	= ieee80211_set_multicast_list,
 	.ndo_set_mac_address 	= ieee80211_change_mac,
 	.ndo_select_queue	= ieee80211_netdev_select_queue,