WDS Client with 802.1x

I am a newbie to 802.1x configuration but know my way around OpenWrt. I have recently set up FreeRADIUS on my TD-W8980 V1 running OpenWrt 18.06.1 and it's working great so far. The problem that I am facing now is I cannot connect my Tp-Link MR3420 v2, running 17.01.6, to my main router as a WDS client. I have already installed the full version of wpad on the MR3420 with minimal LuCI.

I can successfully connect the AP to main router using the Routed Client method with relayd. It forwards the IPs and internet traffic but it does not seem to work with WDS anyhow. I know how the WDS configuration works and I believe I have set it up right but it's not working.

The config is as follows:

root@LEDE:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option delegate '0'
        option _orig_ifname 'eth1 wlan0 wlan0-1'
        option _orig_bridge 'true'
        option ifname 'eth1'
        option ipaddr '192.168.1.254'
        option gateway '192.168.1.1'
        option dns '192.168.1.1'

config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 4'

root@LEDE:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/ar934x_wmac'
        option channel '3'
        option country 'US'
        option txpower '21'
        option noscan '1'
        option htmode 'HT40'

config wifi-iface
        option device 'radio0'
        option mode 'sta'
        option network 'lan'
        option wds '1'
        option ssid 'OpenWrt RAID Server'
        option encryption 'wpa2+ccmp'
        option eap_type 'peap'
        option auth 'EAP-MSCHAPV2'
        option identity 'AP254'
        option password 'Ap254-270293'

config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'wpa2'
        option auth_server '192.168.1.1'
        option auth_secret 'ap254'
        option network 'lan'

Can someone provide any pointers? Thank you.