WDS client connects, but doesn't forward DHCP, doesn't route

Hey everyone!

Old-time user of DD-WRT here who just discovered OpenWRT, and I must say I'm thoroughly impressed! Why didn't I have a look a long time ago :slight_smile:

I'm having the following Problem. In a friend's home, I tried to set up a wireless repeater, because their main access point is in a really stupid location and cannot be moved easily. They had a TP-Link Archer C6 lying around, so why not use it for the job.

I flashed OpenWRT 21.02.2 according to this guide, and then followed this guide to establish a WDS connection to their main access point (which is an Icotera i6850 provided by their ISP).

Now I'm experiencing the following symptoms (I stopped the guide before the last step (creating a WiFi network on the repeater) to check whether it would get me online with a wired connection):

  • I don't get an IP assigned on the wired interface, so I set a manual one, which allows me to connect to the OpenWRT interface, but doesn't get me online
  • On the web interface, it seems like the WDS client connected just fine (screenshots attached)
  • On the main access point I don't see anything listed as a "WDS Slave".

Relevant IPs:

  • 192.168.1.1 the main AP
  • 192.168.1.2 the OpenWRT box to be used as a repeater
  • 192.168.1.3 my computer (statically assigned)

I suspect that the AP just doesn't want to talk to the OpenWRTs WDS client, especially because it's user manual contains the sentence

Number of slaves: number of i3550 devices working in a slave mode

indicating that it might be locked down to Icotera WDS clients...

So my questions are:

  • Is anything wrong about my config?
  • Is there anything I could try to make it work
  • What alternatives there are - I'm aware that it should be possible to have two different networks (i.e. one from the AP to OpenWRT, and the second one spawned by OpenWRT, with OpenWRT doing NAT, DHCP etc.), but I'd like to get a proper repeater bridge working if possible to get roaming.

Some config files and screenshots you might find useful:

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'pci0000:00/0000:00:00.0'
        option channel '36'
        option band '5g'
        option htmode 'VHT80'
        option cell_density '0'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/ahb/18100000.wmac'
        option channel '1'
        option band '2g'
        option htmode 'HT20'
        option disabled '1'

config wifi-iface 'wifinet0'
        option device 'radio0'
        option mode 'sta'
        option network 'WDSClient'
        option ssid 'JoeyLillyLaraBobby'
        option encryption 'psk2'
        option key 'My super secret wifi key'
        option wds '1'
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fde2:4e2b:8a30::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'
        option stp '1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.2'
        option gateway '192.168.1.1'

config interface 'wan'
        option device 'eth0.2'
        option proto 'dhcp'

config interface 'wan6'
        option device 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '2 3 4 5 0t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 0t'

config interface 'WDSClient'
        option proto 'dhcp'

config device
        option name 'eth0'

root@OpenWrt:~# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option localservice '1'
        option ednspacket_max '1232'
        list server '192.168.1.1'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'
        option ignore '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

Let me know if you need to see any more screenshots, I took a few more, but can only add one...

I'm not sure I follow - isn't the point of WDS that wlan0 doesn't have an IP, and that the LAN side has an IP within the same subnet?

1 Like

My apologies, was a misread.

1 Like