WAX206 Wireless AX or AC Upload Speed Disparity

Previously, I received some advice on turning on hardware flow offloading to fix the disparity between physical ethernet upload/download; that advice was spot on, and I now have parity in my ethernet/hardwired connections (around 1Gbps down/1Gbps down).

Currently after some troubleshooting and assistance from the community I was able to configure my WIFI with the following settings: AX on channel 48 (4240Mhz) and width of 160MHz (config below). Download works great, ~1Gbps but my upload is only at ~100Mbps. I'm currently using Firmware Version OpenWrt SNAPSHOT r23147-4b8b2f4f97. I appreciate any advice, thanks.

wax-wireless-performance

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'redacted'
        option channel '9'
        option band '2g'
        option htmode 'HT40'
        option cell_density '1'
        option country 'US'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'redacted'
        option band '5g'
        option htmode 'HE160'
        option cell_density '1'
        option channel '48'
        option rts '2347'
        option country 'US'

config wifi-iface 'wifinet0'
        option device 'radio0'
        option mode 'ap'
        option ssid 'redacted'
        option encryption 'sae-mixed'
        option isolate '1'
        option key 'redacted'
        option network 'lan'

config wifi-iface 'wifinet1'
        option device 'radio1'
        option mode 'ap'
        option ssid 'redacted'
        option encryption 'sae-mixed'
        option isolate '1'
        option key 'redacted'
        option network 'lan'

Could you test limiting your 5 GHz Wi-Fi to 11ac mode?

The speed problems should only affect 11ax mode. I think I see the same issue:

Big forum thread about this issue: [Solved] 802.11ax worse than 802.11ac with mt76 driver?

The fix of dropping 160 MHz channel support that Mediatek implemented was rejected by the community, because some green field users use 160 MHz channels in areas with no or few other 5 GHz network interference:

The solutions that have been found to fix 802.11ax 80 MHz channel bandwidth so far are:

  1. Remove IEEE80211_VHT_CAP_SUPP_CHAN_WIDTH_160MHZ | in mt7915/init.c as does this pull-request to the mt76 wifi: mt76: mt7915: disable VHT CAP SUPP CHAN WIDTH 160Mhz for mt7915. This will remove 160 MHz VHT (802.11ac) bandwidth capabilities, which may be undesired.
    There is also [MAC80211][mt76][remove mt7915 BW160 support]
  2. Some report switching to 160 MHz bandwidth solved their issue. To make this work, your client devices may have to support 160 MHz bandwidth. Not sure.
    Maybe there are more solutions, which have not been published by Mediatek yet, but this is what is publicly known at the very moment about this problem.

Also I suggest to avoid sae-mixed mode. Instead better create two SSIDs, one with sae WPA3-only and another with WPA2 CCMP forced for stations that don’t yet support WPA3.

Thanks for your quick reply, I am seeing the same issue with AC that I did with AX. Please see below, I also updated the security info to avoid mixed mode. Thanks again.

image

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'redacted'
        option channel '9'
        option band '2g'
        option htmode 'HT40'
        option cell_density '1'
        option country 'US'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'redacted'
        option band '5g'
        option htmode 'VHT160'
        option cell_density '1'
        option channel '48'
        option rts '2347'
        option country 'US'

config wifi-iface 'wifinet0'
        option device 'radio0'
        option mode 'ap'
        option ssid 'redacted'
        option encryption 'psk2'
        option isolate '1'
        option key 'redacted'
        option network 'lan'

config wifi-iface 'wifinet1'
        option device 'radio1'
        option mode 'ap'
        option ssid 'redacted'
        option encryption 'sae'
        option isolate '1'
        option key 'redacted'
        option network 'lan'

Ok. Do you you also see the same issues with 11ac mode and an 80 MHz channel? I get 400 Mbit/s upload through multiple walls on 11ac 80 MHz.

Also: do you have a Linux laptop or desktop computer able to run iperf3 to test local Wi-Fi speeds just between station and router?

I still think we as OpenWrt community should accept the Mediatek workaround and drop 160 MHz channel support to get expected 11ax performance. The majority of users in dense city environment would benefit of 11ax improvements and the minority of users in green field use cases with no or only few other 5 GHz interfering networks around could compile their own driver with 160 MHz channel support.

So this is what I'm getting with VHT80
image

I will be able to use a windows laptop w/ wsl tomorrow. Let me know what I need to run using iperf3 and I'll get it done.

Thanks again!

Thanks for your test, again.

For iperf3 local throughput testing on the OpenWrt device run:

opkg update
opkg install iperf3
iperf3 -s -D

on the client:
iperf3 -c <IP address of the OpenWrt iperf3 server>

There are more options to play with iperf3 but I would start with this. After finishing tests I would run
killall iperf3
to quit the iperf3 server.

upload also depends on hardware and software of your client device. What client device do you use to connect to your wax206 accesspoint?

1 Like

These are the results for vht160:

1560.0 Mbit/s, 160 MHz, VHT-MCS 9, VHT-NSS 2
1733.3 Mbit/s, 160 MHz, VHT-MCS 9, VHT-NSS 2, Short GI

iperf3 -c 192.168.50.1
Connecting to host 192.168.50.1, port 5201
[  5] local 172.28.12.19 port 43388 connected to 192.168.50.1 port 5201
[ ID] Interval           Transfer     Bitrate         Retr  Cwnd
[  5]   0.00-1.00   sec  70.3 MBytes   589 Mbits/sec    0   1.91 MBytes
[  5]   1.00-2.00   sec  86.2 MBytes   724 Mbits/sec    0   1.91 MBytes
[  5]   2.00-3.00   sec  91.2 MBytes   765 Mbits/sec    0   1.91 MBytes
[  5]   3.00-4.00   sec  91.2 MBytes   766 Mbits/sec    0   1.91 MBytes
[  5]   4.00-5.00   sec  90.0 MBytes   755 Mbits/sec    0   1.91 MBytes
[  5]   5.00-6.00   sec  92.5 MBytes   776 Mbits/sec    0   1.91 MBytes
[  5]   6.00-7.00   sec  92.5 MBytes   776 Mbits/sec    0   1.91 MBytes
[  5]   7.00-8.00   sec  91.2 MBytes   765 Mbits/sec    0   1.91 MBytes
[  5]   8.00-9.00   sec  91.2 MBytes   765 Mbits/sec    0   1.91 MBytes
[  5]   9.00-10.00  sec  88.8 MBytes   745 Mbits/sec    0   1.91 MBytes
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-10.00  sec   885 MBytes   743 Mbits/sec    0             sender
[  5]   0.00-10.02  sec   884 MBytes   740 Mbits/sec                  receiver

These are the results for VHT80:

866.7 Mbit/s, 80 MHz, VHT-MCS 9, VHT-NSS 2, Short GI
866.7 Mbit/s, 80 MHz, VHT-MCS 9, VHT-NSS 2, Short GI

iperf3 -c 192.168.50.1
Connecting to host 192.168.50.1, port 5201
[  5] local 172.28.12.19 port 43384 connected to 192.168.50.1 port 5201
[ ID] Interval           Transfer     Bitrate         Retr  Cwnd
[  5]   0.00-1.00   sec  52.8 MBytes   443 Mbits/sec    0   1.92 MBytes
[  5]   1.00-2.00   sec  63.8 MBytes   535 Mbits/sec    0   1.92 MBytes
[  5]   2.00-3.00   sec  75.0 MBytes   629 Mbits/sec    0   1.92 MBytes
[  5]   3.00-4.00   sec  76.2 MBytes   640 Mbits/sec    0   1.92 MBytes
[  5]   4.00-5.00   sec  75.0 MBytes   629 Mbits/sec    0   1.92 MBytes
[  5]   5.00-6.00   sec  75.0 MBytes   629 Mbits/sec    0   1.92 MBytes
[  5]   6.00-7.00   sec  76.2 MBytes   640 Mbits/sec    0   1.92 MBytes
[  5]   7.00-8.00   sec  76.2 MBytes   640 Mbits/sec    0   1.92 MBytes
[  5]   8.00-9.00   sec  73.8 MBytes   619 Mbits/sec    0   1.92 MBytes
[  5]   9.00-10.00  sec  77.5 MBytes   650 Mbits/sec    0   1.92 MBytes
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-10.00  sec   722 MBytes   605 Mbits/sec    0             sender
[  5]   0.00-10.03  sec   721 MBytes   603 Mbits/sec                  receiver

Note: This machine is using an Intel(R) Wireless-AC 9260 160MHz and the 172.28.12.19 address is related to WSL

Performance on this adapter on VHT is way better than the device I was testing before. With this device VHT80 is more balanced when I speed test online and VHT160 has superior download. I'm going to try this again with HE80/160 as soon as I receive an adapter for it; the AX devices I currently have attached are not capable of running iperf3. Thanks!

Thanks for the update. I would have expected to get more out of VHT160.

Which 11ax devices do you have?

I would be interested if you also experience less TCP local wi-fi throughput over 11ax than over 11ac, with 11ax capable clients, with some common obstacles between the router and the client as real world use case.

These are my AX results from a OnePlus9 Phone; it's pretty terrible :smiley:
HE80 is definitely better than HE160 but still awful.
I'm definitely going to try from laptop soon.

Side note: I tried the windows binaries on the AC160 machine... WSL was consistently better than the native windows binary. Go figure. ¯\_(ツ)_/¯

HE160

2161.3 Mbit/s, 160 MHz, HE-MCS 10, HE-NSS 2
2041.2 Mbit/s, 160 MHz, HE-MCS 10, HE-NSS 2, HE-GI 1

Connecting to host 192.168.50.1, port 5201
[  5] local 192.168.50.96 port 39822 connected to 192.168.50.1 port 5201
[ ID] Interval           Transfer     Bitrate         Retr  Cwnd
[  5]   0.00-1.00   sec  15.9 MBytes   133 Mbits/sec  311   72.1 KBytes       
[  5]   1.00-2.00   sec  16.5 MBytes   138 Mbits/sec  203   63.6 KBytes       
[  5]   2.00-3.00   sec  14.6 MBytes   123 Mbits/sec  224   62.2 KBytes       
[  5]   3.00-4.00   sec  12.6 MBytes   106 Mbits/sec  156   66.5 KBytes       
[  5]   4.00-5.00   sec  14.4 MBytes   121 Mbits/sec  178   62.2 KBytes       
[  5]   5.00-6.00   sec  13.0 MBytes   109 Mbits/sec  177   53.7 KBytes       
[  5]   6.00-7.00   sec  16.6 MBytes   139 Mbits/sec  180   53.7 KBytes       
[  5]   7.00-8.00   sec  13.1 MBytes   110 Mbits/sec  179   63.6 KBytes       
[  5]   8.00-9.00   sec  15.6 MBytes   131 Mbits/sec  159   63.6 KBytes       
[  5]   9.00-10.00  sec  12.8 MBytes   107 Mbits/sec  154   74.9 KBytes       
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-10.00  sec   145 MBytes   122 Mbits/sec  1921             sender
[  5]   0.00-10.00  sec   145 MBytes   121 Mbits/sec                  receiver

iperf Done.

HE80

1200.9 Mbit/s, 80 MHz, HE-MCS 11, HE-NSS 2
1134.2 Mbit/s, 80 MHz, HE-MCS 11, HE-NSS 2, HE-GI 1

Connecting to host 192.168.50.1, port 5201
[  5] local 192.168.50.96 port 40632 connected to 192.168.50.1 port 5201
[ ID] Interval           Transfer     Bitrate         Retr  Cwnd
[  5]   0.00-1.00   sec  19.4 MBytes   162 Mbits/sec  268   69.3 KBytes       
[  5]   1.00-2.00   sec  16.5 MBytes   138 Mbits/sec  135   74.9 KBytes       
[  5]   2.00-3.00   sec  17.8 MBytes   149 Mbits/sec  159   65.0 KBytes       
[  5]   3.00-4.00   sec  18.6 MBytes   156 Mbits/sec   94    119 KBytes       
[  5]   4.00-5.00   sec  36.4 MBytes   305 Mbits/sec  135    157 KBytes       
[  5]   5.00-6.00   sec  37.9 MBytes   318 Mbits/sec   90    194 KBytes       
[  5]   6.00-7.00   sec  35.9 MBytes   301 Mbits/sec  135    144 KBytes       
[  5]   7.00-8.00   sec  36.2 MBytes   304 Mbits/sec   90    177 KBytes       
[  5]   8.00-9.00   sec  34.1 MBytes   286 Mbits/sec  135    153 KBytes       
[  5]   9.00-10.00  sec  29.5 MBytes   247 Mbits/sec  265    199 KBytes       
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-10.00  sec   282 MBytes   237 Mbits/sec  1506             sender
[  5]   0.00-10.00  sec   281 MBytes   236 Mbits/sec                  receiver

iPerf3 by Ping Master - Network Tools & IP Utilities

1 Like

VHT (802.11ac) results from your phone would be helpful as it would be the same hardware + same location.

Sure thing. Like I mentioned before I trust the results from the WSL box more, I will rerun as soon as I receive AX adapter.

Results from VHT160 (OnePlus9)

1733.3 Mbit/s, 160 MHz, VHT-MCS 9, VHT-NSS 2, Short GI
1733.3 Mbit/s, 160 MHz, VHT-MCS 9, VHT-NSS 2, Short GI

Connecting to host 192.168.50.1, port 5201
[  5] local 192.168.50.96 port 42866 connected to 192.168.50.1 port 5201
[ ID] Interval           Transfer     Bitrate         Retr  Cwnd
[  5]   0.00-1.00   sec  35.8 MBytes   299 Mbits/sec  468    170 KBytes       
[  5]   1.00-2.00   sec  35.1 MBytes   295 Mbits/sec  225    130 KBytes       
[  5]   2.00-3.01   sec  34.4 MBytes   287 Mbits/sec  135    143 KBytes       
[  5]   3.01-4.00   sec  37.6 MBytes   317 Mbits/sec  180    139 KBytes       
[  5]   4.00-5.00   sec  34.6 MBytes   291 Mbits/sec  180    119 KBytes       
[  5]   5.00-6.00   sec  26.1 MBytes   219 Mbits/sec  207    163 KBytes       
[  5]   6.00-7.00   sec  35.6 MBytes   299 Mbits/sec  225    157 KBytes       
[  5]   7.00-8.00   sec  34.2 MBytes   287 Mbits/sec  225    133 KBytes       
[  5]   8.00-9.00   sec  37.0 MBytes   310 Mbits/sec  225    100 KBytes       
[  5]   9.00-10.00  sec  30.0 MBytes   252 Mbits/sec  135    110 KBytes       
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-10.00  sec   340 MBytes   286 Mbits/sec  2205             sender
[  5]   0.00-10.00  sec   339 MBytes   285 Mbits/sec                  receiver

Results from VHT80 (OnePlus9)

866.7 Mbit/s, 80 MHz, VHT-MCS 9, VHT-NSS 2, Short GI
866.7 Mbit/s, 80 MHz, VHT-MCS 9, VHT-NSS 2, Short GI

Connecting to host 192.168.50.1, port 5201
[  5] local 192.168.50.96 port 43200 connected to 192.168.50.1 port 5201
[ ID] Interval           Transfer     Bitrate         Retr  Cwnd
[  5]   0.00-1.00   sec  18.0 MBytes   151 Mbits/sec  325   55.1 KBytes       
[  5]   1.00-2.00   sec  19.5 MBytes   164 Mbits/sec  226   59.4 KBytes       
[  5]   2.00-3.00   sec  17.6 MBytes   148 Mbits/sec  202   72.1 KBytes       
[  5]   3.00-4.00   sec  19.4 MBytes   163 Mbits/sec  275   73.5 KBytes       
[  5]   4.00-5.00   sec  19.0 MBytes   159 Mbits/sec  156    100 KBytes       
[  5]   5.00-6.00   sec  19.2 MBytes   161 Mbits/sec  248   55.1 KBytes       
[  5]   6.00-7.00   sec  20.6 MBytes   173 Mbits/sec  201   55.1 KBytes       
[  5]   7.00-8.00   sec  18.2 MBytes   153 Mbits/sec  224   63.6 KBytes       
[  5]   8.00-9.00   sec  18.4 MBytes   154 Mbits/sec  208   65.0 KBytes       
[  5]   9.00-10.00  sec  19.0 MBytes   159 Mbits/sec  258   2.83 KBytes       
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-10.00  sec   189 MBytes   159 Mbits/sec  2323             sender
[  5]   0.00-10.00  sec   188 MBytes   158 Mbits/sec                  receiver

This. Just. Sucks. :neutral_face:

I mean: it's useable, and should be enough for smart phone usage most of the time, but at the same time a lot of effort is wasted when the interface runs at 2 Gbit/s and you only get 122 Mbit/s TCP speed.

6% effiency for HE160
20% efficiency for HE80

I would more like to get into the area of 50% TCP throughput when the connection is good, no other users or SSIDs interfere and the router is idling. 500 Mbit/s iperf3 for a 1000 Mbit/s 11ax connection would be nice to have.

Example: I get 545 Mbit/s average over 30 second iperf3 upload test being in direct sight 1 meter away from the router on VHT80, with my 11ac iPhone. Should be around 833 Mbit/s 2 stream most of the time. That's 65% efficiency, not 6% or 20%.

Edit
Your connection seems to be either loaded with other usage or your channel is congested or intefered with other networks. Look at the retransmission counter in your iperf3 table. :melting_face:

Maybe this is the cause for the low performance in your case. My retransmissions are nearly always zero. Otherwise it's hard to find a cause for low 11ax driver performance when there are lots of low level TCP retransmissions.

Example from just now, the network is loaded with video streams and I am not alone on my VHT80 channel:

iperf3 -c 192.168.1.1 -t 30
Connecting to host 192.168.1.1, port 5201
[  5] local 192.168.1.150 port 49530 connected to 192.168.1.1 port 5201
[ ID] Interval           Transfer     Bitrate         Retr  Cwnd
[  5]   0.00-1.00   sec  58.1 MBytes   487 Mbits/sec    0   2.00 MBytes       
[  5]   1.00-2.00   sec  62.5 MBytes   524 Mbits/sec    0   2.00 MBytes       
[  5]   2.00-3.00   sec  61.2 MBytes   514 Mbits/sec    0   2.00 MBytes       
[  5]   3.00-4.00   sec  61.2 MBytes   514 Mbits/sec    0   2.00 MBytes       
[  5]   4.00-5.00   sec  60.0 MBytes   503 Mbits/sec    0   2.00 MBytes       
[  5]   5.00-6.00   sec  62.5 MBytes   524 Mbits/sec    0   2.00 MBytes       
[  5]   6.00-7.00   sec  50.0 MBytes   419 Mbits/sec    0   2.00 MBytes       
[  5]   7.00-8.00   sec  58.8 MBytes   493 Mbits/sec    0   2.00 MBytes       
[  5]   8.00-9.00   sec  61.2 MBytes   514 Mbits/sec    0   2.00 MBytes       
[  5]   9.00-10.00  sec  61.2 MBytes   514 Mbits/sec    0   2.00 MBytes       
[  5]  10.00-11.00  sec  57.5 MBytes   482 Mbits/sec    0   2.00 MBytes       
[  5]  11.00-12.00  sec  52.5 MBytes   440 Mbits/sec    0   2.00 MBytes       
[  5]  12.00-13.00  sec  52.5 MBytes   440 Mbits/sec    0   2.00 MBytes       
[  5]  13.00-14.00  sec  61.2 MBytes   514 Mbits/sec    0   2.00 MBytes       
[  5]  14.00-15.00  sec  62.5 MBytes   524 Mbits/sec    0   2.00 MBytes       
[  5]  15.00-16.00  sec  61.2 MBytes   514 Mbits/sec    0   2.00 MBytes       
[  5]  16.00-17.00  sec  62.5 MBytes   524 Mbits/sec    0   2.00 MBytes       
[  5]  17.00-18.00  sec  61.2 MBytes   514 Mbits/sec    0   2.00 MBytes       
[  5]  18.00-19.00  sec  60.0 MBytes   503 Mbits/sec    0   2.00 MBytes       
[  5]  19.00-20.00  sec  60.0 MBytes   503 Mbits/sec    0   2.00 MBytes       
[  5]  20.00-21.00  sec  60.0 MBytes   503 Mbits/sec    0   2.00 MBytes       
[  5]  21.00-22.00  sec  62.5 MBytes   524 Mbits/sec    0   2.00 MBytes       
[  5]  22.00-23.00  sec  48.8 MBytes   409 Mbits/sec    0   2.00 MBytes       
[  5]  23.00-24.00  sec  62.5 MBytes   524 Mbits/sec    0   2.00 MBytes       
[  5]  24.00-25.00  sec  60.0 MBytes   503 Mbits/sec    0   2.00 MBytes       
[  5]  25.00-26.00  sec  43.8 MBytes   367 Mbits/sec    0   2.00 MBytes       
[  5]  26.00-27.00  sec  43.8 MBytes   367 Mbits/sec    0   2.00 MBytes       
[  5]  27.00-28.00  sec  46.2 MBytes   388 Mbits/sec    0   2.00 MBytes       
[  5]  28.00-29.00  sec  46.2 MBytes   388 Mbits/sec    0   2.00 MBytes       
[  5]  29.00-30.00  sec  38.8 MBytes   325 Mbits/sec  135   1.40 MBytes       
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-30.00  sec  1.66 GBytes   476 Mbits/sec  135             sender
[  5]   0.00-30.08  sec  1.66 GBytes   473 Mbits/sec                  receiver

135 retransmits in the last second, otherwise zero retransmits. Not around 2000 retransmits as in your case.

I do see that, with HE AND VHT on the OnePlus9, I do not see any retransmits with the Intel VHT. This makes me think that perhaps something isn't quite right on this phone as my area is not congested at all. I'm in Suburban US in a townhouse community but we're plenty apart from each other whereas not to cause congestion. I am eagerly awaiting the arrival of the AC adapter so I can test it on the laptop. Meanwhile I'll try to see if there's anything on this cellphone that can be adjusted.

Maybe its aggressive power saving on this smart phone. What happens with the retransmit counter if the phone is charging?

The charging did not change things for the OP9 but I remembered I have a Kindle fire; although slower and definitely not apples to apples, there's no retries.

VHT80 (Kindle Fire)

433.3 Mbit/s, 80 MHz, VHT-MCS 9, VHT-NSS 1, Short GI
433.3 Mbit/s, 80 MHz, VHT-MCS 9, VHT-NSS 1, Short GI

Connecting to host 192.168.50.1, port 5201
[  5] local 192.168.50.99 port 42132 connected to 192.168.50.1 port 5201
[ ID] Interval           Transfer     Bitrate         Retr  Cwnd
[  5]   0.00-1.02   sec  34.4 MBytes   283 Mbits/sec    0   1.26 MBytes       
[  5]   1.02-2.00   sec  35.8 MBytes   306 Mbits/sec    0   1.26 MBytes       
[  5]   2.00-3.01   sec  36.9 MBytes   306 Mbits/sec    0   1.26 MBytes       
[  5]   3.01-4.01   sec  35.7 MBytes   301 Mbits/sec    0   1.26 MBytes       
[  5]   4.01-5.01   sec  36.6 MBytes   305 Mbits/sec    0   1.26 MBytes       
[  5]   5.01-6.00   sec  36.1 MBytes   306 Mbits/sec    0   1.26 MBytes       
[  5]   6.00-7.00   sec  35.4 MBytes   298 Mbits/sec    0   1.26 MBytes       
[  5]   7.00-8.00   sec  37.2 MBytes   311 Mbits/sec    0   1.26 MBytes       
[  5]   8.00-9.00   sec  35.8 MBytes   302 Mbits/sec    0   1.26 MBytes       
[  5]   9.00-10.02  sec  37.2 MBytes   306 Mbits/sec    0   1.26 MBytes       
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-10.02  sec   361 MBytes   302 Mbits/sec    0             sender
[  5]   0.00-10.03  sec   361 MBytes   302 Mbits/sec                  receiver

Yes, 70% iperf3 throughput to interface connection rate may be what should be possible in ideal conditions.

11ac is stable and the performance is limited by channel noise, distance and obstacles between both radios.

I would be more interested in getting more 11ax to 11ac comparison measurements from the same 11ax compatible device, at the same location but one time with the OpenWrt router set to 11ax and afterwards to 11ac. This is where MT7915 has problems from what I can see.

1 Like
iperf3 -c 192.168.1.1 -t 30

this only tests upload from your phone and not what your accesspoint phone receives. Please check out Best practices and tools for measuring wifi performance.

E.g.:

TCP test, which measures the upload from client to server
iperf3 -c <IP of Iperf Server> -p <Port of Iperf Server> -t 60 -i 10

TCP test; Reverse mode: server sends, client receives
iperf3 -c <IP of Iperf Server> -p <Port of Iperf Server> -t 60 -i 10 -R

I have collected the logs and screenshots with an Intel AX200 chipset wifi adapter these are the results. Thanks for your patience and support with all this. @odrt @ThiloteE

HE-160

1921.5 Mbit/s, 160 MHz, HE-MCS 9, HE-NSS 2
1814.8 Mbit/s, 160 MHz, HE-MCS 9, HE-NSS 2, HE-GI 1

iperf3 -c 192.168.50.1 -p 5201 -t 60 -i 10
Connecting to host 192.168.50.1, port 5201
[  5] local 172.27.226.35 port 42876 connected to 192.168.50.1 port 5201
[ ID] Interval           Transfer     Bitrate         Retr  Cwnd
[  5]   0.00-10.00  sec  1.14 GBytes   979 Mbits/sec    0   1.99 MBytes
[  5]  10.00-20.00  sec  1.43 GBytes  1.23 Gbits/sec    0   1.99 MBytes
[  5]  20.00-30.00  sec  1.37 GBytes  1.17 Gbits/sec    0   1.99 MBytes
[  5]  30.00-40.00  sec  1.23 GBytes  1.06 Gbits/sec    0   1.99 MBytes
[  5]  40.00-50.00  sec  1.23 GBytes  1.06 Gbits/sec    0   1.99 MBytes
[  5]  50.00-60.00  sec  1.13 GBytes   967 Mbits/sec    0   1.99 MBytes
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-60.00  sec  7.52 GBytes  1.08 Gbits/sec    0             sender
[  5]   0.00-60.01  sec  7.52 GBytes  1.08 Gbits/sec                  receiver

iperf3 -c 192.168.50.1 -p 5201 -t 60 -i 10 -R
Connecting to host 192.168.50.1, port 5201
Reverse mode, remote host 192.168.50.1 is sending
[  5] local 172.27.226.35 port 35234 connected to 192.168.50.1 port 5201
[ ID] Interval           Transfer     Bitrate
[  5]   0.00-10.00  sec  1.07 GBytes   918 Mbits/sec
[  5]  10.00-20.00  sec  1.04 GBytes   895 Mbits/sec
[  5]  20.00-30.00  sec  1.04 GBytes   896 Mbits/sec
[  5]  30.00-40.00  sec  1.08 GBytes   927 Mbits/sec
[  5]  40.00-50.00  sec  1.07 GBytes   918 Mbits/sec
[  5]  50.00-60.00  sec  1001 MBytes   839 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-60.00  sec  6.28 GBytes   899 Mbits/sec    0             sender
[  5]   0.00-60.00  sec  6.28 GBytes   899 Mbits/sec                  receiver

HE-160

HE-80

1200.9 Mbit/s, 80 MHz, HE-MCS 11, HE-NSS 2
1134.2 Mbit/s, 80 MHz, HE-MCS 11, HE-NSS 2, HE-GI 1

iperf3 -c 192.168.50.1 -p 5201 -t 60 -i 10
Connecting to host 192.168.50.1, port 5201
[  5] local 172.27.226.35 port 42586 connected to 192.168.50.1 port 5201
[ ID] Interval           Transfer     Bitrate         Retr  Cwnd
[  5]   0.00-10.00  sec  1.05 GBytes   898 Mbits/sec    0   1.99 MBytes
[  5]  10.00-20.00  sec  1.09 GBytes   935 Mbits/sec    0   1.99 MBytes
[  5]  20.00-30.00  sec   882 MBytes   740 Mbits/sec    1   1.99 MBytes
[  5]  30.00-40.00  sec  1.04 GBytes   892 Mbits/sec    0   1.99 MBytes
[  5]  40.00-50.00  sec  1.09 GBytes   933 Mbits/sec    0   1.99 MBytes
[  5]  50.00-60.00  sec  1.09 GBytes   932 Mbits/sec    0   1.99 MBytes
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-60.00  sec  6.21 GBytes   889 Mbits/sec    1             sender
[  5]   0.00-60.01  sec  6.21 GBytes   888 Mbits/sec                  receiver

iperf3 -c 192.168.50.1 -p 5201 -t 60 -i 10 -R
Connecting to host 192.168.50.1, port 5201
Reverse mode, remote host 192.168.50.1 is sending
[  5] local 172.27.226.35 port 55822 connected to 192.168.50.1 port 5201
[ ID] Interval           Transfer     Bitrate
[  5]   0.00-10.00  sec   938 MBytes   787 Mbits/sec
[  5]  10.00-20.00  sec   937 MBytes   786 Mbits/sec
[  5]  20.00-30.00  sec   937 MBytes   786 Mbits/sec
[  5]  30.00-40.00  sec   939 MBytes   788 Mbits/sec
[  5]  40.00-50.00  sec   948 MBytes   795 Mbits/sec
[  5]  50.00-60.00  sec   943 MBytes   791 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-60.00  sec  5.51 GBytes   789 Mbits/sec    0             sender
[  5]   0.00-60.00  sec  5.51 GBytes   789 Mbits/sec                  receiver

HE-80

VHT-160

1733.3 Mbit/s, 160 MHz, VHT-MCS 9, VHT-NSS 2, Short GI
1733.3 Mbit/s, 160 MHz, VHT-MCS 9, VHT-NSS 2, Short GI

iperf3 -c 192.168.50.1 -p 5201 -t 60 -i 10
Connecting to host 192.168.50.1, port 5201
[  5] local 172.27.226.35 port 47798 connected to 192.168.50.1 port 5201
[ ID] Interval           Transfer     Bitrate         Retr  Cwnd
[  5]   0.00-10.00  sec  1.42 GBytes  1.22 Gbits/sec    0   1.97 MBytes
[  5]  10.00-20.00  sec  1.43 GBytes  1.23 Gbits/sec    0   1.97 MBytes
[  5]  20.00-30.00  sec  1.28 GBytes  1.10 Gbits/sec    1   1.97 MBytes
[  5]  30.00-40.00  sec  1.38 GBytes  1.18 Gbits/sec    0   1.97 MBytes
[  5]  40.00-50.00  sec  1.41 GBytes  1.22 Gbits/sec    0   1.97 MBytes
[  5]  50.00-60.00  sec  1.42 GBytes  1.22 Gbits/sec    0   1.97 MBytes
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-60.00  sec  8.35 GBytes  1.19 Gbits/sec    1             sender
[  5]   0.00-60.01  sec  8.34 GBytes  1.19 Gbits/sec                  receiver

iperf3 -c 192.168.50.1 -p 5201 -t 60 -i 10 -R
Connecting to host 192.168.50.1, port 5201
Reverse mode, remote host 192.168.50.1 is sending
[  5] local 172.27.226.35 port 47802 connected to 192.168.50.1 port 5201
[ ID] Interval           Transfer     Bitrate
[  5]   0.00-10.00  sec  1011 MBytes   848 Mbits/sec
[  5]  10.00-20.00  sec   999 MBytes   838 Mbits/sec
[  5]  20.00-30.00  sec  1007 MBytes   845 Mbits/sec
[  5]  30.00-40.00  sec  1013 MBytes   850 Mbits/sec
[  5]  40.00-50.00  sec  1007 MBytes   844 Mbits/sec
[  5]  50.00-60.00  sec  1013 MBytes   850 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-60.00  sec  5.91 GBytes   846 Mbits/sec    0             sender
[  5]   0.00-60.00  sec  5.91 GBytes   846 Mbits/sec                  receiver

VHT160

VHT-80
866.7 Mbit/s, 80 MHz, VHT-MCS 9, VHT-NSS 2, Short GI
866.7 Mbit/s, 80 MHz, VHT-MCS 9, VHT-NSS 2, Short GI

iperf3 -c 192.168.50.1 -p 5201 -t 60 -i 10
Connecting to host 192.168.50.1, port 5201
[  5] local 172.27.226.35 port 49522 connected to 192.168.50.1 port 5201
[ ID] Interval           Transfer     Bitrate         Retr  Cwnd
[  5]   0.00-10.00  sec   826 MBytes   693 Mbits/sec    0   1.99 MBytes
[  5]  10.00-20.00  sec   846 MBytes   710 Mbits/sec    0   1.99 MBytes
[  5]  20.00-30.00  sec   848 MBytes   711 Mbits/sec    0   1.99 MBytes
[  5]  30.00-40.00  sec   852 MBytes   715 Mbits/sec    0   1.99 MBytes
[  5]  40.00-50.00  sec   850 MBytes   713 Mbits/sec    0   1.99 MBytes
[  5]  50.00-60.00  sec   851 MBytes   714 Mbits/sec    0   1.99 MBytes
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-60.00  sec  4.95 GBytes   709 Mbits/sec    0             sender
[  5]   0.00-60.02  sec  4.95 GBytes   709 Mbits/sec                  receiver

iperf3 -c 192.168.50.1 -p 5201 -t 60 -i 10 -R
Connecting to host 192.168.50.1, port 5201
Reverse mode, remote host 192.168.50.1 is sending
[  5] local 172.27.226.35 port 45986 connected to 192.168.50.1 port 5201
[ ID] Interval           Transfer     Bitrate
[  5]   0.00-10.00  sec   743 MBytes   623 Mbits/sec
[  5]  10.00-20.00  sec   750 MBytes   629 Mbits/sec
[  5]  20.00-30.00  sec   751 MBytes   630 Mbits/sec
[  5]  30.00-40.00  sec   750 MBytes   629 Mbits/sec
[  5]  40.00-50.00  sec   750 MBytes   630 Mbits/sec
[  5]  50.00-60.00  sec   746 MBytes   626 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-60.00  sec  4.39 GBytes   628 Mbits/sec    0             sender
[  5]   0.00-60.00  sec  4.38 GBytes   628 Mbits/sec                  receiver

VHT-80

Ethernet for reference.

2 Likes

Let me summarize what we know so far:

  1. It has been demonstrated that ax performance can be greater than ac with the wax206 being used as accesspoint and ax200 as client.

    Your ax200 card has good overall throughput and ax > ac for upload when using 80 MHz channels, but lower when using 160MHz channels.

    Client: ax200

    Protocol Throughput
    (802.11ax) HE160 1080 Mbits/sec
    (802.11ax) HE80 889 Mbits/sec
    (802.11ac) VHT160 1190 Mbits/sec
    (802.11ac) VHT 80 709 Mbits/sec
  2. You isolated the problem and have shown that there is a performance problem with your phone OnePlus9 that regardless of ax or ac seems to have low performance.

    Client: OnePlus9

    Protocol Throughput
    (802.11ax) HE160 122 Mbits/sec
    (802.11ax) HE80 236 Mbits/sec
    (802.11ac) VHT160 286 Mbits/sec
    (802.11ac) VHT 80 158 Mbits/sec
  3. There are stark discrepancies between results from iperf and fast.com, where iperf has high throughput but fast.com has low throughput for uploading. You have tested your local wifi via iperf and you have tested total throughput (local network + internet) via fast.com. You say the difference only exists, when you use wifi, but not when you use cables. That probably means your main router has problems steering the data from wifi towards your outward internet.

So there are three bottlenecks in your connection: 1. your phone/kindle 2. your wifi is slower than cables; 3. probably some kind of wifi --> ethernet congestion in your main router.

2 Likes