WAX206 - manual vlan conf in eth0 not working

Hi, I'm using r22555-cd8c698f78 on a new WAX206, and I've notice that you can't bridge a wireless interface with a vlan. I have the same configuration in other devices without issues. The only difference seems to be that we can have eth0 and lan1-4 listed as devices. If i define an interface on vlan1.14 (for example) i can get connectivity from the router, but if I bridge a wlan, the wlan doesn't. Same setup with individual ports on multiple subnets does work ok. Not sure if related, but i can't also define vlans for the default bridge, or I will lose all connectivity.
Thank you for any ideas.

The move to DSA (distributed switch architecture) has changed the way you define them.

In my /etc/sysconfig/network I have (trimmed, because I've got a number of VLANs):

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	option vlan_filtering '1'

config bridge-vlan
	option device 'br-lan'
	option vlan '1001'
	list ports 'lan1:u*'
	list ports 'lan2:u*'
	list ports 'lan3:u*'
	list ports 'lan4:u*'

config bridge-vlan
	option device 'br-lan'
	option vlan '1002'
	list ports 'lan1:t'
	list ports 'lan2:t'
	list ports 'lan3:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '1003'
	list ports 'lan1:t'
	list ports 'lan2:t'
	list ports 'lan3:t'

config interface 'lan'
	option device 'br-lan.1001'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '192.168.7.254'
	list dns '192.168.7.254'
	list dns_search 'lan'
	list dns_search 'local'

config interface 'GUEST'
	option proto 'static'
	option device 'br-lan.1002'
	option ipaddr '192.168.100.254'
	option netmask '255.255.255.0'
	list dns '192.168.100.254'
	list dns_search 'lan'
	list dns_search 'local'

config interface 'iot'
	option proto 'static'
	option device 'br-lan.1003'
	option ipaddr '192.168.101.254'
	option netmask '255.255.255.0'
	list dns '192.168.101.254'
	list dns_search 'lan'
	list dns_search 'local'

So VLAN 1001 is untagged on all four ports, and the others are tagged on the three downlink ports to the rest of the house.

In /etc/config/wireless:

config wifi-iface 'phy0-ap0'
	option device 'radio0'
	option mode 'ap'
	option ssid 'REDACTED'
	option key '***'
	option network 'lan'
	option encryption 'psk2'

...and similarly for the GUEST and iot networks, there's an SSID joined to both of them.

Works perfectly!

1 Like

I use a WAX206 as an AP with three VLANs and one of the WLAN is part of one of the VLANs (I'm on r22514-c8934099bf), it works for me. lan1-lan4 and wan are all part of the lan bridge.

Can you post your /etc/config/network and /etc/config/wireless and make sure that you remove all identifiable information like SSID, password and public IPs, etc.

Here is the one VLAN which the WLAN is part of, DSA style:

/etc/config/network
[snip]
config bridge-vlan
	option device 'br-lan'
	option vlan '50'
	list ports 'lan1:t'
	list ports 'lan2'
	list ports 'lan4'
	list ports 'wan:t'

config interface '<VLAN50 name would go here>'
	option proto 'static'
	option device 'br-lan.50'
	option ipaddr '10.11.50.81'
	option netmask '255.255.255.0'
[snip]

/etc/config/wireless
[snip]
config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/18000000.wmac'
	option channel 'auto'
	option band '2g'
	option htmode 'HT40'
	option country 'CH'
	option cell_density '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network '<It got its own firewall zone of course>'
	option mode 'ap'
	option ssid '<The Best SSID In The World>'
	option encryption 'psk2+ccmp'
	option key '<it's so secret it hurts>'
[snip]

Hi, maybe it's because I'm using luci. When i try to apply

which is equivalent to your bridge vlan config, I'm losing the device. Is there an error on my config? Should I ditch Luci and manually edit /etc/config/network instead?
Thanks for the help.

I've also tried a different config with a separate interface lan4, so I don't lose it.

config device
	option type 'bridge'
	option name 'br62'
	list ports 'lan4'

config bridge-vlan
	option device 'br62'
	option vlan '14'
	list ports 'lan4:t'

config bridge-vlan
	option device 'br62'
	option vlan '62'
	list ports 'lan4:u*'

As soon as I apply, my wireless bridge br62 breaks.
Trunks on the switch are good as I've tried the same port on a server with no issue.

You need to ensure that your lan interface is put on the VLAN rather than the bridge.

From my config:

config interface 'lan'
	option device 'br-lan.1001'

Hi,
following your instructions I've configured:

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'

config interface 'lan'
	option device 'br-lan.14'
	option proto 'dhcp'

config interface 'public'
	option proto 'none'
	option device 'br-lan.62'

config bridge-vlan
	option device 'br-lan'
	option vlan '14'
	list ports 'lan1:u*'
	list ports 'lan2:u*'
	list ports 'lan3:u*'

config bridge-vlan
	option device 'br-lan'
	option vlan '62'
	list ports 'lan1:t'
	list ports 'lan2:t'
	list ports 'lan3:t'

And seems to be working fine, brilliant!
I will test tomorrow with the real configuration and the WDS bits.
Thank you so much, I've been really looking forward to upgrade my lab, but couldn't find the right router AP for it until now.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.