WAN problem on local network

Hi all,

I have a Netgear R7800, before the WAN port was on LAN1, I wanted to put it on the WAN port, the only possibility for the cable to be recognized was to modify the switch. However, since I modified it, the internet is reaching the router but is no longer broadcast on my network. I enclose my differences config files. How can I redistribute the internet on my network? Thanking you for your help. Greetings.

etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd5c:648d:f739::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option delegate '0'
	option ipaddr '192.168.0.2'
	option gateway '192.168.0.254'
	list dns '192.168.0.254'
	option ifname 'bat0 eth1.1'
	option stp '1'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '6t 5'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '2'
	option ports '0t 4 3 2 1'

config interface 'WAN'
	option proto 'none'
	option delegate '0'
	option ifname 'eth1.1'

config interface 'bat0'
	option proto 'batadv'
	option routing_algo 'BATMAN_IV'
	option aggregated_ogms '1'
	option ap_isolation '0'
	option bonding '0'
	option fragmentation '1'
	option gw_mode 'off'
	option log_level '0'
	option orig_interval '1000'
	option bridge_loop_avoidance '1'
	option distributed_arp_table '1'
	option multicast_mode '1'
	option network_coding '0'
	option hop_penalty '30'
	option isolation_mark '0x00000000/0x00000000'

config interface 'nwi_mesh0'
	option mtu '2304'
	option proto 'batadv_hardif'
	option master 'bat0'

You have both LAN and WAN defined on "eth1.1"; one should be on "eth0.1", and the other one on "eth1.2".

2 Likes

Thank you for your answer, I made the changes but I still do not have internet on my network.


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd5c:648d:f739::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option delegate '0'
	option ipaddr '192.168.0.2'
	option gateway '192.168.0.254'
	list dns '192.168.0.254'
	option stp '1'
	option ifname 'bat0 eth0.2'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '6t 5'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '2'
	option ports '0t 4 3 2 1'

config interface 'WAN'
	option delegate '0'
	option proto 'static'
	option gateway '192.168.0.254'
	option ipaddr '192.168.0.202'
	list dns ' 208.67.222.222'
	list dns ' 208.67.222.220'
	option ifname 'eth1.2'

config interface 'bat0'
	option proto 'batadv'
	option routing_algo 'BATMAN_IV'
	option aggregated_ogms '1'
	option ap_isolation '0'
	option bonding '0'
	option fragmentation '1'
	option gw_mode 'off'
	option log_level '0'
	option orig_interval '1000'
	option bridge_loop_avoidance '1'
	option distributed_arp_table '1'
	option multicast_mode '1'
	option network_coding '0'
	option hop_penalty '30'
	option isolation_mark '0x00000000/0x00000000'

config interface 'nwi_mesh0'
	option mtu '2304'
	option proto 'batadv_hardif'
	option master 'bat0'


Check the output:

ip address show; ip route show; ip rule show

You do not have a network mask on the WAN interface, and both LAN and WAN are on the same network segment. Perhaps you could explain a bit more how is this device connected to other devices.

1 Like

Here is the diagram of my network, before connecting the internet to the WAN port it was connected to the LAN1 and it worked correctly, I had internet on my br-lan. My WAN network working without being configured in the router.
I know that this network is not done according to the rules of the art, but being inexperienced I tried to do as well as possible and functional, thing which was the case with which I change port. I tried to find a tutorial that suits my case but my search was in vain. Thank you very much for your help.

ip address show

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether cc:40:d0:56:12:fd brd ff:ff:ff:ff:ff:ff
    inet6 fe80::ce40:d0ff:fe56:12fd/64 scope link
       valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether cc:40:d0:56:12:fc brd ff:ff:ff:ff:ff:ff
    inet6 fe80::ce40:d0ff:fe56:12fc/64 scope link
       valid_lft forever preferred_lft forever
7: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether cc:40:d0:56:12:fd brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.2/24 brd 192.168.0.255 scope global br-lan
       valid_lft forever preferred_lft forever
    inet6 fe80::ce40:d0ff:fe56:12fd/64 scope link
       valid_lft forever preferred_lft forever
8: eth0.2@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether cc:40:d0:56:12:fd brd ff:ff:ff:ff:ff:ff
10: bat0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UNKNOWN qlen 1000
    link/ether 06:21:2c:fe:3e:f4 brd ff:ff:ff:ff:ff:ff
11: mesh0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 2304 qdisc noqueue master bat0 state UP qlen 1000
    link/ether cc:40:d0:56:12:ff brd ff:ff:ff:ff:ff:ff
    inet6 fe80::ce40:d0ff:fe56:12ff/64 scope link
       valid_lft forever preferred_lft forever
12: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether cc:40:d0:56:12:fe brd ff:ff:ff:ff:ff:ff
    inet6 fe80::ce40:d0ff:fe56:12fe/64 scope link
       valid_lft forever preferred_lft forever
13: wlan1-1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether ce:40:d0:56:12:ff brd ff:ff:ff:ff:ff:ff
    inet6 fe80::cc40:d0ff:fe56:12ff/64 scope link
       valid_lft forever preferred_lft forever
14: eth1.2@eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether cc:40:d0:56:12:fc brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.202/32 brd 255.255.255.255 scope global eth1.2
       valid_lft forever preferred_lft forever
    inet6 fe80::ce40:d0ff:fe56:12fc/64 scope link
       valid_lft forever preferred_lft forever

ip route show

default via 192.168.0.254 dev br-lan
192.168.0.0/24 dev br-lan scope link  src 192.168.0.2

0:      from all lookup local
32766:  from all lookup main
32767:  from all lookup default

1 Like

I isolated my problem, I wanted to use the WAN port for my network but for a silent access point it doesn't work, that's why I didn't have internet on my routers. Tomorrow I put my blah back on LAN1 as it was before. Thanking you for your help.

1 Like

You're using it as a LAN device (dumb AP) so really you want all five Ethernet ports to be switched together as the same network. This is simple to do-- in the switch configuration move port 5 from VLAN 1 into VLAN 2, which becomes eth0.2 which is attached to the lan network. Then you can plug Ethernet cables into any port and it will work the same.

Do not create a wan network. The simple dumb AP (without guest networks etc) only has one network, the LAN.

2 Likes

thank you very much for your help, i moved my cable to lan1 and everything is working now.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.