WAN Configuration for German ISP (M-NET)

Hello,
I am new to the OpenWRT world and I would like to ask the community for some help.
I do have very limited knowledge of IT (I can connect to the router of SSH and I can run basic commands on it), just so you know how to approach me :grinning:

So, here is my situation. I live in Germany and I do have M-NET as an ISP. They do provide their own Fritzbox router with their own custom firmware which is driving me nuts... So I thought I can give OpenWRT a try, maybe I can make the WAN connection working.
I purchased a GL-S1300 router which comes with OpenWRT installed by default. https://www.gl-inet.com/products/gl-s1300/
For the last 2 days, I am trying to make my WAN connection to work without success.
According to the M-NET forum posts (in german) https://forum.m-net.de/viewtopic.php?f=23&t=12865&sid=65dafede4f70dfa6326f25100ea4cc94 this connection should work.
I have IPV6 DualStack with the VLAN ID: 40.
Somehow I believe I am not doing something right with the VLAN IDs - as I said I am not an expert on the topic.
Any help which leads to solving this frustrating issue will be rewarded with :beer:
many thanks

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'auto'

config interface 'lan'
        option ifname 'eth1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option hostname 'GL-S1300-530-5G'
        option ipaddr '192.168.8.1'
        option ieee1905managed '1'

config interface 'wan'
        option hostname 'GL-S1300-530-5G'
        option metric '10'
        option proto 'pppoe'
        option username 'Xxxxx@mdsl.mnet-online.de'
        option password 'xxxxxx'
        option disabled '0'
        option ipv6 '1'
        option ifname 'eth0'

config interface 'wan6'
        option proto 'dhcpv6'
        option _orig_ifname '@wan'
        option _orig_bridge 'true'
        option reqaddress 'try'
        option reqprefix 'auto'
        option ifname 'eth0'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0t 2 3 4'
		
		config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 5'
        option vid '2'

config switch_ext
        option device 'switch0'
        option name 'QosPtMode'
        option port_id '1'
        option mode 'dscp'
        option status 'enable'

config switch_ext
        option device 'switch0'
        option name 'QosPtMode'
        option port_id '2'
        option mode 'dscp'
        option status 'enable'

config switch_ext
        option device 'switch0'
        option name 'QosPtMode'
        option port_id '3'
        option mode 'dscp'
        option status 'enable'
config switch_ext
        option device 'switch0'
        option name 'QosPtMode'
        option port_id '4'
        option mode 'dscp'
        option status 'enable'

config switch_ext
        option device 'switch0'
        option name 'QosPtMode'
        option port_id '5'
        option mode 'dscp'
        option status 'enable'

config interface 'guest'
        option ifname 'guest'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.9.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option ports '1'
        option vid '40'```

You didn't mention, did you put your Fritzbox in bridge mode?

@Hegabo the idea is that I am trying to connect the WRT router to the WAN without the fritzbox. I would like to remove the fritzbox 4040 from my network.

Sorry, I thought the Fritizbox is also your modem. The page you sent is for registered users only.

Did you check if you need to replicate the MAC address?

If you need vlan40, then you need to change these:

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option ports '0t 1t'
        option vid '40'

and connect the cable where port 1 is.

No need to clone the MAC of the modem.
here is my latest config.

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'auto'

config interface 'lan'
        option ifname 'eth1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option hostname 'GL-S1300-530-5G'
        option ipaddr '192.168.8.1'
        option ieee1905managed '1'

config interface 'wan'
        option hostname 'GL-S1300-530-5G'
        option metric '10'
        option proto 'pppoe'
        option username 'xxxxx@mdsl.mnet-online.de'
        option password 'xxxx'
        option disabled '0'
        option peerdns '1'
        option defaultroute '1'
        option ipv6 '1'
        option _orig_ifname 'eth0'
        option _orig_bridge 'false'
        option ifname 'eth0'

config interface 'wan6'
        option _orig_ifname '@wan'
        option proto 'dhcpv6'
        option _orig_bridge 'true'
        option reqaddress 'try'
        option reqprefix 'auto'
        option ifname 'eth0.40'


config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 1 2 3 4'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '40'
        option ports '0t 5'
        option vid '40'

config switch_ext
        option device 'switch0'
        option name 'QosPtMode'
        option port_id '1'
        option mode 'dscp'
        option status 'enable'

config switch_ext
        option device 'switch0'
        option name 'QosPtMode'
        option port_id '2'
        option mode 'dscp'
        option status 'enable'

config switch_ext
        option device 'switch0'
        option name 'QosPtMode'
        option port_id '3'
        option mode 'dscp'
        option status 'enable'

config switch_ext
        option device 'switch0'
        option name 'QosPtMode'
        option port_id '4'
        option mode 'dscp'
        option status 'enable'

config switch_ext
        option device 'switch0'
        option name 'QosPtMode'
        option port_id '5'
        option mode 'dscp'
        option status 'enable'

config interface 'guest'
        option ifname 'guest'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.9.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wwan'
        option proto 'dhcp'
        option metric '20'
        option ifname 'wlan-sta0'

The router has OpenWrt Chaos Calmer 15.05.1 r48067

And when I try to connect to the WAN PPPOE I get the following error:

Sun Apr 26 13:34:27 2020 daemon.warn pppd[28766]: Timeout waiting for PADO packets
Sun Apr 26 13:34:27 2020 daemon.err pppd[28766]: Unable to complete PPPoE Discovery
Sun Apr 26 13:34:27 2020 daemon.info pppd[28766]: Exit.
Sun Apr 26 13:34:27 2020 daemon.notice netifd: Interface 'wan' is now down
Sun Apr 26 13:34:27 2020 daemon.notice netifd: Interface 'wan' is setting up now
Sun Apr 26 13:34:27 2020 daemon.info pppd[29882]: Plugin rp-pppoe.so loaded.
Sun Apr 26 13:34:27 2020 daemon.info pppd[29882]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7

I tried to debug a bit and here are some extra information:

root@GL-S1300:~# ifstatus wan
{
        "up": false,
        "pending": true,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "proto": "pppoe",
        "device": "eth0",
        "data": {

        },
        "errors": [
                {
                        "subsystem": "pppoe",
                        "code": "CONNECT_FAILED"
                }
        ]
}

root@GL-S1300:~# ifstatus wan6
{
        "up": false,
        "pending": true,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "proto": "dhcpv6",
        "device": "eth0.40",
        "data": {

        }
}

Very old and unsupported version. Moreover the GL-Inet OpenWrt is a branch of OpenWrt. So it will be hard to find someone to help, as no one will be able to reproduce your issue.

1 Like

This is ancient version and is considered vurlnable. I'm surprised GL.iNet would release a new model with such outdated version.

You may want to tech if they have a firmware upgrade or it before you spend much time configuring it.

1 Like

Wouldn't it make sense to return the GL-S1300 abd flash OpenWrt on your fritzbox 4040?https://openwrt.org/toh/avm/avm_fritz_box_4040

1 Like

Do you know that your uglifyed vendor FritzBox 4040 is also supported by OpenWrt?

2 Likes

so I guess I will pack the GL.iNet router and back to Amazon :slightly_smiling_face:
lucky I can return it within 30 days with no questions asked.

Now, I would still like to buy another router which supports OpenWrt.
Here are my requirements, maybe you can recommend me something.

  • I have my wifi running on EERO in bridge mode - is doing a pretty good job as a mesh network and I am not planning to change it.
  • I need a router which can handle a VPN Server / client - I want to do this so that some devices on my network (e.g. the smart TV) will go through the VPN to US or UK. This was one of the reasons why I selected GL.iNet - the ease of running a VPN.
  • I was indeed considering using Fritxbox 4040 also with openWRT (as some of you suggested) but from what I read on the AVM forums they have an issue with VPN server/client because of the fritzbox hardware?(maybe) https://vpn-anbieter-vergleich-test.de/fritzbox-mit-vpn-verbinden/ But I believe I will give it a try to see if I can make it work.

VPN doesn't have to do with hardware. Only the hardware crypto acceleration part could boost the throughput.
I think what they say is that the protocols some VPN providers use is not supported by the stock firmware.
OpenWrt supports a lot of different protocols (almost all I can think of).

1 Like

3 hours later - now i have OpenWRT on the FZ 4040.
Now, considering the limitation
Unsupported:
VLAN on WAN port
Any ideas on how to set my PPOE WAN connection with the VLAN ID 40?

try changing option ifname within the config interface 'wan' (and wan6) blocks to eth0.40

That's because the IPQ4018 chip has a hidden switch between eth1 and the "WAN" port on the back. The switch is pre-configured in a way that WAN packets will be untagged.

Simplest workaround is to add VLAN 40 to the main switch and use one of the LAN ports instead.

1 Like

So, let me see if I understood this correctly:

  1. Network -> Interfaces -> Set WAN and WAN6 to eth0 instead of eth1. (It is currently set for eth1)
  2. Switch -> set the LAN ports to something like this:
    I have to admit I have no idea what I am doing here with the VLAN ID... so have mercy :persevere:
    I am trying to follow the instructions here:
    https://openwrt.org/toh/avm/avm_fritz_box_4040
    If I apply these settings it means that I will have to connect WAN Cable to LAN1? And I can use LAN2 or 3 on the Fritzbox to connect my switch?

No, just forget about WAN and eth1. Ignore them.

Or port 4.

Since packets to the ISP need to be tagged, you would set LAN1 tagged in VLAN 40. VLAN 40 contains only the CPU and the ISP, both tagged. The LAN1 port should be off in the other VLAN(s) since it is for the WAN only.

The default is to untag eth0 and use it only for LAN, you need to change that so it is tagged for LAN (in VLAN x, where x is something other than 40, and probably should not be 1 or 2) as well as WAN on VLAN 40.

That requires changing the LAN physical interface to eth0.x Also set the wan network physical interface to eth0.40. No interfaces should be attached to plain eth0.

It is good to log in by wifi while doing this, so that if the Ethernet is misconfigured you still have control.

To use the now unused eth1 port as an extra LAN connection, bring it into the lan network bridge.

1 Like

@comanbo, did you have any success in the end? What is missing from the information on the m-net forum?

I did manage by sending back to Amazon the garbage GL-S1300 and installing OWRT on my Fritzbox 4040. :slight_smile: