WAN and WWAN failover configuration using mwan3

Hello,

I'm trying to setup a failover for my WAN using a 4G LTE module. I added two interfaces to mwan3 using luci

The above given is my interfaces page. When I run mwan3 status in the console I get

Interface status:
 interface wan is online 00h:00m:47s, uptime 00h:25m:08s and tracking is active
 interface 4G is error (16) and tracking is active

I'm not sure why interface 4G is showing an error.

For reference here's my /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd24:fbdc:4aca::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        list ports 'sfp2'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'br-wan'
        option type 'bridge'
        list ports 'eth1'
        list ports 'wan'

config device
        option name 'eth1'
        option macaddr 'a6:7e:3b:8b:99:c0'

config device
        option name 'wan'
        option macaddr 'a6:7e:3b:8b:99:c0'

config interface 'wan'
        option device 'br-wan'
        option proto 'dhcp'
        option defaultroute '1'
        option metric '10'

config interface 'wan6'
        option device 'br-wan'
        option proto 'dhcpv6'

config interface '4G'
        option proto 'qmi'
        option auth 'none'
        option pdptype 'ipv4v6'
        option device '/dev/cdc-wdm0'
        option defaultroute '0'
        option metric '50'

And /etc/config/mwan3

config globals 'globals'
        option enabled '1'

config interface 'wan'
        option enabled '1'
        option initial_state 'online'
        option family 'ipv4'
        list track_ip '8.8.8.8'
        option track_method 'ping'
        option reliability '1'
        option count '1'
        option size '56'
        option max_ttl '60'
        option timeout '4'
        option interval '10'
        option failure_interval '5'
        option recovery_interval '5'
        option down '5'
        option up '5'

config interface '4G'
        option enabled '1'
        option initial_state 'online'
        option family 'ipv6'
        list track_ip '2001:4860:4860::8888'
        option track_method 'ping'
        option reliability '1'
        option count '1'
        option size '56'
        option max_ttl '60'
        option timeout '4'
        option interval '10'
        option failure_interval '5'
        option recovery_interval '5'
        option down '5'
        option up '5'

This is what is available in my network interfaces page

Fwiw, I can ping 1.1.1.1 from both wwan0 (which is the interface which is showing up in ifconfig) as well as well as br-wan

My end goal is to be able to use 4G LTE as a failover for my wired WAN.

Regards and thank you for any suggestions!

I'm using a snapshot build from the master branch of https://github.com/openwrt/openwrt

Enable the defaultroute option for the 4G interface and restart the network and mwan3` services.

2 Likes

That did it, thank you!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.