VPN from OpenWrt to Fritzbox using VPNC IPSec

Dear all,

I just bought a new AR750S router running OpenWRT 3.010

I'd like to set it up in such a fashion that it connects to my Fritzbox at home via a VPN connection. I'm aware that Fritzbox only supports IPSec which is not natively supported by the AR750S.

I did found some instructions on how to setup the connection using the VPNC add-on.

However, I struggle to get this working and maybe someone here could help:

My AR750S is connected to an open Wifi network which again ist connected to the internet.

I followed the instructions and set up everything accordingly. As a output device I specified the WWAN interface.

However, when I connect the VPN Interface I get the Error Network device is not present.

What is it that I'm doing wrong?


The interface wwan is repeater interface of the AR750S.It requires a repeater connection to appear.If your repeater is already connected, you may need to provide a more detailed log.
As far as I understand, here you only need to select an external network interface, you can choose WAN or other

thank for looking into this. I also tried other configurations using the wired WAN port and specifying WAN or WAN6 as output interface. however I always get the same error message.


It means you have another process using that port:

netstat -lnp | grep :500

thanks for looking into this.

the problem with the "network device not present" could be identified.

now OpenWRT can connect via VPN. Unfortunately I'm not able yet to resolve IP dresses in the local network of the Fritzbox

it seems as if not all Traffic is going through the VPN. From the interface menu in OpenWRT I see that the RX of the VPN Interface is 0 and the TX is much smaller that what I see through the WWAN

You need to use remote-LAN DNS-server exclusively.

That depends on your local routing table.

how do I set these up correctly?

I just struggling in setting up VPN to my brother's Fritz!Box

The package vpnc is missing or can't be found / installed. vpnc-scripts is available.

What am I missing? Any help appreciated.

that is odd, all I did was following the guide (install three packages) which I linked in the first post followed by the fix for the IPv6.

It sure is. It does not show up in the package list (18.6). Neither if I update the list in the router or if I check the project's pages for included packages ...

I will create a new topic to get more attention on this.

I now got the packages and I got a connection allowing me to connect to devices in the remote network.
This link is helpful:

But now, when I connect the vpn, it tries to route all traffic through the vpn.
IPv4 Route points to the vpn interface, not wan.

Where can I define routing of only the remote network through the vpn?

Getting deeper in this issue this becomes more and more interessting ..

Looking in the source on master, comparing to 18.06.2, there is an additional option in the lua for the vpnc configuration for setting default route via vpn tunnel or not.
Seems as if my problem is already worked on ... I try to get a bit more information on this.

Hello everyone, I have the same problems as Kugelfang. Same device and error message. Has a solution been found?

What version are you using? 19.07.0?
Error is "device not present"?
In this case the solution is to leave the output Interface empty.