VPN and streaming: Netflix, Amazon Prime Video

Hi. I would like some help regarding port forwarding in OpenWRT 19.07.6.
Here is my setup: I am in Mexico, connected to the inernet via Telmex through a DSL modem/router. I have connected a second OpenWRT router to the Telmex modem/router using the WAN port on the OpenWRT router. The Telmex router is 192.168.1.254. The LAN address of the OpenWRT router is 192.168.1.64. The LAN behind the OpenWRT router is 192.168.2.2-225. I use an OpenVPN supplied by ExpressVPN to connect to the internet so that it appears that I am in the United States. The OpenVPN tunnel is functioning correctly, that is my isp location is in the US.
So far, so good. My problem is that I want to connect to Netflix and Amazon Prime Video through the Roku on the OpenWRT LAN. Neither Netflix nor Prime Video loads any video. When I try to connect on a laptop using the VPN, it is clear that these two services can detect the use of a VPN.
The OpenVPN tunnel uses port 1195. I have seen discussions about using port forwarding to send traffic to port 443 in the hope that this would evade VPN detection.
I use the Luci interface to manage OpenWRT. No SSH or Linux. Can someone give me simplified instructions to accomplish the port forwarding via the Luci interface? BTW, I tried changing the port number in the OVPN config file from port 1195 to port 443 without success (I loose internet connectivity).

I fail to see how a port change would fool the streaming providers ?

Especially when the port is between you and the VPN server, not you and the streaming servers.

Check out Smart DNS proxy, or swap VPN provider, for one who actually claim their service work
for streaming.

3 Likes

No, they do not detect that you are using a VPN, they detect that you are connecting to them from a VPN provider. See the difference?

It does not matter how you connect to the VPN provider, or even if your computer is physically on their premises; what they are detecting is a connection from an IP address that belongs to a VPN provider.

3 Likes

Make sure to disable peer DNS and configure a major public upstream DNS provider.
Otherwise, those services can identify your actual region by the ISP DNS you are using.

I have a similar situation with expressvpn, just one router (openwrt) but I assume it would work the same for you, I use luci-app-vpnbypass and just set the Roku ip in the Local IP Addresses to Bypass field, I also set static lease in Luci > Network > DHCP and DNS > Static Leases for the Roku and then tag dns in /etc/config/dhcp like this (so a small amount of ssh would be required), works well and no problems with Amazon or Netflix.

edit - if the problem is that you need to have a US location to get the content you want then instead of bypassing the vpn, try the Los Angeles 3 server from express vpn (if its available for you), I've found that one usually works with Amazon and /Netflix while connected.

1 Like

Mike. Thanks for the reply. Once I install luci-app-vpnbypass where do I find it?

Found it after refreshing OpenWRT