Voip phones ring but no voice

Hello everybody.
I'm from Italy and i have fttc 100/20 with TIM (italian isp)
My configuration is:
Tplink W9980 with openwrt as vdsl modem
Tplink VR1200V as router with voip functionality (connected to the W9980 with ethernet cable)

The problem is that i can make and receive calls but i can't hear any sound/voice. For example, when i call any phone number i don't hear ringing tones and voice and the other person can't hear me. I think the problem is that one or more ports are blocked. I tried to enable DMZ on the VR1200V with W9980 ip address but it doesn't work. Also i tried to enable port forwarding on 5060 port but it doesn't work.

What can i do? Thanks for attention.

1 Like


Tplink W9980
is that device doing NAT?

what is the wan ip address of the Tplink VR1200V?

If it isn't a public address, and particularly if it's a CGN address, there's little hope of it ever working. If you have a public IP then it should work by use of STUN settings to help the SIP phones determine their public address.

I solved all these problems by using a grand stream phone that supports IPv6 and connecting to a PBX that has IPv6... Voila, my calls work 100%

My SIP phones work with two different providers without any special port forwarding behind NAT, without STUN.
Make sure your provider doesn't require any incoming ports open to the telephone.

Some of the most important settings seem to be "symmetric rtp". With this set, there aren't two separate UDP streams but rather what looks to the firewall like "request / reply" on the same port.

There's plenty that can be done if you're behind regular NAT. But I think if you're behind CGN it's probably hopeless. If the address on the WAN is in the space (for carrier grade nat) then @DDiego is probably in trouble.

If the WAN is in a non CGN NAT space, then he has double-nat, and that also is trouble, and whether it works will depend on the answers to the good questions posed by @asdffdsa. If the WAN address is a public address, then it should be able to work.

[SOLVED] Incoming calls not reaching hosts on the network


Moving the SIP connection over to IPv6 (in case both your ISP, and the SIP servers support it) would be another solution to this issue.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.