Vodafone WAN provider uses credentials , how to configure WAN interface

Hi,
I have a Vodafone broadband which I would like to connect to my openwrt router. How to configure WAN interface with username and login provided from Vodafone?
It's Fiber connection small box on the wall which is connected to Vodafone router to WAN port via ethernet cable.
For my config I want to connect this fibre box to my OpenWrt router to eth1.
Any help, please ?

What is the connection protocol?
Is it PPPoE? Usually username and password is that.
If so, in your OpenWRT router you can select protocol type as that and enter username and password.

There is yet another way ISPs identify/authenticate the router.
You select connection as DHCP and when you start browsing they redirect you to their login page where you enter username/password and then your router's mac is registered with ISP.

You have to find out which type is yours. Possibly talk to the customer care, they should help you put your own router.

There is some errors like below, any idea ?

Protocol: PPPoE
MAC: 40:62:31:06:CC:40
RX: 0 B (0 Pkts.)
TX: 3.29 KB (52 Pkts.)
Error: Connection attempt failed

Error: Unknown error (USER_REQUEST)

Thu Feb  6 22:37:35 2020 daemon.notice netifd: Interface 'wan' is now down
Thu Feb  6 22:37:35 2020 daemon.notice netifd: Interface 'wan' is setting up now
Thu Feb  6 22:37:35 2020 daemon.err insmod: module is already loaded - slhc
Thu Feb  6 22:37:35 2020 daemon.err insmod: module is already loaded - ppp_generic
Thu Feb  6 22:37:35 2020 daemon.err insmod: module is already loaded - pppox
Thu Feb  6 22:37:35 2020 daemon.err insmod: module is already loaded - pppoe
Thu Feb  6 22:37:35 2020 daemon.info pppd[4324]: Plugin rp-pppoe.so loaded.
Thu Feb  6 22:37:35 2020 daemon.info pppd[4324]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Thu Feb  6 22:37:36 2020 daemon.notice pppd[4324]: pppd 2.4.7 started by root, uid 0
Thu Feb  6 22:37:51 2020 daemon.warn pppd[4324]: Timeout waiting for PADO packets
Thu Feb  6 22:37:51 2020 daemon.err pppd[4324]: Unable to complete PPPoE Discovery
Thu Feb  6 22:37:51 2020 daemon.info pppd[4324]: Exit.
Thu Feb  6 22:37:51 2020 daemon.notice netifd: Interface 'wan' is now down
Thu Feb  6 22:37:51 2020 daemon.notice netifd: Interface 'wan' is setting up now
Thu Feb  6 22:37:51 2020 daemon.err insmod: module is already loaded - slhc
Thu Feb  6 22:37:51 2020 daemon.err insmod: module is already loaded - ppp_generic
Thu Feb  6 22:37:51 2020 daemon.err insmod: module is already loaded - pppox
Thu Feb  6 22:37:51 2020 daemon.err insmod: module is already loaded - pppoe
Thu Feb  6 22:37:51 2020 daemon.info pppd[4377]: Plugin rp-pppoe.so loaded.
Thu Feb  6 22:37:51 2020 daemon.info pppd[4377]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Thu Feb  6 22:37:51 2020 daemon.notice pppd[4377]: pppd 2.4.7 started by root, uid 0
Thu Feb  6 22:38:06 2020 daemon.warn pppd[4377]: Timeout waiting for PADO packets
Thu Feb  6 22:38:06 2020 daemon.err pppd[4377]: Unable to complete PPPoE Discovery
Thu Feb  6 22:38:06 2020 daemon.info pppd[4377]: Exit.
Thu Feb  6 22:38:06 2020 daemon.notice netifd: Interface 'wan' is now down
Thu Feb  6 22:38:06 2020 daemon.notice netifd: Interface 'wan' is setting up now
Thu Feb  6 22:38:06 2020 daemon.err insmod: module is already loaded - slhc
Thu Feb  6 22:38:06 2020 daemon.err insmod: module is already loaded - ppp_generic
Thu Feb  6 22:38:06 2020 daemon.err insmod: module is already loaded - pppox
Thu Feb  6 22:38:06 2020 daemon.err insmod: module is already loaded - pppoe
Thu Feb  6 22:38:06 2020 daemon.info pppd[4430]: Plugin rp-pppoe.so loaded.
Thu Feb  6 22:38:06 2020 daemon.info pppd[4430]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Thu Feb  6 22:38:06 2020 daemon.notice pppd[4430]: pppd 2.4.7 started by root, uid 0

Your client is not even reaching the server, this is not a credentials issue. You probably need to use an specific VLAN on the WAN. Unfortunately, which VLAN depends on the provider and the country.

[quote="eduperez, post:4, topic:54709"] You probably need to use an specific VLAN on the WAN
[/quote]
@wisnia2 check your Vodafone router and see the configurations there (or ask Vodafone if you think they don't mind you using a third-party router).

I use "qotom Q350G4 (8GB RAM 64GB SSD + I5-4200U)"x64 mini pc.
Is possible to provide vlan configuration on that box ? software vlan ?
or I need to buy any managed switch ? and configure it ?

You can create a vlan, you just need to know the number to tag the data. Contact Vodafone and ask for the settings. I am in Italy and operators are obliged to release their credentials to their users and all the settings to use a modem other than that of the ISP.

Try vlan 1036 or use tcpdump or wireshark to see if any VLAN-tagged frames are coming from the ONT (if you cannot check on ISP router).
Here is how to configure VLANs: https://openwrt.org/docs/guide-user/network/vlan/start

Hi,

I've spoken today with Vodafone support and the confirmed that Vlan is 101 and I should use pppoe configuration.
Where should I put this vlan number ?
Could you please send me a sample of WAN interface with this info if possible?
Is pppoe has any vlan option where I could put 101 ?

Thanks

Assuming you know how to configure PPPoE without VLAN, edit the configuration and add a VLAN id after the port:

option ifname 'eth0.101'
1 Like

Hi, thanks AndrewZ, even if my WAN is on eth1 ?

If your wan port is eth1 you need to use option ifname 'eth1.101'

1 Like

Thanks a lot jow ... I plan to test all tonight ...

Thanks again

Hi,
Doesn't work unfortunately. System is completely reinstalled and fresh bulid "openwrt-19.07.1-x86-64-combined-ext4"

Did I miss any option in WAN interface ?

Below my /etc/config/network:

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fde4:6847:2120::/48'

config interface 'lan'
option type 'bridge'
option ifname 'eth0 eth2 eth3'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'

config interface 'wan'
option username 'xxxxxxx2@broadband.vodafone.co.uk'
option password 'nxxxxxb'
option proto 'pppoe'
option ipv6 'auto'
option ifname 'eth1.101'

config interface 'wan6'
option ifname 'eth1'
option proto 'dhcpv6'

and error is the same

Please help

Delete the wan6, it is not needed in this situation and may be conflicting for eth1. (If your ISP supports IPv6, pppoe will handle it.)

Just got connected to Vodafone broadband (UK) today, I didn't need to add any Vlan 101, I left the WAN default option that came with my initial OpenWRT install : option ifname 'eth1.2'
I also deleted the WAN6.
Like the OP, I have an OpenReach modem (the small box?).

I initially followed online recommendations telling to add the Vlan 101 in Network > Interfaces > WAN > Physical Settings > Interface > add custom, but that didn't work.

All I needed to do is set the WAN protocol to PPPoE, add my username and password, and save & apply.

Hopes this helps.

@mk24 I'll do it today, thanks

@Darius Thanks for your info. Some question below:

  1. Do you have a fibre gigafast vodafone broadband ? I mean do you have an extra small box (fibre box) at home on the wall ? I ask to be sure we have the same solution. I connect ethernet cable from that small fibre box to my openwrt router. Do you have the same ?
    Did you restart that box before you connect your own router ?

  2. My OpenWrt is set on Mini PC , not on a proper router, so I have a software vlan. Do you think guys it make any difference ?

  3. Did you put your username with domain (@broadband.vodafone.co.uk)? or without (xxxxxxx2 )? Did you put any DNS info in WAN config ?

  4. Could you please send me your WAN settings ?

I'll try to change my settings today, delete WAN6 and change

option ifname 'eth1.101'
to
option ifname 'eth1.2'
I hope it help.

Thanks a lot for your help

@wisnia2

  1. No, I have their "Vodafone Superfast 2" connection, the 63Mb. I basically connect my Linksys WRT32X to an OpenReach modem with an ethernet cable, the modem is then connected to a phone socket on the wall with another cable. I did restart both the modem and router for good measure.
  2. 3 and 4.
    config interface 'wan'
    option proto 'pppoe'
    option ipv6 '0'
    list dns '103.86.96.100'
    list dns '103.86.99.100'
    option peerdns '0'
    option password 'ABCDeFgh'
    option username 'dsl001234567@broadband.vodafone.co.uk'
    option ifname 'eth1.2'

The 3 lines about DNS where added when I configured a VPN client on the router. These 3 lines are not needed if you don't use a VPN client. Just make sure that you at least tick "Use DNS servers advertised by peer" in Network > Interfaces > WAN > Advanced Settings.
Up until yesterday, I was with EE Broadband and things worked in similar fashion.
Maybe in my case the Vlan 101 is set at modem level..?
My setting is different from yours, so I don't know if this will help you in the end. But at least this could help someone else. I scratched my head for a while yesterday trying to figure out how to set this up!

Thanks a lot @Darius, will check in the evening and will share my results.