Hello. I have a TP-Link 841 v13 router flashed for openwrt, I also have two local networks: 192.168.0.0/16 and 10.15.0.0/16, the first network is untagged vlan 1, the second network is tagged vlan 3. How to do two independent Wi-Fi zones for clients running on these vlans in Luci?
Hi
generic advice is that you need to create two SSID and bond them to corresponding interface/network
for ex
SSID Home -> to your vlan1
SSID Guest -> to your vlan3
it could be done from luci, wireless
These two local networks were not created on this router. These networks come from the switch.
then, without further information i think nobody could help you ... our crystal ball is broken
from SSH:
cat /etc/board.json
cat /etc/config/network
and paste output here using preformatted text " < />"
{
"model": {
"id": "tplink,tl-wr841n-v13",
"name": "TP-Link TL-WR841N v13"
},
"led": {
"wlan2g": {
"name": "wlan2g",
"sysfs": "green:wlan",
"trigger": "phy0tpt"
},
"lan1": {
"name": "lan1",
"sysfs": "green:lan1",
"trigger": "switch0",
"type": "switch",
"mode": "",
"port_mask": "0x2",
"speed_mask": ""
},
"lan2": {
"name": "lan2",
"sysfs": "green:lan2",
"trigger": "switch0",
"type": "switch",
"mode": "",
"port_mask": "0x4",
"speed_mask": ""
},
"lan3": {
"name": "lan3",
"sysfs": "green:lan3",
"trigger": "switch0",
"type": "switch",
"mode": "",
"port_mask": "0x8",
"speed_mask": ""
},
"lan4": {
"name": "lan4",
"sysfs": "green:lan4",
"trigger": "switch0",
"type": "switch",
"mode": "",
"port_mask": "0x10",
"speed_mask": ""
},
"wan": {
"name": "wan",
"sysfs": "green:wan",
"trigger": "switch0",
"type": "switch",
"mode": "",
"port_mask": "0x01",
"speed_mask": ""
}
},
"switch": {
"switch0": {
"enable": true,
"reset": true,
"ports": [
{
"num": 1,
"role": "lan"
},
{
"num": 2,
"role": "lan"
},
{
"num": 3,
"role": "lan"
},
{
"num": 4,
"role": "lan"
},
{
"num": 0,
"role": "wan"
},
{
"num": 6,
"device": "eth0",
"need_tag": false,
"want_untag": false
}
],
"roles": [
{
"role": "lan",
"ports": "1 2 3 4 6t",
"device": "eth0.1"
},
{
"role": "wan",
"ports": "0 6t",
"device": "eth0.2"
}
]
}
},
"network": {
"lan": {
"device": "eth0.1",
"protocol": "static"
},
"wan": {
"device": "eth0.2",
"protocol": "dhcp",
"macaddr": "c0:25:e9:61:b3:db"
}
}
}
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fdef:9314:86e2::/48'
config interface 'lan'
option device 'br-lan-test.1'
option proto 'static'
option ipaddr '192.168.4.122'
option netmask '255.255.0.0'
option ip6assign '60'
config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'switch0'
option vlan '1'
option ports '1 2 3 4 6t'
config device
option type 'bridge'
option name 'br-lan-test'
list ports 'eth0.1'
option mtu '1500'
option macaddr 'C0:25:E9:61:B3:DA'
option ipv6 '0'
config bridge-vlan
option device 'br-lan-test'
option vlan '3'
list ports 'eth0.1:t'
config bridge-vlan
option device 'br-lan-test'
option vlan '1'
list ports 'eth0.1'
config interface 'lan_vlan_3'
option proto 'static'
option device 'br-lan-test.3'
option ipaddr '10.15.22.2'
option netmask '255.255.0.0'
option gateway '10.15.22.1'
Hi
it is MT7628N which is still on swconfig
... and you are mixing things with DSA and your config is invalid
so, best is to
- reset to factory
- follow this tutorial
2.1. look for this section "#### For devices with switch only"
if i get it right, you want DumbAP only to pass 2 vlans to 2 different SSID
I need to implement two independent Wi-Fi zones that distribute Internet from two different vlans. This router is connected to the switch via twisted pair cable, through which two vlans are supplied to it: vlan 1 is untagged, vlan 3 is tagged.
yes, since your OpenWRT does NOT provide routing/dhcp/firewal etc ... it is called DumbAP
you have 2 vlans via switch, and your OWRT only make bridge between vlans and SSIDs
Ready. Got what I wanted. There are nuances when setting up, a beginner may get confused.
This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.