VLANs+iptv config on 2 devices

Hello there.
I have 2 service from my ISP: Internet and IPTV.
Internet come to Bridge ONT on PPoE vlan 10 and IPTV come on vlan 20.
I trunk it from ISP ONT to my AX3200 and then to my old TP-814N.
My configuration is complete mess and sometimes working strange
(Can work two days in anouther room and then lost one of vlans).
Can somebody please help me figure out this mess and get some stability in my TV and internet?
My isp ont as far as i understand gives iptv box dhcp ip from their net when its connecteed to port 4 on ISP box

(As AV tech i can figure out and setup different configurations in audio-video, configure IGMP for AV purposes, but full network configs are too complex for me RN, so sorry if i explain something wrong, if you point me where i will try to rephrase it)
Some ports on diagramm can be named wrong

Config from main device

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fda3:0e1c:5d68::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	option igmp_snooping '1'

config interface 'lan'
	option device 'br-lan.10'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'wan'
	option macaddr 'd4:da:21:1c:ae:e0'

config interface 'wan'
	option device 'INTERNET'
	option proto 'pppoe'
	option username 'user'
	option password 'pass'
	option ipv6 'auto'
	option type 'bridge'

config device
	option type '8021q'
	option ifname 'wan'
	option vid '10'
	option name 'INTERNET'

config device
	option type '8021q'
	option ifname 'wan'
	option vid '20'
	option name 'IPTV'
	option ipv6 '0'
	option multicast '1'
	option multicast_router '2'
	option multicast_fast_leave '1'

config interface 'iptv'
	option proto 'none'
	option device 'br-iptv'

config bridge-vlan
	option device 'br-lan'
	option vlan '10'
	list ports 'lan1:u*'
	list ports 'lan2:t'
	list ports 'lan3'

config bridge-vlan
	option device 'br-lan'
	option vlan '20'
	list ports 'lan2:t'

config device
	option name 'br-lan.20'
	option type '8021q'
	option ifname 'br-lan'
	option vid '20'
	option igmpversion '3'

config device
	option name 'lan2'
	option multicast_router '2'
	option multicast_fast_leave '1'
	option igmpversion '3'

config device
	option type 'bridge'
	option name 'br-iptv'
	option igmp_snooping '1'
	option ipv6 '0'
	option multicast '1'
	option igmpversion '3'
	list ports 'br-lan.20'
	list ports 'IPTV'

config device
	option type '8021q'
	option ifname 'wl0-ap0'
	option vid '10'
	option name 'wl0-ap0.10'

config device
	option type '8021q'
	option ifname 'wl1-ap0'
	option vid '10'
	option name 'wl1-ap0.10'

config device
	option name 'br-lan.10'
	option type '8021q'
	option ifname 'br-lan'
	option vid '10'

COnfig from 2nd device


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd91:ea9d:f1f9::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option delegate '0'
	option igmp_snooping '1'
	option ipaddr '192.168.1.5'
	option netmask '255.255.255.0'
	option gateway '192.168.1.1'
	option dns '192.168.1.1'
	option ifname 'eth0 eth0.10 eth1'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '10'
	option ports '0t 2 3 4t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '20'
	option ports '0t 1 4t'

config interface 'vlan_iptv'
	option ifname 'eth0.20'
	option proto 'none'

There's a lot here that is probably not necessary. Fundamentally, you need to add the wan port to br-lan and use bridge-vlans on the main router to make this work.

Start by making backups of each device just in case things don't work out here (I think they will, but I want you to have an easy restore point).

We'll begin by adding the wan to br-lan and removing the igmp snooping:

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'wan'

Next, we'll setup bridge-vlans:

config bridge-vlan
	option device 'br-lan'
	option vlan '1'
	list ports 'lan1:u*'
	list ports 'lan2:u*'
	list ports 'lan3:u*'

config bridge-vlan
	option device 'br-lan'
	option vlan '10'
	list ports 'wan:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '20'
	list ports 'lan3:t'
	list ports 'wan:t'

Now we'll edit the lan to use br-lan.1:

config interface 'lan'
	option device 'br-lan.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

and the wan to use br-lan.10 (we also need to remove the bridge line):

config interface 'wan'
	option device 'br-lan.10'
	option proto 'pppoe'
	option username 'user'
	option password 'pass'
	option ipv6 'auto'

Last, the iptv interface needs to use br-lan.20

config interface 'iptv'
	option proto 'none'
	option device 'br-lan.20'

Now delete all the 802.1q stanzas and the previous bridge and bridge-vlans:

Moving on to the 2nd device, you'll put VLAN 1 untagged on the uplink port and on the other ports used for the lan. VLAN 20 will be tagged on both the uplink for and the port that connects to your STB (I believe that the IPTV set top box will want it VLAN 20 tagged).

The problem is that the syntax of your 814N looks really old and possibly wrong (depending on the version of the device and of OpenWrt). I'd recommend that you reset it to defaults and then post the following so that I can make recommendations for that device.

ubus call system board
cat /etc/config/network

Thank you for your response.
I will strat to modify my main device, but first to adress this:

its old slightly cutted firmware OpenWrt 18.06.8 r7989-82fbd85747, but cos of low flash its last possible option for this device.
( TP-Link TL-WR841N/ND v9 Qualcomm Atheros QCA9533 ver 1 rev 1)

as i understand in my experiments, box want vlan untagged, but only with iptv. If i send there Vlan 10 it also connects but only for VOD functions

Ok... so this is so old (and very much unsupported) that I don't remember the syntax for it... I can only comment on the principle.

  • On the uplink port, you want VLAN 1 untagged + VLAN 20 tagged.
  • On the port that goes to the STB, you will have only VLAN 20, untagged (per your comment; you can always change it to tagged if that is necessary).
  • The other ports will probably be assigned VLAN 1, untagged.

With a swconfig device, you do not need any interface nor do you need a special bridge for the IPTV network -- just the switch configuration should do the trick. You obviously need a network interface for the lan, and it should be a bridge if this device is also being used for wifi.

With all that said, I would recommend that you get a new device since this 841N is so old that it is now almost 5 major releases behind on the firmware, which means it has tons of security vulnerabilities that have not been patched. Beyond that, I wouldn't recommend enabling wifi on this device; just use it as a switch only. With respect to a replacement device -- if you don't need wifi, you can just get a simple managed switch. Otherwise, any newer OpenWrt supported router will be preferred.

Ok, this part completly lock me out of network on my PC. Gladly i have backup(always backup first=))) and can restore from failsafe mode

Sequencing is critical.... you need to finish all the bridge-vlans and such in one shot before you restart the network service. IMO, the easiest way to do this is either direct edits of the config file or UCI commands on the CLI.

Thats what i do. I prefer config file edits rather then using gui. Easier to understand for me

1 Like

Good. If you want to have me read over the network config file changes before you apply them, post it here when you're done with the edits.

Here is the log after modifying network file

at Dec 14 01:38:40 2024 daemon.warn odhcpd[1566]: No default route present, overriding ra_lifetime!
Sat Dec 14 01:38:41 2024 user.err igmpproxy[3151]: There must be at least 1 Vif as upstream.
Sat Dec 14 01:38:43 2024 daemon.info hostapd: wl0-ap0: STA 50:ec:50:0b:60:03 IEEE 802.11: authenticated
Sat Dec 14 01:38:43 2024 daemon.info hostapd: wl0-ap0: STA 50:ec:50:0b:60:03 IEEE 802.11: associated (aid 1)
Sat Dec 14 01:38:46 2024 user.err igmpproxy[3152]: There must be at least 1 Vif as upstream.
Sat Dec 14 01:38:46 2024 daemon.info hostapd: wl0-ap0: STA 50:ec:50:0b:60:03 IEEE 802.11: authenticated
Sat Dec 14 01:38:46 2024 daemon.info hostapd: wl0-ap0: STA 50:ec:50:0b:60:03 IEEE 802.11: associated (aid 1)
Sat Dec 14 01:38:46 2024 daemon.notice hostapd: wl0-ap0: AP-STA-CONNECTED 50:ec:50:0b:60:03 auth_alg=open
Sat Dec 14 01:38:46 2024 daemon.info hostapd: wl0-ap0: STA 50:ec:50:0b:60:03 WPA: pairwise key handshake completed (RSN)
Sat Dec 14 01:38:46 2024 daemon.notice hostapd: wl0-ap0: EAPOL-4WAY-HS-COMPLETED 50:ec:50:0b:60:03
Sat Dec 14 01:38:51 2024 user.err igmpproxy[3153]: There must be at least 1 Vif as upstream.
Sat Dec 14 01:38:54 2024 daemon.warn odhcpd[1566]: No default route present, overriding ra_lifetime!
Sat Dec 14 01:38:56 2024 user.err igmpproxy[3154]: There must be at least 1 Vif as upstream.
Sat Dec 14 01:38:56 2024 daemon.info procd: Instance igmpproxy::instance1 s in a crash loop 6 crashes, 0 seconds since last crash
Sat Dec 14 01:39:04 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.10) 192.168.1.10 50:ec:50:0b:60:03
Sat Dec 14 01:39:04 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.10) 192.168.1.10 50:ec:50:0b:60:03
Sat Dec 14 01:39:04 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.10) 192.168.1.10 50:ec:50:0b:60:03
Sat Dec 14 01:39:04 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.10) 192.168.1.10 50:ec:50:0b:60:03
Sat Dec 14 01:39:04 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan.10) 192.168.1.10 50:ec:50:0b:60:03
Sat Dec 14 01:39:04 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan.10) 192.168.1.10 50:ec:50:0b:60:03 rockrobo
Sat Dec 14 01:39:09 2024 daemon.info hostapd: wl0-ap0: STA aa:c9:21:07:a8:9f IEEE 802.11: authenticated
Sat Dec 14 01:39:09 2024 daemon.info hostapd: wl0-ap0: STA aa:c9:21:07:a8:9f IEEE 802.11: associated (aid 2)
Sat Dec 14 01:39:09 2024 daemon.notice hostapd: wl0-ap0: AP-STA-CONNECTED aa:c9:21:07:a8:9f auth_alg=sae
Sat Dec 14 01:39:09 2024 daemon.info hostapd: wl0-ap0: STA aa:c9:21:07:a8:9f WPA: pairwise key handshake completed (RSN)
Sat Dec 14 01:39:09 2024 daemon.notice hostapd: wl0-ap0: EAPOL-4WAY-HS-COMPLETED aa:c9:21:07:a8:9f
Sat Dec 14 01:39:10 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan.10) 192.168.1.15 aa:c9:21:07:a8:9f
Sat Dec 14 01:39:10 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan.10) 192.168.1.15 aa:c9:21:07:a8:9f
Sat Dec 14 01:39:10 2024 daemon.warn odhcpd[1566]: No default route present, overriding ra_lifetime!
Sat Dec 14 01:39:14 2024 daemon.info hostapd: wl1-ap0: STA 80:19:34:96:4e:bb IEEE 802.11: authenticated
Sat Dec 14 01:39:14 2024 daemon.info hostapd: wl1-ap0: STA 80:19:34:96:4e:bb IEEE 802.11: associated (aid 2)
Sat Dec 14 01:39:14 2024 daemon.notice hostapd: wl1-ap0: STA-OPMODE-SMPS-MODE-CHANGED 80:19:34:96:4e:bb off
Sat Dec 14 01:39:14 2024 daemon.notice hostapd: wl1-ap0: AP-STA-CONNECTED 80:19:34:96:4e:bb auth_alg=open
Sat Dec 14 01:39:14 2024 daemon.info hostapd: wl1-ap0: STA 80:19:34:96:4e:bb WPA: pairwise key handshake completed (RSN)
Sat Dec 14 01:39:14 2024 daemon.notice hostapd: wl1-ap0: EAPOL-4WAY-HS-COMPLETED 80:19:34:96:4e:bb
Sat Dec 14 01:39:14 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.10) 80:19:34:96:4e:bb
Sat Dec 14 01:39:14 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.10) 192.168.1.12 80:19:34:96:4e:bb
Sat Dec 14 01:39:14 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan.10) 192.168.1.12 80:19:34:96:4e:bb
Sat Dec 14 01:39:14 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan.10) 192.168.1.12 80:19:34:96:4e:bb inzenieris-laptop
Sat Dec 14 01:39:21 2024 kern.info kernel: [   62.550904] mt7530-mdio mdio-bus:00 lan3: Link is Down
Sat Dec 14 01:39:21 2024 daemon.notice netifd: Network device 'lan3' link is down
Sat Dec 14 01:39:21 2024 kern.info kernel: [   62.557284] br-lan: port 3(lan3) entered disabled state
Sat Dec 14 01:39:21 2024 daemon.info hostapd: wl1-ap0: STA e0:dc:ff:08:d4:cd IEEE 802.11: authenticated
Sat Dec 14 01:39:21 2024 daemon.info hostapd: wl1-ap0: STA e0:dc:ff:08:d4:cd IEEE 802.11: associated (aid 3)
Sat Dec 14 01:39:21 2024 daemon.notice hostapd: wl1-ap0: AP-STA-CONNECTED e0:dc:ff:08:d4:cd auth_alg=open
Sat Dec 14 01:39:21 2024 daemon.info hostapd: wl1-ap0: STA e0:dc:ff:08:d4:cd WPA: pairwise key handshake completed (RSN)
Sat Dec 14 01:39:21 2024 daemon.notice hostapd: wl1-ap0: EAPOL-4WAY-HS-COMPLETED e0:dc:ff:08:d4:cd
Sat Dec 14 01:39:22 2024 daemon.warn odhcpd[1566]: No default route present, overriding ra_lifetime!
Sat Dec 14 01:39:23 2024 daemon.notice hostapd: wl1-ap0: STA-OPMODE-N_SS-CHANGED b6:e9:4c:81:72:eb 1
Sat Dec 14 01:39:23 2024 daemon.info hostapd: wl1-ap0: STA b6:e9:4c:81:72:eb IEEE 802.11: associated (aid 4)
Sat Dec 14 01:39:23 2024 daemon.notice hostapd: wl1-ap0: AP-STA-CONNECTED b6:e9:4c:81:72:eb auth_alg=sae
Sat Dec 14 01:39:23 2024 daemon.info hostapd: wl1-ap0: STA b6:e9:4c:81:72:eb WPA: pairwise key handshake completed (RSN)
Sat Dec 14 01:39:23 2024 daemon.notice hostapd: wl1-ap0: EAPOL-4WAY-HS-COMPLETED b6:e9:4c:81:72:eb
Sat Dec 14 01:39:24 2024 daemon.warn odhcpd[1566]: No default route present, overriding ra_lifetime!
Sat Dec 14 01:39:25 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.10) e0:dc:ff:08:d4:cd
Sat Dec 14 01:39:25 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.10) 192.168.1.16 e0:dc:ff:08:d4:cd
Sat Dec 14 01:39:25 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan.10) 192.168.1.16 b6:e9:4c:81:72:eb
Sat Dec 14 01:39:25 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan.10) 192.168.1.16 b6:e9:4c:81:72:eb Galaxy-A71-pol-zovatela-Igor
Sat Dec 14 01:39:25 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan.10) 192.168.1.16 b6:e9:4c:81:72:eb
Sat Dec 14 01:39:25 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan.10) 192.168.1.16 b6:e9:4c:81:72:eb Galaxy-A71-pol-zovatela-Igor
Sat Dec 14 01:39:25 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan.10) 192.168.1.16 e0:dc:ff:08:d4:cd
Sat Dec 14 01:39:25 2024 daemon.info dnsmasq-dhcp[1]: DHCPNAK(br-lan.10) 192.168.1.16 e0:dc:ff:08:d4:cd address in use
Sat Dec 14 01:39:29 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.10) e0:dc:ff:08:d4:cd
Sat Dec 14 01:39:29 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.10) 192.168.1.18 e0:dc:ff:08:d4:cd
Sat Dec 14 01:39:29 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan.10) 192.168.1.18 e0:dc:ff:08:d4:cd
Sat Dec 14 01:39:29 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan.10) 192.168.1.18 e0:dc:ff:08:d4:cd RedmiNote7-RedmiNote
Sat Dec 14 01:39:34 2024 daemon.info dnsmasq-dhcp[1]: DHCPRELEASE(br-lan.10) 192.168.1.10 50:ec:50:0b:60:03
Sat Dec 14 01:39:38 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.10) 192.168.1.10 50:ec:50:0b:60:03
Sat Dec 14 01:39:38 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.10) 192.168.1.10 50:ec:50:0b:60:03
Sat Dec 14 01:39:38 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.10) 192.168.1.10 50:ec:50:0b:60:03
Sat Dec 14 01:39:38 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.10) 192.168.1.10 50:ec:50:0b:60:03
Sat Dec 14 01:39:38 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan.10) 192.168.1.10 50:ec:50:0b:60:03
Sat Dec 14 01:39:38 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan.10) 192.168.1.10 50:ec:50:0b:60:03 rockrobo
Sat Dec 14 01:41:12 2024 kern.info kernel: [  174.303247] mt7530-mdio mdio-bus:00 lan3: Link is Up - 100Mbps/Full - flow control rx/tx
Sat Dec 14 01:41:12 2024 kern.info kernel: [  174.311458] br-lan: port 3(lan3) entered blocking state
Sat Dec 14 01:41:12 2024 kern.info kernel: [  174.316712] br-lan: port 3(lan3) entered forwarding state
Sat Dec 14 01:41:12 2024 daemon.notice netifd: Network device 'lan3' link is up
Sat Dec 14 01:41:19 2024 daemon.info hostapd: wl1-ap0: STA 50:da:d6:03:62:14 IEEE 802.11: authenticated
Sat Dec 14 01:41:19 2024 daemon.info hostapd: wl1-ap0: STA 50:da:d6:03:62:14 IEEE 802.11: associated (aid 5)
Sat Dec 14 01:41:19 2024 daemon.notice hostapd: wl1-ap0: AP-STA-CONNECTED 50:da:d6:03:62:14 auth_alg=sae
Sat Dec 14 01:41:19 2024 daemon.info hostapd: wl1-ap0: STA 50:da:d6:03:62:14 WPA: pairwise key handshake completed (RSN)
Sat Dec 14 01:41:19 2024 daemon.notice hostapd: wl1-ap0: EAPOL-4WAY-HS-COMPLETED 50:da:d6:03:62:14
Sat Dec 14 01:41:19 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan.10) 192.168.1.18 50:da:d6:03:62:14
Sat Dec 14 01:41:19 2024 daemon.info dnsmasq-dhcp[1]: DHCPNAK(br-lan.10) 192.168.1.18 50:da:d6:03:62:14 address in use
Sat Dec 14 01:41:20 2024 daemon.warn odhcpd[1566]: No default route present, overriding ra_lifetime!
Sat Dec 14 01:41:23 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.10) 50:da:d6:03:62:14
Sat Dec 14 01:41:23 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.10) 192.168.1.19 50:da:d6:03:62:14
Sat Dec 14 01:41:23 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.10) 50:da:d6:03:62:14
Sat Dec 14 01:41:23 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.10) 192.168.1.19 50:da:d6:03:62:14
Sat Dec 14 01:41:23 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.10) 50:da:d6:03:62:14
Sat Dec 14 01:41:23 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.10) 192.168.1.19 50:da:d6:03:62:14
Sat Dec 14 01:41:23 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan.10) 192.168.1.19 50:da:d6:03:62:14
Sat Dec 14 01:41:23 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan.10) 192.168.1.19 50:da:d6:03:62:14 Xiaomi-11-Lite-5G-NE
Sat Dec 14 01:42:07 2024 daemon.info hostapd: wl1-ap0: STA ea:ad:bf:bd:c7:0c IEEE 802.11: authenticated
Sat Dec 14 01:42:08 2024 daemon.info hostapd: wl1-ap0: STA ea:ad:bf:bd:c7:0c IEEE 802.11: associated (aid 6)
Sat Dec 14 01:42:08 2024 daemon.notice hostapd: wl1-ap0: AP-STA-CONNECTED ea:ad:bf:bd:c7:0c auth_alg=sae
Sat Dec 14 01:42:08 2024 daemon.info hostapd: wl1-ap0: STA ea:ad:bf:bd:c7:0c WPA: pairwise key handshake completed (RSN)
Sat Dec 14 01:42:08 2024 daemon.notice hostapd: wl1-ap0: EAPOL-4WAY-HS-COMPLETED ea:ad:bf:bd:c7:0c
Sat Dec 14 01:42:08 2024 daemon.warn odhcpd[1566]: No default route present, overriding ra_lifetime!
Sat Dec 14 01:42:12 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.10) ea:ad:bf:bd:c7:0c
Sat Dec 14 01:42:12 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.10) 192.168.1.20 ea:ad:bf:bd:c7:0c
Sat Dec 14 01:42:12 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan.10) 192.168.1.16 ea:ad:bf:bd:c7:0c
Sat Dec 14 01:42:12 2024 daemon.info dnsmasq-dhcp[1]: DHCPNAK(br-lan.10) 192.168.1.16 ea:ad:bf:bd:c7:0c address in use
Sat Dec 14 01:42:12 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan.10) 192.168.1.16 ea:ad:bf:bd:c7:0c
Sat Dec 14 01:42:12 2024 daemon.info dnsmasq-dhcp[1]: DHCPNAK(br-lan.10) 192.168.1.16 ea:ad:bf:bd:c7:0c address in use
Sat Dec 14 01:42:12 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan.10) 192.168.1.16 ea:ad:bf:bd:c7:0c
Sat Dec 14 01:42:12 2024 daemon.info dnsmasq-dhcp[1]: DHCPNAK(br-lan.10) 192.168.1.16 ea:ad:bf:bd:c7:0c address in use
Sat Dec 14 01:42:12 2024 daemon.warn odhcpd[1566]: No default route present, overriding ra_lifetime!
Sat Dec 14 01:42:12 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.10) ea:ad:bf:bd:c7:0c
Sat Dec 14 01:42:12 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.10) 192.168.1.20 ea:ad:bf:bd:c7:0c
Sat Dec 14 01:42:13 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan.10) 192.168.1.20 ea:ad:bf:bd:c7:0c
Sat Dec 14 01:42:13 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan.10) 192.168.1.20 ea:ad:bf:bd:c7:0c
Sat Dec 14 01:42:16 2024 daemon.warn odhcpd[1566]: No default route present, overriding ra_lifetime!
Sat Dec 14 01:45:37 2024 daemon.info hostapd: wl1-ap0: STA aa:c9:21:07:a8:9f IEEE 802.11: associated (aid 7)
Sat Dec 14 01:45:37 2024 daemon.notice hostapd: wl0-ap0: Prune association for aa:c9:21:07:a8:9f
Sat Dec 14 01:45:37 2024 daemon.notice hostapd: wl0-ap0: AP-STA-DISCONNECTED aa:c9:21:07:a8:9f
Sat Dec 14 01:45:38 2024 daemon.notice hostapd: wl1-ap0: AP-STA-CONNECTED aa:c9:21:07:a8:9f auth_alg=sae
Sat Dec 14 01:45:38 2024 daemon.info hostapd: wl1-ap0: STA aa:c9:21:07:a8:9f WPA: pairwise key handshake completed (RSN)
Sat Dec 14 01:45:38 2024 daemon.notice hostapd: wl1-ap0: EAPOL-4WAY-HS-COMPLETED aa:c9:21:07:a8:9f
Sat Dec 14 01:45:42 2024 daemon.warn odhcpd[1566]: No default route present, overriding ra_lifetime!
Sat Dec 14 01:46:07 2024 daemon.info hostapd: wl0-ap0: STA aa:c9:21:07:a8:9f IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Sat Dec 14 01:46:24 2024 daemon.err uhttpd[1687]: [info] luci: accepted login on / for root from 192.168.1.11

And here is modified network file itself


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fda3:0e1c:5d68::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'wan'

config interface 'lan'
	option device 'br-lan.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'wan'
	option macaddr 'd4:da:21:1c:ae:e0'

config interface 'wan'
	option device 'br-lan.10'
	option proto 'pppoe'
	option username '***'
	option password ***'
	option ipv6 'auto'

config interface 'iptv'
	option proto 'none'
	option device 'br-lan.20'

You are missing the bridge-vlans:

Oh, Thx, my bad, i modified them first and then completly delete them as old lines.
Now my main router works, so i will try to setup old one.
Its definetly old, my ISP give it to my around 10 years ago and then replaced it. Its only serves as bridge to my main iptv and backup iptv(from isp) in my bedroom. So i think i can use it as kinda managed switch

1 Like