Vlan tagged dhcp no

Hello good afternoon, I have several days trying a configuration and nothing.
My network is as follows: A main router Cisco Rev340W with the Native VLAN 1 IP 172.17.0.1 I also have another VLAN 10 IP 172.20.10.1 Labeling, I also have an Openwrt WRT190ACS router, its IP 172.17.0.5 I have it connected LAN to LAN , in this router and created another Wi -Fi network for VLAN 10 and in this is where it gives me the error that customers do not connect, the LAN network without labeling no problem is only in VLAN, can they help me?

NETWORK

	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdf3:ab93:38ee::/48'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '172.17.0.5'
	option gateway '172.17.0.1'
	list dns '172.17.0.1'

config device
	option name 'wan'
	option macaddr 'XX:XX:XX.XX:XX:XX'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'
	option auto '0'

config device
	option name 'br-lan.999'
	option type 'bridge'
	option macaddr 'XX:XX:XX.XX:XX:XX'
	list ports 'eth0'

config interface 'vlan999'
	option proto 'static'
	option ipaddr '192.168.254.5'
	option netmask '255.255.255.0'
	option gateway '192.168.254.1'
	option device 'br-lan.999'


This is incorrectly formed, but it would be for VLAN 999. It doesn't match your description of using VLAN 10 at all.

Where is the connectivity issue -- is it PC2? Is PC2 connected by ethernet or wifi? How is OpenWrt involved here? It seems like you have some sort of wireless link between the AP and the switch based on your diagram... if that's not the case, please clarify.

If you are right , This is the configuration:


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdf3:ab93:38ee::/48'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '172.17.0.5'
	option gateway '172.17.0.1'
	list dns '172.17.0.1'

config device
	option name 'wan'
	option macaddr 'XX:XX:XX.XX:XX:XX'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'
	option auto '0'

config device
	option name 'br-lan.10'
	option type 'bridge'
	option macaddr 'XX:XX:XX.XX:XX:XX'
	list ports 'eth0'

config interface 'vlan10'
	option proto 'static'
	option ipaddr '172.20.10.5'
	option netmask '255.255.255.0'
	option gateway '172.20.10.1'
	option device 'br-lan.10'
The clients with whom I have the problem are Wi -Fi customers, who connect in the AP in the VLAN 10.
In the VLAN 1 no or problem

Ok... so this is still formed incorrectly, and actually does not need an address...

It should look like this (assuming that the connection is to port lan1):

config bridge-vlan
	option device 'br-lan'
	option vlan '10'
	list ports 'lan1:t'

config interface 'vlan10'
	option proto 'none'
	option device 'br-lan.10'

The modified, but still does not connect the log:

Thu Mar 30 20:15:30 2023 daemon.info hostapd: wlan1-1: STA ac:d6:18:44:46:1e IEEE 802.11: authenticated
Thu Mar 30 20:15:30 2023 daemon.info hostapd: wlan1-1: STA ac:d6:18:44:46:1e IEEE 802.11: associated (aid 1)
Thu Mar 30 20:15:31 2023 daemon.notice hostapd: wlan1-1: AP-STA-CONNECTED ac:d6:18:44:46:1e
Thu Mar 30 20:15:31 2023 daemon.info hostapd: wlan1-1: STA ac:d6:18:44:46:1e WPA: pairwise key handshake completed (RSN)
Thu Mar 30 20:15:31 2023 daemon.notice hostapd: wlan1-1: EAPOL-4WAY-HS-COMPLETED ac:d6:18:44:46:1e
Thu Mar 30 20:15:49 2023 daemon.notice hostapd: wlan1-1: AP-STA-DISCONNECTED ac:d6:18:44:46:1e
Thu Mar 30 20:15:51 2023 daemon.info hostapd: wlan1-1: STA ac:d6:18:44:46:1e IEEE 802.11: authenticated
Thu Mar 30 20:15:51 2023 daemon.info hostapd: wlan1-1: STA ac:d6:18:44:46:1e IEEE 802.11: associated (aid 1)
Thu Mar 30 20:15:51 2023 daemon.notice hostapd: wlan1-1: AP-STA-CONNECTED ac:d6:18:44:46:1e
Thu Mar 30 20:15:51 2023 daemon.info hostapd: wlan1-1: STA ac:d6:18:44:46:1e WPA: pairwise key handshake completed (RSN)
Thu Mar 30 20:15:51 2023 daemon.notice hostapd: wlan1-1: EAPOL-4WAY-HS-COMPLETED ac:d6:18:44:46:1e
Thu Mar 30 20:16:09 2023 daemon.notice hostapd: wlan1-1: AP-STA-DISCONNECTED ac:d6:18:44:46:1e
Thu Mar 30 20:17:02 2023 daemon.info hostapd: wlan1-1: STA ac:d6:18:44:46:1e IEEE 802.11: authenticated
Thu Mar 30 20:17:02 2023 daemon.info hostapd: wlan1-1: STA ac:d6:18:44:46:1e IEEE 802.11: associated (aid 1)
Thu Mar 30 20:17:03 2023 daemon.notice hostapd: wlan1-1: AP-STA-CONNECTED ac:d6:18:44:46:1e
Thu Mar 30 20:17:03 2023 daemon.info hostapd: wlan1-1: STA ac:d6:18:44:46:1e WPA: pairwise key handshake completed (RSN)
Thu Mar 30 20:17:03 2023 daemon.notice hostapd: wlan1-1: EAPOL-4WAY-HS-COMPLETED ac:d6:18:44:46:1e
Thu Mar 30 20:17:21 2023 daemon.notice hostapd: wlan1-1: AP-STA-DISCONNECTED ac:d6:18:44:46:1e
Thu Mar 30 20:17:22 2023 daemon.info hostapd: wlan1-1: STA ac:d6:18:44:46:1e IEEE 802.11: authenticated
Thu Mar 30 20:17:23 2023 daemon.info hostapd: wlan1-1: STA ac:d6:18:44:46:1e IEEE 802.11: associated (aid 1)
Thu Mar 30 20:17:23 2023 daemon.notice hostapd: wlan1-1: AP-STA-CONNECTED ac:d6:18:44:46:1e
Thu Mar 30 20:17:23 2023 daemon.info hostapd: wlan1-1: STA ac:d6:18:44:46:1e WPA: pairwise key handshake completed (RSN)
Thu Mar 30 20:17:23 2023 daemon.notice hostapd: wlan1-1: EAPOL-4WAY-HS-COMPLETED ac:d6:18:44:46:1e
Thu Mar 30 20:17:41 2023 daemon.notice hostapd: wlan1-1: AP-STA-DISCONNECTED ac:d6:18:44:46:1e
Thu Mar 30 20:17:43 2023 daemon.info hostapd: wlan1-1: STA ac:d6:18:44:46:1e IEEE 802.11: authenticated
Thu Mar 30 20:17:43 2023 daemon.info hostapd: wlan1-1: STA ac:d6:18:44:46:1e IEEE 802.11: associated (aid 1)
Thu Mar 30 20:17:43 2023 daemon.notice hostapd: wlan1-1: AP-STA-CONNECTED ac:d6:18:44:46:1e
Thu Mar 30 20:17:43 2023 daemon.info hostapd: wlan1-1: STA ac:d6:18:44:46:1e WPA: pairwise key handshake completed (RSN)
Thu Mar 30 20:17:43 2023 daemon.notice hostapd: wlan1-1: EAPOL-4WAY-HS-COMPLETED ac:d6:18:44:46:1e
Thu Mar 30 20:18:01 2023 daemon.notice hostapd: wlan1-1: AP-STA-DISCONNECTED ac:d6:18:44:46:1e
Thu Mar 30 20:18:13 2023 daemon.info hostapd: wlan1-1: STA ac:d6:18:44:46:1e IEEE 802.11: authenticated
Thu Mar 30 20:18:13 2023 daemon.info hostapd: wlan1-1: STA ac:d6:18:44:46:1e IEEE 802.11: associated (aid 1)
Thu Mar 30 20:18:13 2023 daemon.notice hostapd: wlan1-1: AP-STA-CONNECTED ac:d6:18:44:46:1e
Thu Mar 30 20:18:13 2023 daemon.info hostapd: wlan1-1: STA ac:d6:18:44:46:1e WPA: pairwise key handshake completed (RSN)
Thu Mar 30 20:18:13 2023 daemon.notice hostapd: wlan1-1: EAPOL-4WAY-HS-COMPLETED ac:d6:18:44:46:1e
Thu Mar 30 20:18:31 2023 daemon.notice hostapd: wlan1-1: AP-STA-DISCONNECTED ac:d6:18:44:46:1e
Thu Mar 30 20:18:33 2023 daemon.info hostapd: wlan1-1: STA ac:d6:18:44:46:1e IEEE 802.11: authenticated
Thu Mar 30 20:18:33 2023 daemon.info hostapd: wlan1-1: STA ac:d6:18:44:46:1e IEEE 802.11: associated (aid 1)
Thu Mar 30 20:18:33 2023 daemon.notice hostapd: wlan1-1: AP-STA-CONNECTED ac:d6:18:44:46:1e
Thu Mar 30 20:18:33 2023 daemon.info hostapd: wlan1-1: STA ac:d6:18:44:46:1e WPA: pairwise key handshake completed (RSN)
Thu Mar 30 20:18:33 2023 daemon.notice hostapd: wlan1-1: EAPOL-4WAY-HS-COMPLETED ac:d6:18:44:46:1e
Thu Mar 30 20:18:51 2023 daemon.notice hostapd: wlan1-1: AP-STA-DISCONNECTED ac:d6:18:44:46:1e


Let's take a look at the wireless configuration (/etc/config/wireless).

Have you verified that the main router is providing DHCP services on VLAN 10 as expected (via wired connection, for example)?

If I have it here now I am trying with VLAN 999


config wifi-device 'radio0'
	option type 'mac80211'
	option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
	option channel '36'
	option band '5g'
	option htmode 'VHT80'
	option country 'ES'
	option cell_density '0'
	option disabled '1'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option macaddr 'XX:XX:XX.XX:XX:XX'
	option disabled '1'
	option ssid 'OpenWrt-5.0Ghz'
	option encryption 'psk2'
	option key 'contraseña'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option country 'ES'
	option cell_density '0'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option macaddr 'XX:XX:XX.XX:XX:XX'
	option encryption 'psk2'
	option key 'contraseña'
	option ssid 'OpenWrt-2.4-Ghz'

config wifi-iface 'wifinet2'
	option device 'radio0'
	option mode 'ap'
	option ssid 'OpenWrt-5.0Ghz'
	option encryption 'psk2'
	option key 'contraseña'
	option disabled '1'
	option network 'vlan999'

config wifi-iface 'wifinet3'
	option device 'radio1'
	option mode 'ap'
	option ssid 'OpenWrt-2.4-Ghz-test'
	option encryption 'psk2'
	option key 'contraseña'
	option network 'vlan999'

If all the VLANs get to the switch, and if I assign it to any port of the commuter, the IP assigns me well

Router main Vlan:


Switch:

The problem is in the VLAN 10 to be labeled does not connect and the IP does not assign me
Connexion between router is Lan to Lan remembers
Sorry for my English but I'm Spanish

Router Openwrt :



Why? VLAN 999 isn't the one you're trying to use, is it?? You talked about VLAN 10, not VLAN 999.

The main router shows DHCP disabled on all networks. Do you have another DHCP server?

I think you need a bridge-vlan for each network, and no connections directly to the underlying br-lan.

Create another bridge-vlan numbered 1 and include all the lan ports in it (untagged) and change the lan network device to br-lan.1.

This combines tagged and untagged packets on port lan1, which isn't a best practice it would be better to set the switch to also send lan packets tagged 1 and change lan1's assignment into bridge-vlan 1 to tagged.

IPV4 is activated in all the networks looks at the photo of the commuter as all the VLANs with activated DHCP arrive

Ah... ok. My mistake.

Side note...With respect to the switch, normally you only setup a management interface in the network(s) that are trusted for that purpose. Typically that is either your main lan or a dedicated management network. You should not have addresses on all networks if those networks are not intended to have access to the switch itself (for management/admin purposes).

Back to the issue at hand... your diagram shows a connection scheme like this:
router > AP (OpenWrt) > switch

Is that correct?? If not, what is the connection order, and what physical ports are being used on each device.

Thank you very much for everything, this is my connection diagram and the failure

Are you certain that all of your VLANs are actually working on the switch? And are you certain your diagram is accurate relative to your phyiscal topology?

This seems improbable gien your current configuration, unless you've redacted details of your OpenWrt configuration.

This is my network connection diagram or typology as you want to call it.

If the VLANs are working, where you do not work is in the AP Openwrt and the VLAN 999 that is not native and tagged.
An example of working:

And the SWITCH ARP

Sorry, maybe I wasn't clear.

Your diagram shows the main router port 1 > AP port 1 > AP port 4 > switch port 1.
Based on the OpenWrt configuration you have shared, the VLANs on the switch (10, 11, 100, 999) should not work if the physical connections are as you have shown.

Please verify the physical connections -- I would think that the main router actually connects directly to the switch, and then the switch to the AP.

Ok, according to the tutorial that is followed by the AP Openwrt router, it will behave like a switch, so it is connected to LAN and not to Wan

This is the link

And that's why all VLANs arrive in the switch without configuring anything

Yes, I understand the dumb AP configuration, and yes that should connect to the lan port.

But I'm asking that you verify that the wiring itself (as in tracing the physical wires to check the accuracy of your diagram). I suspect that the main router connects directly to the switch (and not directly to the AP). The VLANs should not pass through the dumb AP based on the current configuration.

I don't know if you can appreciate it in the photo, but it is proven and everything is connected as the draw ok
The orange cable with the RJ45 in black is correct

Ok. Thank you for verifying.

Something is quite unusual in your config. The VLANs passing through the ap should not be possible given the config.

I’d recommend resetting your openwrt system to defaults and then we can get it configured properly.

1 Like

Ok thank you very much, and state by reviewing all the cables and checking.
And I return to the state of the AP router, I connect it again and I am on the same scenario as when we incede.
All the best.