VLAN on r7800 tagged or untagged on eth1

Somehow, the VLAN thing with a LAN and Wifi bridge has changed somehow during the last few releases.
But I don't want to open this book.

As of now, there is one thing I am extremely wondering about.
The config as described here is not working for me.

As soon as I set eth1 for the VLAN 1 to tagged, nothing works anymore. All ports are without connection.

What works for me is shown here:

Is this how it is supposed to be?

I might need to mention, that the VLAN 9 is in the Device br-guest, and that there is a separate Wifi with separate subnet assigned to the Interface GUEST as of now.

Interface

Cheers, Frood

If the interface associated with VLAN1 is set as eth1 (as compared to eth1.1), your experience makes sense. When an interface is setup without the ".x", it is treating that as untagged. If it has the ".x" it will look for a tagged network.

what's in your /etc/config/network file?

I do not fully understand, but if it makes sense, ok.
the sample over here is also without .x

config interface 'lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option device 'br-lan'

config interface 'wan'
        option proto 'dhcp'
        option peerdns '0'
        list dns '127.0.0.1'
        option device 'eth0'

config interface 'wan6'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'auto'
        option peerdns '0'
        list dns '0::1'
        option device 'eth0'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '1 2 3 6'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option vid '2'
        option ports '0 5'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option ports '4 6t'
        option vid '9'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth1'

config device 'guest_dev'
        option type 'bridge'
        option name 'br-guest'
        list ports 'eth1.9'

config interface 'guest'
        option proto 'static'
        option device 'br-guest'
        option netmask '255.255.255.0'
        option ipaddr '192.168.5.1'


The br-lan bridge device is setup with port "eth1", therefore the CPU should be untagged for VLAN1.

If, on the other hand, it said:

then it would expect the CPU to be tagged. You can try it yourself -- change the bridge to eth1.1 and change the switch configuration to tagged on the CPU -- it will continue to work. But if you do either one individually, it will fail.

eth0 and eth1 is somehow created automatically. In Luci, it cannot be changed, right?
you mean to change it in /etc/config/network ?

Changing them in LuCI may be tricky (it may require a few extra steps), but you could change it directly in the file (or using UCI commands). However, there is no real reason to do so unless you have a specific purpose for the change.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.