VLAN on "Alice Gate VoIP 2 Plus WiFi"

Powered by LuCI openwrt-22.03 branch (git-24.067.02332-4c1ddfb) / OpenWrt 22.03.7 r20341-591b7e93d3

VLAN on "Alice Gate VoIP 2 Plus WiFi"

Hi, I'm new on this forum and using OpenWRT too.
I'm trying to configure 3 VLAN:

  • personal (192.168.10.0)
  • guests (192.168.20.0)
  • IPCamera (192.168.30.0)
    any VLAN should not browse on each other.

My router has 4 ethernet port and wifi, but seems that ethernet ports are on same physical interface [eth1]
(probably there are not ASICS on each port, only one ASICS for all, just my suppose).

I suppose that the device is not configurable for manager layer-3 switching, bare I hope I'm wrong

I successfully created VLAN on switch page, but creating a new device and a new interface, I can't ping the interface IP.
(I can't obtain IP setting DHCP Server for interface too).

Any suggest? Thanks

This is the default configuration file:

config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd34:52b8:c15e::/48'

config device
option name 'br-lan'
option type 'bridge'
list ports 'eth1'

config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'

config interface 'wan'
option device 'eth0'
option proto 'dhcp'

config interface 'wan6'
option device 'eth0'
option proto 'dhcpv6'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0 3 5'

config switch_vlan
option device 'switch0'
option ports '1 2'
option vlan '2'

This is my last test:

config interface 'loopback'
  option device 'lo'
  option proto 'static'
  option ipaddr '127.0.0.1'
  option netmask '255.0.0.0'

config globals 'globals'
  option ula_prefix 'fd34:52b8:c15e::/48'

config device
  option name 'br-lan'
  option type 'bridge'
  list ports 'eth1'

config interface 'lan'
  option device 'br-lan'
  option proto 'static'
  option ipaddr '192.168.1.1'
  option netmask '255.255.255.0'
  option ip6assign '60'

config interface 'wan'
  option device 'eth0'
  option proto 'dhcp'

config interface 'wan6'
  option device 'eth0'
  option proto 'dhcpv6'

config switch
  option name 'switch0'
  option reset '1'
  option enable_vlan '1'

config switch_vlan
  option device 'switch0'
  option vlan '1'
  option ports '0t 3 5'

config switch_vlan
  option device 'switch0'
  option vlan '2'
  option ports '0t 1 2'

config device
  option type '8021q'
  option ifname 'eth1'
  option vid '10'
  option name 'eth1.10'

config device
  option type '8021q'
  option ifname 'eth1'
  option vid '20'
  option name 'eth1.20'

config interface 'vlan10'
  option proto 'static'
  option device 'eth1.10'
  option ipaddr '192.168.10.1'
  option netmask '255.255.255.0'

config interface 'vlan20'
  option proto 'static'
  option device 'eth1.20'
  option ipaddr '192.168.20.1'
  option netmask '255.255.255.0'

ssh ip link:

root@OpenWrt:~# ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN qlen 1000
    link/ether 02:10:18:01:00:01 brd ff:ff:ff:ff:ff:ff
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel master br-lan state UP qlen 1000
    link/ether 02:10:18:01:00:02 brd ff:ff:ff:ff:ff:ff
4: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 00:23:8e:5c:db:5c brd ff:ff:ff:ff:ff:ff
5: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 02:10:18:01:00:02 brd ff:ff:ff:ff:ff:ff
6: eth1.10@eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 02:10:18:01:00:02 brd ff:ff:ff:ff:ff:ff
7: eth1.20@eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 02:10:18:01:00:02 brd ff:ff:ff:ff:ff:ff

Are you using tagged frames on the lan host that you try to ping?
There doesn't seem to be any binding of physical port with the vlans you created. You only have vlans 1 and 2 untagged on ports 3, 5 and 1,2 respectively.