VLAN MR8300 - can't separate eth0 and eth1

I'm using OpenWrt 22.03.0 r19685-512e76967f with Linksys MR8300 router. I want to setup VLANs but looks that I can't separate eth0 and eth1 (if I configure either to be different from the other, it sets itself back to be the same). Here are the default settings.

How should I set up the VLANs (preferably via Luci)?
I want to have LAN, GUEST, IOT networks with internet connection (on my router with firewall separation everything works fine, but want it with VLAN as planning a second AP later)?

Thanks in advance

You cannot have two networks untagged on any physical interface -- that includes the CPU. Notice that you have eth0 and eth1 set for untagged for both VLAN 1 and VLAN 2. One (or ideally both) of those networks must be tagged for it to work.

What are you trying to achieve? We can advise/guide you through the process if we know the goal.

1 Like

Press the add vlan in the bottom corner.
Let them stay tagged on the cpu parameter.

This is my default setup and it works (I didn't change it since the install).
I'd like to have one vlan for lan, second for iot, third guest. then I can use these vlan ids from second ap to refer to (I plan mesh tunnel between router and ap). for now the router setup would be the plan to link all router ports to lan. The other vlans won't be router physical ports, but ports to link zones to vlans.

Is this the main router, or do you have another router upstream? If there is a router upstream, do the VLANs already exist there?

that's the main router linked to internet via WAN.

Sorry... I'm not understanding what you mean...

Are you saying that this device (MR8300) is the main router and is using the WAN port to connect to the internet?

Or are you saying that there is another router upstream of the 8300, and that the connection between the upstream router connects to the MR8300 via the 8300's wan port?

Feel free to draw a diagram if that might be more clear.

Sorry for the confusion. MR8300 is the main router connecting to internet via WAN.
I want to set-up the vlans on this router only (yet).
This router will be tunneled with another ap via mesh. this router's vlan ids will be used as aliases from the access point.

Ok... so typically the WAN is connected to one of the CPU ports (eth0 or eth1) and that often is the only thing that connects to that CPU port. The LAN(s) connect to the other CPU port.

To create new VLANs, you'll want to start with the default config then add a VLAN. Set the VLAN as tagged on the CPU used for the LAN, and then you can set the ethernet ports appropriately (either off or tagged; if you want it to be untagged on a port, you must change the existing LAN to be tagged or off on that port).

This is my WAN interface

even if these are the connections, I can't change CPU ports independently at VLAN settings, as these reset themselves to each other...
I use bridging interface for lan with eth0

You should leave your WAN alone.

You'll be creating a new VLAN that will be connected to the CPU used for the LAN. Do this is the switch page you showed earlier.

I didn't change my WLAN interface vs default (edit - WAN instead of WLAN here!).
My problem is that once I add vlans, I must set-up eth0 and eth1 and these will be the same...
I've already re-started the settings from zero, as couldn't finish correctly.

We weren't talking about WLAN. You showed a screenshot of your WAN.

yes, the WAN. I didn't change a thing there.

Leave the WAN alone. Why are you trying to change it?

Go to the switch page.... click add VLAN, then assign that to ett0 as a tagged interface. This will create eth0.x where x is the VLAN ID.

so add new VLAN, then link it to eth0, all ports can be tagged (except WAN and eth1), right?

yes, if that is your goal in terms of physical connectivity on the ethernet ports.

can't add vlan, even if I click on it many times... :frowning:

Maybe you messed something up... let's see your screen.

I made the changes, now I can add vlans (did it), but can't set eth1 different to eth0 in any of the lines within eth1 (CPU) column.
this is how it looks now