Vlan for wan TP-Link TL-WR941N/ND v6 HELP!

Hi all! this is my first post, i need to configure this setting for my provvider on my tl-wr941 OpenWrt 18.06.1:

  1. Creare la vlan 835 on the wan interface
  2. config wan with 192.168.200.6/30 gw 192.168.200.5
  3. Config loopback ip with my public ip assigned x.x.x.x/32
    this is my conf:
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd22:36e9:cddd::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth0'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 1 2 3 4'
        option vid '1'

Help please!
sorry for the english

config interface 'wan_tagged' #tagged but not working
        option proto 'static'
        option ifname 'eth0.10'
        option ipaddr '10.0.0.1'
        option netmask '255.255.255.254'
        option gateway '10.0.0.2'

(Last edited by penim on 3 Nov 2015, 06:32)

To tag with ID 835, you would use eth0.835. Why does your latest example use IP addresses of 10 instead of 192.168.200.X ?

config interface wan
    option ifname 'eth0.835'
    option proto static
    option ipaddr '192.168.200.6/30'
    option gateway '192.168.200.5'
    option dns '192.168.200.5'  # Or ISP's designated DNS, or a public DNS

Comment out or remove the wan6 part, as your ISP does not support IPv6.
(It is not necessary to change the switch configuration, since on this model router eth0 goes directly to the blue WAN Ethernet port, bypassing the switch.)

thank you, a mistake...